summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-01-13 01:28:14 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-01-13 01:28:14 +0000
commit3879a1fd579cebd69071957215aa599e2a58515c (patch)
tree611fd95df7f1fece74d4e63c05c6c5a84665fa4d /www-apps/dspam-web
parentAdd patch from upstream to fix newer slab version #77301 by regala. (diff)
downloadhistorical-3879a1fd579cebd69071957215aa599e2a58515c.tar.gz
historical-3879a1fd579cebd69071957215aa599e2a58515c.tar.bz2
historical-3879a1fd579cebd69071957215aa599e2a58515c.zip
Version bump
Diffstat (limited to 'www-apps/dspam-web')
-rw-r--r--www-apps/dspam-web/ChangeLog5
-rw-r--r--www-apps/dspam-web/Manifest4
-rw-r--r--www-apps/dspam-web/dspam-web-3.3.11.ebuild165
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.3.111
4 files changed, 173 insertions, 2 deletions
diff --git a/www-apps/dspam-web/ChangeLog b/www-apps/dspam-web/ChangeLog
index ef12b2800d4d..f3c06dcbee3d 100644
--- a/www-apps/dspam-web/ChangeLog
+++ b/www-apps/dspam-web/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apps/dspam-web
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.10 2005/01/05 01:11:53 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.11 2005/01/13 01:28:14 st_lim Exp $
+
+ 13 Jan 2005; Lim Swee Tat <st_lim@gentoo.org> :
+ Version bump
05 Jan 2005; Lim Swee Tat <st_lim@gentoo.org> :
Fixed URL for dspam
diff --git a/www-apps/dspam-web/Manifest b/www-apps/dspam-web/Manifest
index 2f3fed9a37d9..d4e8ddbb9ca4 100644
--- a/www-apps/dspam-web/Manifest
+++ b/www-apps/dspam-web/Manifest
@@ -1,7 +1,9 @@
-MD5 0f3b71b132bf69e7f260228f1fadd5d9 ChangeLog 2001
+MD5 250e5ab10d8bbdb3e9fe633c54c4218c ChangeLog 2067
MD5 200f508058004a98dd2c61761111d363 dspam-web-3.2.4.ebuild 5213
+MD5 eea596b9eaa407d76728fa286cab6548 dspam-web-3.3.11.ebuild 4970
MD5 02b8d404199d28d7c1c185280ced86a8 dspam-web-3.3.8.ebuild 5213
MD5 f1ea445d6b4ddf81c55a4e886bc04218 metadata.xml 341
+MD5 b59703cc943f7df3ca77763cc47c59f9 files/digest-dspam-web-3.3.11 64
MD5 ffdfc8d816078f4c58b75b9bed07503f files/htaccess 135
MD5 b4099a94a52af9abd4ade48d82914c3c files/htpasswd 19
MD5 ea56d34fd80be48f9b308655b5620c2f files/digest-dspam-web-3.2.4 63
diff --git a/www-apps/dspam-web/dspam-web-3.3.11.ebuild b/www-apps/dspam-web/dspam-web-3.3.11.ebuild
new file mode 100644
index 000000000000..778bdc96cd97
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.3.11.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.3.11.ebuild,v 1.1 2005/01/13 01:28:14 st_lim Exp $
+
+inherit webapp eutils
+
+MY_PN=${PN/-web/}
+MY_PV=${PV/_rc3/.pr1}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
+
+HOMEPAGE="http://dspam.nuclearelephant.com/"
+LICENSE="GPL-2"
+DEPEND=">=mail-filter/dspam-3.2_rc3
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86 ~ppc"
+S=${WORKDIR}/${MY_P}
+HOMEDIR=/etc/mail/dspam
+
+src_compile() {
+ local myconf
+
+ # these are the default settings
+ myconf="${myconf} --enable-daemon"
+ #myconf="${myconf} --enable-nodalcore"
+ myconf="${myconf} --enable-homedir"
+ myconf="${myconf} --enable-long-username"
+ myconf="${myconf} --enable-robinson"
+ #myconf="${myconf} --enable-chi-square"
+ #myconf="${myconf} --enable-robinson-pvalues"
+ use large-domain && myconf="${myconf} --enable-large-scale" ||\
+ myconf="${myconf} --enable-domain-scale"
+
+ myconf="${myconf} --with-dspam-mode=4755"
+ myconf="${myconf} --with-dspam-owner=dspam"
+ myconf="${myconf} --with-dspam-group=dspam"
+ myconf="${myconf} --with-dspam-home=${HOMEDIR} --sysconfdir=${HOMEDIR}"
+ myconf="${myconf} --with-logdir=${LOGDIR}"
+
+ use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
+
+ # select storage driver
+ if use mysql || use mysql41; then
+ myconf="${myconf} --with-storage-driver=mysql_drv"
+ myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
+ myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
+ myconf="${myconf} --with-client-compression"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use postgres ; then
+ myconf="${myconf} --with-storage-driver=pgsql_drv"
+ myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
+ myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use oci8 ; then
+ myconf="${myconf} --with-storage-driver=ora_drv"
+ myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # I am in no way a Oracle specialist. If someone knows
+ # how to query the version of Oracle, then let me know.
+ if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1)
+ then
+ --with-oracle-version=MAJOR
+ myconf="${myconf} --with-oracle-version=10"
+ fi
+ elif use sqlite ; then
+ myconf="${myconf} --with-storage-driver=sqlite_drv"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ else
+ myconf="${myconf} --with-storage-driver=libdb4_drv"
+ fi
+
+ econf ${myconf} || die
+ cd ${S}/cgi
+ make
+}
+
+src_install () {
+ cd ${S}/cgi
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i dspam.cgi
+
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+ doins *.css
+ doins *.gif
+ doins rgb.txt
+ doins default.prefs
+ doins admins
+ doins configure.pl
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ insopts -m755 -o apache -g apache
+ doins *.cgi
+
+ for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
+ done
+
+ dodir ${MY_HTDOCSDIR}/templates
+
+ insinto ${MY_HTDOCSDIR}/templates
+ doins templates/*.html
+
+ #All files must be owned by server
+ cd ${D}${MY_HTDOCSDIR}
+ for x in `find . -type f -print` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.3.11 b/www-apps/dspam-web/files/digest-dspam-web-3.3.11
new file mode 100644
index 000000000000..2593420ae228
--- /dev/null
+++ b/www-apps/dspam-web/files/digest-dspam-web-3.3.11
@@ -0,0 +1 @@
+MD5 c459a4622b18862e85103a06110fdd3f dspam-3.3.11.tar.gz 657885