summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-12-09 00:56:17 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-12-09 00:56:17 +0000
commit381f937c1785719ff7420d5f5db641a677ad4943 (patch)
treec18ad2f73ba26d811112413597ba3fa3cb7f3450 /www-apps/dspam-web
parentbump (diff)
downloadhistorical-381f937c1785719ff7420d5f5db641a677ad4943.tar.gz
historical-381f937c1785719ff7420d5f5db641a677ad4943.tar.bz2
historical-381f937c1785719ff7420d5f5db641a677ad4943.zip
Version bump
Diffstat (limited to 'www-apps/dspam-web')
-rw-r--r--www-apps/dspam-web/ChangeLog5
-rw-r--r--www-apps/dspam-web/Manifest4
-rw-r--r--www-apps/dspam-web/dspam-web-3.2.3.ebuild169
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.2.31
4 files changed, 177 insertions, 2 deletions
diff --git a/www-apps/dspam-web/ChangeLog b/www-apps/dspam-web/ChangeLog
index fb3b176913ae..f0a644e31de9 100644
--- a/www-apps/dspam-web/ChangeLog
+++ b/www-apps/dspam-web/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apps/dspam-web
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.8 2004/11/18 11:17:49 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/ChangeLog,v 1.9 2004/12/09 00:56:17 st_lim Exp $
+
+ 09 Dec 2004; Lim Swee Tat <st_lim@gentoo.org> :
+ Version bump
*dspam-web-3.2.2 (18 Nov 2004)
diff --git a/www-apps/dspam-web/Manifest b/www-apps/dspam-web/Manifest
index 46ce68cf9763..a3436d93c97d 100644
--- a/www-apps/dspam-web/Manifest
+++ b/www-apps/dspam-web/Manifest
@@ -1,8 +1,9 @@
-MD5 19f394f3eeb1971a3560658bd5640dd8 ChangeLog 1681
+MD5 956f517d5b50fbf0de1c9cb6f508598b ChangeLog 1747
MD5 4692761753a5e1a98e276b526d94012e dspam-web-3.0.0.ebuild 2466
MD5 15fea5e0579a78f28af532687fef2dfb dspam-web-3.2.0.ebuild 5249
MD5 627c90d46d2502411088ed40ca694015 dspam-web-3.2.1.ebuild 5249
MD5 fcb07899c10e8e3662af241f6987bd6d dspam-web-3.2.2.ebuild 5249
+MD5 674e05a7965d9ec8aa276eea006fa863 dspam-web-3.2.3.ebuild 5249
MD5 f1ea445d6b4ddf81c55a4e886bc04218 metadata.xml 341
MD5 ffdfc8d816078f4c58b75b9bed07503f files/htaccess 135
MD5 b4099a94a52af9abd4ade48d82914c3c files/htpasswd 19
@@ -10,3 +11,4 @@ MD5 05dce5dc8cf516655657aa2a4cc5f1da files/digest-dspam-web-3.0.0 63
MD5 4b7bb6bbede742676e3e7017210104c5 files/digest-dspam-web-3.2.0 63
MD5 4d666bbdf8092d4bd49428ea31eadbfb files/digest-dspam-web-3.2.1 63
MD5 5e423ac033f04ebc7dcc1d61e77c34fa files/digest-dspam-web-3.2.2 63
+MD5 e8b69a8c4c9e136977f8b1485a914d18 files/digest-dspam-web-3.2.3 63
diff --git a/www-apps/dspam-web/dspam-web-3.2.3.ebuild b/www-apps/dspam-web/dspam-web-3.2.3.ebuild
new file mode 100644
index 000000000000..430d9a7f33fd
--- /dev/null
+++ b/www-apps/dspam-web/dspam-web-3.2.3.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.2.3.ebuild,v 1.1 2004/12/09 00:56:17 st_lim Exp $
+
+inherit webapp eutils
+
+MY_PN=${PN/-web/}
+MY_PV=${PV/_rc3/.pr1}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://www.nuclearelephant.com/projects/dspam/sources/${MY_P}.tar.gz"
+
+HOMEPAGE="http://www.nuclearelephant.com/projects/dspam/index.html"
+LICENSE="GPL-2"
+DEPEND=">=mail-filter/dspam-3.2_rc3
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86 ~ppc"
+S=${WORKDIR}/${MY_P}
+HOMEDIR=/etc/mail/dspam
+
+src_compile() {
+ local myconf
+
+ # these are the default settings
+ myconf="${myconf} --with-signature-life=14"
+ myconf="${myconf} --enable-broken-return-codes"
+ myconf="${myconf} --enable-experimental"
+ myconf="${myconf} --enable-long-username"
+ myconf="${myconf} --enable-robinson"
+ #myconf="${myconf} --enable-chi-square"
+ myconf="${myconf} --enable-robinson-pvalues"
+ #myconf="${myconf} --enable-broken-mta"
+ myconf="${myconf} --enable-large-scale"
+ #myconf="${myconf} --enable-domain-scale"
+
+ # ${HOMEDIR}/data is a symlink to ${DATADIR}
+ myconf="${myconf} --with-dspam-mode=4755"
+ myconf="${myconf} --with-dspam-owner=dspam"
+ myconf="${myconf} --with-dspam-group=dspam"
+ myconf="${myconf} --enable-homedir --with-dspam-home=${HOMEDIR} --sysconfdir=${HOMEDIR}"
+ myconf="${myconf} --with-logdir=/var/log/dspam"
+
+ # enables support for debugging (touch /etc/dspam/.debug to turn on)
+ # optional: even MORE debugging output, use with extreme caution!
+ use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
+
+ # select storage driver
+ if use mysql || use mysql41; then
+ myconf="${myconf} --with-storage-driver=mysql_drv"
+ myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
+ myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
+ myconf="${myconf} --with-client-compression"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use postgres ; then
+ myconf="${myconf} --with-storage-driver=pgsql_drv"
+ myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
+ myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # an experimental feature available with MySQL and PgSQL backend
+ if use neural ; then
+ myconf="${myconf} --enable-neural-networking"
+ fi
+ elif use oci8 ; then
+ myconf="${myconf} --with-storage-driver=ora_drv"
+ myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ # I am in no way a Oracle specialist. If someone knows
+ # how to query the version of Oracle, then let me know.
+ if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1)
+ then
+ --with-oracle-version=MAJOR
+ myconf="${myconf} --with-oracle-version=10"
+ fi
+ elif use sqlite ; then
+ myconf="${myconf} --with-storage-driver=sqlite_drv"
+ myconf="${myconf} --enable-virtual-users"
+ myconf="${myconf} --enable-preferences-extension"
+
+ else
+ myconf="${myconf} --with-storage-driver=libdb4_drv"
+ fi
+
+ econf ${myconf} || die
+ cd ${S}/cgi
+ make
+}
+
+src_install () {
+ cd ${S}/cgi
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i dspam.cgi
+
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+ doins *.css
+ doins *.gif
+ doins rgb.txt
+ doins default.prefs
+ doins admins
+ doins configure.pl
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ insopts -m755 -o apache -g apache
+ doins *.cgi
+
+ for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
+ done
+
+ dodir ${MY_HTDOCSDIR}/templates
+
+ insinto ${MY_HTDOCSDIR}/templates
+ doins templates/*.html
+
+ #All files must be owned by server
+ cd ${D}${MY_HTDOCSDIR}
+ for x in `find . -type f -print` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.2.3 b/www-apps/dspam-web/files/digest-dspam-web-3.2.3
new file mode 100644
index 000000000000..2337ef822d20
--- /dev/null
+++ b/www-apps/dspam-web/files/digest-dspam-web-3.2.3
@@ -0,0 +1 @@
+MD5 0c5d62df8746332906d487d5c5ad9926 dspam-3.2.3.tar.gz 620153