summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-04 20:33:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-04 20:33:13 +0000
commitf2c83b49bdd06c9516a35f96be96880d95fb3904 (patch)
tree27998ceaa05c0d8131ea3875b0a71ab7b7bb962a /www-apache/mod_dnssd/files
parentOne more minor cosmetic change.. (diff)
downloadhistorical-f2c83b49bdd06c9516a35f96be96880d95fb3904.tar.gz
historical-f2c83b49bdd06c9516a35f96be96880d95fb3904.tar.bz2
historical-f2c83b49bdd06c9516a35f96be96880d95fb3904.zip
Fix mod_dnssd-0.6-ldflags.patch to properly respect LDFLAGS (bug #266433).
Package-Manager: portage-13611-svn/cvs/Linux x86_64
Diffstat (limited to 'www-apache/mod_dnssd/files')
-rw-r--r--www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
index 55d15c55438e..699f2301f442 100644
--- a/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
+++ b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
@@ -1,21 +1,22 @@
---
Respect LDFLAGS and properly use LIBS to avoid missing symbols at runtime.
---- a/src/Makefile.in 2009-01-22 17:42:02.000000000 +0100
-+++ b/src/Makefile.in 2009-04-16 22:26:17.092709780 +0200
-@@ -16,13 +16,13 @@
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -16,13 +16,14 @@
APXS=@APXS@
APACHECTL=@APACHECTL@
-LIBS=-Wl,"@LIBS@" @AVAHI_LIBS@
+LIBS="@LIBS@" @AVAHI_LIBS@
CFLAGS=-Wc,"@CFLAGS@" @AVAHI_CFLAGS@
++APXS_LDFLAGS=`for ldflag in $(LDFLAGS); do echo -Wl,$$ldflag; done`
all: mod_dnssd.la
mod_dnssd.la: @srcdir@/mod_dnssd.c
- $(APXS) -c $(CFLAGS) $(LIBS) @srcdir@/mod_dnssd.c
-+ $(APXS) -c $(CFLAGS) -Wl,$(LDFLAGS) @srcdir@/mod_dnssd.c $(LIBS)
++ $(APXS) -c $(CFLAGS) $(APXS_LDFLAGS) @srcdir@/mod_dnssd.c $(LIBS)
install: all
$(APXS) -i -a mod_dnssd.la