summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-25 22:02:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-25 22:02:57 +0000
commit3d2b2c48c8b517e74802f3f2d7df40d0c00fdbe6 (patch)
tree9a949830b10f876e0e683dbcf1694ed7d74f9e76 /sys-libs/openipmi/openipmi-1.4.14.ebuild
parentrename the versions to more closely track the debian patch levels (diff)
downloadhistorical-3d2b2c48c8b517e74802f3f2d7df40d0c00fdbe6.tar.gz
historical-3d2b2c48c8b517e74802f3f2d7df40d0c00fdbe6.tar.bz2
historical-3d2b2c48c8b517e74802f3f2d7df40d0c00fdbe6.zip
Version bump.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs/openipmi/openipmi-1.4.14.ebuild')
-rw-r--r--sys-libs/openipmi/openipmi-1.4.14.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/openipmi/openipmi-1.4.14.ebuild b/sys-libs/openipmi/openipmi-1.4.14.ebuild
new file mode 100644
index 000000000000..be1147125606
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-1.4.14.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-1.4.14.ebuild,v 1.1 2005/03/25 22:02:57 robbat2 Exp $
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/${PN}/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="crypt snmp perl"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/libc
+ dev-libs/glib
+ >=dev-lang/swig-1.3.21
+ sys-libs/gdbm
+ dev-util/pkgconfig
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )"
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ myconf="${myconf} `use_with perl perl yes`"
+ myconf="${myconf} --with-swig=yes --with-glib=yes"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.emulator
+ newdoc cmdlang/README README.cmdlang
+}