summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-11-28 11:57:52 +0000
commitf189db3f9e3b05eacfc9939c84930bbf40010522 (patch)
treec97d0d333738d237888aa492b6ecdd21e23dd0e0 /sys-kernel/xbox-sources
parentfix src_uri (diff)
downloadhistorical-f189db3f9e3b05eacfc9939c84930bbf40010522.tar.gz
historical-f189db3f9e3b05eacfc9939c84930bbf40010522.tar.bz2
historical-f189db3f9e3b05eacfc9939c84930bbf40010522.zip
Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
Diffstat (limited to 'sys-kernel/xbox-sources')
-rw-r--r--sys-kernel/xbox-sources/ChangeLog6
-rw-r--r--sys-kernel/xbox-sources/files/xbox-sources-2.6.8.1.AF_UNIX.patch24
-rw-r--r--sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild4
3 files changed, 31 insertions, 3 deletions
diff --git a/sys-kernel/xbox-sources/ChangeLog b/sys-kernel/xbox-sources/ChangeLog
index e1d32cbbe0ca..b049cfcc3eb4 100644
--- a/sys-kernel/xbox-sources/ChangeLog
+++ b/sys-kernel/xbox-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/xbox-sources
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/ChangeLog,v 1.20 2004/11/27 18:08:56 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/ChangeLog,v 1.21 2004/11/28 11:57:52 plasmaroo Exp $
+
+ 28 Nov 2004; <plasmaroo@gentoo.org> xbox-sources-2.6.8.1-r5.ebuild,
+ +files/xbox-sources-2.6.8.1.AF_UNIX.patch:
+ Adding fixed 2.6 AF_UNIX security patch for 2.6 branch; bug #72688.
*xbox-sources-2.4.28-r1 (27 Nov 2004)
diff --git a/sys-kernel/xbox-sources/files/xbox-sources-2.6.8.1.AF_UNIX.patch b/sys-kernel/xbox-sources/files/xbox-sources-2.6.8.1.AF_UNIX.patch
new file mode 100644
index 000000000000..a95e94fd9362
--- /dev/null
+++ b/sys-kernel/xbox-sources/files/xbox-sources-2.6.8.1.AF_UNIX.patch
@@ -0,0 +1,24 @@
+--- linux-2.6.9/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
++++ linux-2.6.9.plasmaroo/net/unix/af_unix.c 2004-11-24 08:23:21 -08:00
+@@ -1535,9 +1535,11 @@
+
+ msg->msg_namelen = 0;
+
++ down(&u->readsem);
++
+ skb = skb_recv_datagram(sk, flags, noblock, &err);
+ if (!skb)
+- goto out;
++ goto out_unlock;
+
+ wake_up_interruptible(&u->peer_wait);
+
+@@ -1587,6 +1589,8 @@
+
+ out_free:
+ skb_free_datagram(sk,skb);
++out_unlock:
++ up(&u->readsem);
+ out:
+ return err;
+ }
diff --git a/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild b/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild
index ad60c74215c1..1a5341c1ff35 100644
--- a/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild
+++ b/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild,v 1.1 2004/11/27 18:08:56 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/xbox-sources-2.6.8.1-r5.ebuild,v 1.2 2004/11/28 11:57:52 plasmaroo Exp $
ETYPE='sources'
inherit kernel-2
@@ -19,7 +19,7 @@ UNIPATCH_LIST="
${FILESDIR}/${P}.smbfs.patch
${FILESDIR}/${P}.binfmt_elf.patch
${FILESDIR}/${P}.binfmt_a.out.patch
- ${FILESDIR}/${PN}.AF_UNIX.patch"
+ ${FILESDIR}/${P}.AF_UNIX.patch"
DESCRIPTION='Full sources for the Xbox Linux kernel'
SRC_URI="${KERNEL_URI}
mirror://gentoo/${XBOX_PATCHES}