summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-26 00:20:07 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-26 00:20:07 +0000
commit3de7b8abf7a5be1e8b49bc089138a989e5fa9363 (patch)
tree70f712f71fe295b582e696ff60f2cfc42527f4ea /sys-kernel/linux-sources
parentunmask new autoconf and automake (diff)
downloadhistorical-3de7b8abf7a5be1e8b49bc089138a989e5fa9363.tar.gz
historical-3de7b8abf7a5be1e8b49bc089138a989e5fa9363.tar.bz2
historical-3de7b8abf7a5be1e8b49bc089138a989e5fa9363.zip
stamp fix
Diffstat (limited to 'sys-kernel/linux-sources')
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
index 78c35d23a1ba..14eb96cd58c0 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
+# Distributed under the terms of the GNU General Public License v2
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.5 2002/03/22 05:26:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.6 2002/03/26 00:20:07 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -127,4 +127,10 @@ pkg_postinst() {
#this will generate include/linux/modversions.h, among other things:
cd ${ROOT}/usr/src/linux-${KV}
make dep
+ #This next line forces the next "make dep" to run in non-fastdep mode, calling
+ #genksyms and recalculating things correctly for us. This prevents users from
+ #bumping into problems when the default config is in SMP mode, they turn it off,
+ #they build and they get smp_num_cpus redefined errors. A full (non-fastdep)
+ #"make dep" appears to be needed between SMP<->UP switches.
+ find -iname *.stamp -exec rm {} \;
}