summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-17 00:27:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-17 00:27:50 +0000
commitabfe120008829696fb2f0230f719883be9dbecbf (patch)
tree8d854d2be907cca59af3b288423bade53736ab25 /sys-fs/quota
parentNew release: 2.11.0 (diff)
downloadhistorical-abfe120008829696fb2f0230f719883be9dbecbf.tar.gz
historical-abfe120008829696fb2f0230f719883be9dbecbf.tar.bz2
historical-abfe120008829696fb2f0230f719883be9dbecbf.zip
move rc options into a conf.d file and clean up rc file a bit #102721 by M. Giritli
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/files/quota.confd15
-rw-r--r--sys-fs/quota/files/quota.rc628
-rw-r--r--sys-fs/quota/quota-3.09.ebuild3
-rw-r--r--sys-fs/quota/quota-3.10.ebuild3
-rw-r--r--sys-fs/quota/quota-3.12-r1.ebuild3
-rw-r--r--sys-fs/quota/quota-3.12.ebuild3
6 files changed, 33 insertions, 22 deletions
diff --git a/sys-fs/quota/files/quota.confd b/sys-fs/quota/files/quota.confd
new file mode 100644
index 000000000000..5981d05d7104
--- /dev/null
+++ b/sys-fs/quota/files/quota.confd
@@ -0,0 +1,15 @@
+# /etc/init.d/quota
+
+# Run quotacheck ?
+RUN_QUOTACHECK="yes"
+
+# Options for quotacheck
+QUOTACHECK_OPTS="-avug"
+
+
+# Options for quotaon
+QUOTAON_OPTS="-avug"
+
+
+# Options for quotaoff
+QUOTAOFF_OPTS="-avug"
diff --git a/sys-fs/quota/files/quota.rc6 b/sys-fs/quota/files/quota.rc6
index f8c9d448b103..4c1875fed873 100644
--- a/sys-fs/quota/files/quota.rc6
+++ b/sys-fs/quota/files/quota.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/files/quota.rc6,v 1.2 2005/01/07 13:04:51 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/files/quota.rc6,v 1.3 2005/08/17 00:27:50 vapier Exp $
depend() {
need localmount
@@ -9,27 +9,19 @@ depend() {
}
start() {
- ebegin "Starting Quota"
- if [ -x /usr/sbin/quotacheck ]
- then
- echo "Checking quotas. This may take some time."
- /usr/sbin/quotacheck -avug
- echo "Done."
- fi
- if [ -x /usr/sbin/quotaon ]
- then
- echo "Turning on quota"
- /usr/sbin/quotaon -avug
+ if [[ ${RUN_QUOTACHECK} == "yes" ]] ; then
+ ebegin "Checking quotas (may take a while)"
+ /usr/sbin/quotacheck ${QUOTACHECK_OPTS}
+ eend $?
fi
+
+ ebegin "Starting quota"
+ /usr/sbin/quotaon ${QUOTAON_OPTS}
eend $?
}
stop() {
ebegin "Stopping quota"
- if [ -x /usr/sbin/quotaoff ]
- then
- echo "Turning quota off"
- /usr/sbin/quotaoff -avug
- fi
+ /usr/sbin/quotaoff ${QUOTAOFF_OPTS}
eend $?
}
diff --git a/sys-fs/quota/quota-3.09.ebuild b/sys-fs/quota/quota-3.09.ebuild
index b9ae3a2652b4..deaf992bd695 100644
--- a/sys-fs/quota/quota-3.09.ebuild
+++ b/sys-fs/quota/quota-3.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.09.ebuild,v 1.2 2005/01/03 00:11:56 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.09.ebuild,v 1.3 2005/08/17 00:27:50 vapier Exp $
inherit eutils
@@ -41,6 +41,7 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/quota.rc6 quota
+ newconfd ${FILESDIR}/quota.confd quota
# NLS bloat reduction
use nls || rm -rf ${D}/usr/share/locale
diff --git a/sys-fs/quota/quota-3.10.ebuild b/sys-fs/quota/quota-3.10.ebuild
index 149acb0cf571..69b2ce76994c 100644
--- a/sys-fs/quota/quota-3.10.ebuild
+++ b/sys-fs/quota/quota-3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.10.ebuild,v 1.2 2005/01/03 00:11:56 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.10.ebuild,v 1.3 2005/08/17 00:27:50 vapier Exp $
inherit eutils
@@ -41,6 +41,7 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/quota.rc6 quota
+ newconfd ${FILESDIR}/quota.confd quota
# NLS bloat reduction
use nls || rm -rf ${D}/usr/share/locale
diff --git a/sys-fs/quota/quota-3.12-r1.ebuild b/sys-fs/quota/quota-3.12-r1.ebuild
index 6201b8992b0e..2dbc69839622 100644
--- a/sys-fs/quota/quota-3.12-r1.ebuild
+++ b/sys-fs/quota/quota-3.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12-r1.ebuild,v 1.2 2005/06/03 23:06:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12-r1.ebuild,v 1.3 2005/08/17 00:27:50 vapier Exp $
inherit eutils
@@ -59,6 +59,7 @@ src_install() {
dodoc Changelog
newinitd "${FILESDIR}"/quota.rc6 quota
+ newconfd "${FILESDIR}"/quota.confd quota
if use ldap ; then
insinto /etc/openldap/schema
diff --git a/sys-fs/quota/quota-3.12.ebuild b/sys-fs/quota/quota-3.12.ebuild
index bc2ef883f294..441a6cb6697b 100644
--- a/sys-fs/quota/quota-3.12.ebuild
+++ b/sys-fs/quota/quota-3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.8 2005/06/17 20:20:52 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.9 2005/08/17 00:27:50 vapier Exp $
inherit eutils
@@ -48,6 +48,7 @@ src_install() {
dodoc doc/*
newinitd ${FILESDIR}/quota.rc6 quota
+ newconfd ${FILESDIR}/quota.confd quota
}
pkg_postinst() {