summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-24 03:07:11 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-24 03:07:11 +0000
commit90dc50f1798d55e9ab5d67fc6258af5243454583 (patch)
tree128b58638e785ef7e15166283bd4db7a431ff6b9 /sys-fs/dd-rescue/dd-rescue-1.24.ebuild
parentFix building against linux-headers-3.4 (bug #417055, thanks to Marek Bartosie... (diff)
downloadhistorical-90dc50f1798d55e9ab5d67fc6258af5243454583.tar.gz
historical-90dc50f1798d55e9ab5d67fc6258af5243454583.tar.bz2
historical-90dc50f1798d55e9ab5d67fc6258af5243454583.zip
Inherit flag-o-matic for append-ldflags, and use that rather than append-flags.
Package-Manager: portage-2.2.0_alpha107_p3/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/dd-rescue/dd-rescue-1.24.ebuild')
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.24.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/dd-rescue/dd-rescue-1.24.ebuild b/sys-fs/dd-rescue/dd-rescue-1.24.ebuild
index c03b07c3fae9..85ca4accecc9 100644
--- a/sys-fs/dd-rescue/dd-rescue-1.24.ebuild
+++ b/sys-fs/dd-rescue/dd-rescue-1.24.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.24.ebuild,v 1.1 2011/12/05 10:22:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.24.ebuild,v 1.2 2012/05/24 03:07:11 vapier Exp $
EAPI=4
-inherit base toolchain-funcs
+inherit base toolchain-funcs flag-o-matic
MY_PN=${PN/-/_}
MY_P=${MY_PN}-${PV}
@@ -21,7 +21,7 @@ IUSE="static kernel_linux elibc_glibc"
S=${WORKDIR}/${MY_PN}
src_compile() {
- use static && append-flags -static
+ use static && append-ldflags -static
# Passing LDFLAGS together with CFLAGS is not often a good idea, but
# in this case it makes it possible to avoid patching; after all it