summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-06-16 15:57:26 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-06-16 15:57:26 +0000
commitb9a9f3784eb83f5c3418a2ecf73e633ff466461a (patch)
tree6a6f0800092ffa65d405ab04a8392f7bc012cc25 /sys-devel
parentfix digests (diff)
downloadhistorical-b9a9f3784eb83f5c3418a2ecf73e633ff466461a.tar.gz
historical-b9a9f3784eb83f5c3418a2ecf73e633ff466461a.tar.bz2
historical-b9a9f3784eb83f5c3418a2ecf73e633ff466461a.zip
Update am-wrapper script to also use ac_version and am_version functions to
check AC_PREREQ and AM_AUTOMAKE_VERSION (allows us to check strings beyond the first match).
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog10
-rw-r--r--sys-devel/automake/automake-1.8.5-r1.ebuild499
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.8-v2150
-rw-r--r--sys-devel/automake/files/digest-automake-1.8.5-r15
4 files changed, 663 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index ad7391415053..bf6c61f39ff1 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/automake
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.55 2004/05/29 21:59:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.56 2004/06/16 15:57:26 azarah Exp $
+
+*automake-1.8.5-r1 (16 Jun 2004)
+
+ 16 Jun 2004; Martin Schlemmer <azarah@gentoo.org>
+ +files/am-wrapper.pl-1.8-v2, +automake-1.8.5-r1.ebuild:
+ Update am-wrapper script to also use ac_version and am_version functions to
+ check AC_PREREQ and AM_AUTOMAKE_VERSION (allows us to check strings beyond the
+ first match).
*automake-1.8.5 (29 May 2004)
diff --git a/sys-devel/automake/automake-1.8.5-r1.ebuild b/sys-devel/automake/automake-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..45e4cfbdb649
--- /dev/null
+++ b/sys-devel/automake/automake-1.8.5-r1.ebuild
@@ -0,0 +1,499 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r1.ebuild,v 1.1 2004/06/16 15:57:26 azarah Exp $
+
+inherit eutils
+
+# OLD14 = 1.4
+# OLD15 = 1.5
+# OLD16 = 1.6
+# OLD17 = 1.7
+# NEW = 1.8 (.2)
+
+# NOTE: For all of those brave souls out there that wants to fix
+# or update this, note that all three versions install
+# .m4 files to /usr/share/aclocal-${ver}/ and .am files
+# to /usr/share/automake-${ver}/. We then add the default
+# /usr/share/aclocal/ to aclocal's search path by adding
+# "push (@dirlist, \"/usr/share/aclocal\");" after @dirlist
+# is defined the first time (done in fix_bins() function).
+#
+# The theory thus is, all version specific data goes into
+# version specific directories, but programs like ogg/whatever
+# can still install thier .m4 macros into /usr/share/aclocal/.
+#
+# Martin Schlemmer <azarah@gentoo.org>
+# 19 May 2002
+
+
+# Currently this is 1.8, but it could change to 1.8.x as it
+# does with 1.5d ... to determine this, install latest version
+# of 1.8, and look at the generated files in the bin dir ..
+# it should be something like (for 1.8.1):
+#
+# nosferatu automake-1.8.1 # ls /myinstallroot/bin/
+# aclocal aclocal-1.8 automake automake-1.8
+# nosferatu automake-1.8.1 #
+#
+# You should then set NEW_PV to 1.8, as this is the suffix
+NEW_PV="1.8"
+
+OLD17_PV="1.7.9"
+OLD17_PV_S="1.7"
+OLD17_P="${PN}-${OLD17_PV}"
+OLD16_PV="1.6.3"
+OLD16_PV_S="1.6"
+OLD16_P="${PN}-${OLD16_PV}"
+OLD15_PV="1.5"
+OLD15_P="${PN}-${OLD15_PV}"
+OLD14_PV="1.4-p6"
+OLD14_P="${PN}-${OLD14_PV}"
+S="${WORKDIR}/${P}"
+OLD17_S="${WORKDIR}/${OLD17_P}"
+OLD16_S="${WORKDIR}/${OLD16_P}"
+OLD15_S="${WORKDIR}/${OLD15_P}"
+OLD14_S="${WORKDIR}/${OLD14_P}"
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD17_P}.tar.bz2
+ mirror://gnu/${PN}/${OLD16_P}.tar.bz2
+ mirror://gnu/${PN}/${OLD15_P}.tar.gz
+ mirror://gnu/${PN}/${OLD14_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1.5"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390"
+IUSE=
+
+DEPEND="dev-lang/perl
+ >=sys-devel/autoconf-2.58"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${OLD15_S}
+ epatch ${FILESDIR}/${PN}-${OLD15_PV}-target_hook.patch
+ cd ${OLD17_S}
+ epatch ${FILESDIR}/${PN}-${OLD17_PV}-infopage-namechange.patch
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.8.2-infopage-namechange.patch
+ epatch ${FILESDIR}/${PN}-1.8.5-config-guess-uclibc.patch
+}
+
+src_compile() {
+ #
+ # ************ automake-1.8x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake18.info:' \
+ doc/automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.8: \(automake\)|' \
+ doc/automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.8:|' doc/automake.texi
+ perl -pi -e 's:\(automake\):\(automake18\):' doc/automake.texi
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} \
+ || die "configure 1.8x failed"
+ emake || die "emake 1.8x failed"
+
+ #
+ # ************ automake-1.7x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${OLD17_S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake17.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.7: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.7:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake17\):' automake.texi
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} \
+ || die "configure 1.7x failed"
+ emake || die "emake 1.7x failed"
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${OLD16_S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake16.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.6: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.6:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake16\):' automake.texi
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} \
+ || die "configure 1.6x failed"
+ emake || die "emake 1.6x failed"
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake15.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.5: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.5:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake15\):' automake.texi
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} \
+ || die "configure 1.5x failed"
+ emake || die "emake 1.5x failed"
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p6 ************
+ #
+ cd ${OLD14_S}
+
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.4: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.4:|' automake.texi
+ perl -pi -e 's:GNU admin:GNU programming tools:' automake.texi
+# perl -pi -e 's|\* automake: \(automake\)|\* Automake: \(automake\)|' \
+# automake.texi
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} \
+ || die "configure 1.4 failed"
+ emake || die "emake 1.4 failed"
+}
+
+# This basically fix aclocal and automake so that they
+# use the correct directories, and also adds the normal
+# /usr/share/aclocal for aclocal to include.
+fix_bins() {
+
+ for x in aclocal automake
+ do
+ perl -pi -e "s:share/automake\":share/automake-${1}\":g" ${x}
+ perl -pi -e "s:share/aclocal\":share/aclocal-${1}\":g" ${x}
+ done
+
+ # add "/usr/share/aclocal" to m4 search patch
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files (@dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig > aclocal
+ # same as above, but 1.4 looks a bit differently
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files ($acdir, @dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig > aclocal
+ # "aclocal --print-ac-dir" should return "/usr/share/aclocal"
+ cp aclocal aclocal.orig
+ sed -e 's:print $acdir:print "/usr/share/aclocal":' \
+ aclocal.orig > aclocal
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.8-v2 am-wrapper.pl
+ # Name binaries to exact version, as they have limited support for
+ # more than one version installs
+ dosed "s:1\.8x:${NEW_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.7x:${OLD17_PV_S}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.6x:${OLD16_PV_S}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.5x:${OLD15_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+
+ #
+ # ************ automake-1.8x ************
+ #
+
+ cd ${S}
+# not needed for 1.8.2
+# fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo doc/automake18.info*
+
+ docinto ${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.7x ************
+ #
+
+ cd ${OLD17_S}
+# not needed for 1.7.8
+# fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake17.info*
+
+ docinto ${OLD17_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${OLD16_S}
+# not needed for 1.6.3
+# fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake16.info*
+
+ docinto ${OLD16_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+ fix_bins ${OLD15_PV}
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-${OLD15_PV} \
+ m4datadir=/usr/share/aclocal-${OLD15_PV} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD15_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake15.info*
+
+ docinto ${OLD15_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p6 ************
+ #
+
+ cd ${OLD14_S}
+# Not needed anymore for 1.4-p6
+# fix_bins "1.4"
+
+ # Ignore duplicates like automake-1.5 and 1.6
+ #epatch ${FILESDIR}/${PN}-1.4_p5-ignore-duplicates.patch
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-1.4 \
+ m4datadir=/usr/share/aclocal-1.4 \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD14_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ misc stuff ****************
+
+ # Some packages needs a /usr/share/automake directory
+ dosym automake-1.4 /usr/share/automake
+
+ # This is the default macro directory that apps use ..
+ keepdir /usr/share/aclocal
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e ${ROOT}/usr/bin/${x} ]
+ then
+ rm -f ${ROOT}/usr/bin/${x}
+ fi
+ done
+
+ # nuke this if it is a directory, as the new one is a symlink
+ if [ -d ${ROOT}/usr/share/automake ]
+ then
+ rm -rf ${ROOT}/usr/share/automake
+ fi
+
+ # Make sure we move all the macros not installed with automake
+ # to the non version specific aclocal dir.
+ # !!! NOTE: I should really think about removing this lot !!!
+ if [ ! -d ${ROOT}/usr/share/aclocal ]
+ then
+ mkdir -p ${ROOT}/usr/share/aclocal
+ fi
+ if [ -d ${OLD14_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-1.4 ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-1.4/*.m4
+ do
+ if [ ! -f ${OLD14_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${OLD15_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${OLD15_PV} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${OLD15_PV}/*.m4
+ do
+ if [ ! -f ${OLD15_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${OLD16_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${OLD16_PV_S} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${OLD16_PV_S}/*.m4
+ do
+ if [ ! -f ${OLD16_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${OLD17_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${OLD17_PV_S} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${OLD17_PV_S}/*.m4
+ do
+ if [ ! -f ${OLD17_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${NEW_PV} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${NEW_PV}/*.m4
+ do
+ if [ ! -f ${S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+}
+
+pkg_postinst() {
+
+ # nuke duplicate macros
+ for x in ${ROOT}/usr/share/aclocal-1.4/*.m4
+ do
+ if [ -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ rm -f ${ROOT}/usr/share/aclocal/${x##*/}
+ fi
+ done
+
+ echo
+ einfo "Please note that the 'WANT_AUTOMAKE_1_?=1' have changed to:"
+ echo
+ einfo " WANT_AUTOMAKE=<required version>"
+ echo
+ einfo "For instance: WANT_AUTOMAKE=1.6"
+ echo
+}
+
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.8-v2 b/sys-devel/automake/files/am-wrapper.pl-1.8-v2
new file mode 100644
index 000000000000..06df18861346
--- /dev/null
+++ b/sys-devel/automake/files/am-wrapper.pl-1.8-v2
@@ -0,0 +1,150 @@
+#!/usr/bin/perl
+#
+#
+# Author: Guillaume Cottenceau (gc@mandrakesoft.com)
+# Modified by: Martin Schlemmer (azarah@gentoo.org)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.8 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.8'
+# -or-
+# - `Makefile.in' was generated by automake-1.8 or superior, which
+# specifically needs automake-1.8
+# -or_
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.8
+# - runs automake-1.7 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.7'
+# -or-
+# - `Makefile.in' was generated by automake-1.7 or superior, which
+# specifically needs automake-1.7
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.7
+# -or-
+# - runs automake-1.6 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.6'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.6
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.53c'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.53c'
+# - runs automake-1.5 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.5'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.13'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.13'
+# -or-
+# - `Makefile.in' was generated by automake-1.5 or superior, which
+# specifically needs automake-1.5
+#
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+sub am_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+sub ac_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+
+
+
+my $binary = "$0-1.4";
+my $binary_1_5 = "$0-1.5x";
+my $binary_1_6 = "$0-1.6x";
+my $binary_1_7 = "$0-1.7x";
+my $binary_1_8 = "$0-1.8x";
+
+# Automake is really getting out of hand, so rather start supporting
+# WANT_AUTOMAKE = "1.7" the like. Unfortunately it override the old
+# variables, so if not set, just convert the old variables ....
+if ($ENV{WANT_AUTOMAKE} eq "") {
+ if ($ENV{WANT_AUTOMAKE_1_4}) {
+ $ENV{WANT_AUTOMAKE} = '1.4';
+ } elsif ($ENV{WANT_AUTOMAKE_1_6}) {
+ $ENV{WANT_AUTOMAKE} = '1.6';
+ } elsif ($ENV{WANT_AUTOMAKE_1_5}) {
+ $ENV{WANT_AUTOMAKE} = '1.5';
+ }
+}
+
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
+if ($ENV{WANT_AUTOMAKE} ne '1.4') {
+ if (-x $binary_1_8 # user may not have _1_8 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.8')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.8'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.8'
+ || am_version('aclocal.m4') ge '1.8')) {
+ $ENV{WANT_AUTOMAKE} = '1.8'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_8;
+ } elsif (-x $binary_1_7 # user may not have 1.7 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.7')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.7'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.7'
+ || am_version('aclocal.m4') ge '1.7')) {
+ $ENV{WANT_AUTOMAKE} = '1.7'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_7;
+ } elsif (-x $binary_1_6 # user may not have 1.6 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.6')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.6'
+ || am_version('aclocal.m4') ge '1.6'
+ # Autoconf 2.53d and later need automake-1.6c, so enable 1.6 for 2.53
+ # and up .....
+ || ac_version('configure.in') gt '2.52'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.52'
+ || ac_version('aclocal.m4') gt '2.52')) {
+ $ENV{WANT_AUTOMAKE} = '1.6'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_6;
+ } elsif (-x $binary_1_5 # user may have only 1.4 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.5')
+ || -r 'configure.ac'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.5'
+ || ac_version('configure.in') gt '2.13'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.13'
+ || ac_version('aclocal.m4') gt '2.13')) {
+ $ENV{WANT_AUTOMAKE} = '1.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_5;
+ } else {
+ if (-r 'configure.in' || -r 'configure.ac') {
+ $ENV{WANT_AUTOMAKE} = '1.4'; # for further consistency
+ } else {
+ $ENV{WANT_AUTOMAKE} = '1.8';
+ $binary = $binary_1_8;
+ }
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake/files/digest-automake-1.8.5-r1 b/sys-devel/automake/files/digest-automake-1.8.5-r1
new file mode 100644
index 000000000000..4e5695d11b21
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.8.5-r1
@@ -0,0 +1,5 @@
+MD5 0114aa6d7dc32112834b68105fb8d7e2 automake-1.8.5.tar.bz2 663182
+MD5 571fd0b0598eb2a27dcf68adcfddfacb automake-1.7.9.tar.bz2 577705
+MD5 2e8053609e9d318f80db0fce29dca7e9 automake-1.6.3.tar.bz2 476275
+MD5 74a22ac0581378e807ecb334a55c5bab automake-1.5.tar.gz 526934
+MD5 24872b81b95d78d05834c39af2cfcf05 automake-1.4-p6.tar.gz 375060