summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-10-27 23:20:33 +0000
committerNed Ludd <solar@gentoo.org>2005-10-27 23:20:33 +0000
commita9e06c6c390b62da462e2c9a62bdbb2eca15cd41 (patch)
tree2d398a5c3947050d4bc4db89ffd85be25f01037a /sys-devel
parentAdded patch to fix unresolved symbols in driver. Thanks again to Tony Murray (diff)
downloadhistorical-a9e06c6c390b62da462e2c9a62bdbb2eca15cd41.tar.gz
historical-a9e06c6c390b62da462e2c9a62bdbb2eca15cd41.tar.bz2
historical-a9e06c6c390b62da462e2c9a62bdbb2eca15cd41.zip
- initial commit of sparse. Bug #110656
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/sparse/ChangeLog9
-rw-r--r--sys-devel/sparse/Manifest16
-rw-r--r--sys-devel/sparse/files/digest-sparse-2005.10.281
-rw-r--r--sys-devel/sparse/metadata.xml8
-rw-r--r--sys-devel/sparse/sparse-2005.10.28.ebuild26
5 files changed, 60 insertions, 0 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
new file mode 100644
index 000000000000..ea64c0f9dba2
--- /dev/null
+++ b/sys-devel/sparse/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-devel/sparse
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.1 2005/10/27 23:20:33 solar Exp $
+
+*sparse-2005.10.28 (27 Oct 2005)
+
+ 27 Oct 2005; <solar.@gentoo.org> +metadata.xml, +sparse-2005.10.28.ebuild:
+ - initial commit of sparse. Bug #110656
+
diff --git a/sys-devel/sparse/Manifest b/sys-devel/sparse/Manifest
new file mode 100644
index 000000000000..688bd13b7f86
--- /dev/null
+++ b/sys-devel/sparse/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 411b5dba346ef3ec6286d2049e49787f ChangeLog 358
+MD5 1185d0d80ae45ba7cc96254a4b0b8462 files/digest-sparse-2005.10.28 69
+MD5 09adef9c41d44b360b856a5913d179f3 metadata.xml 220
+MD5 f0e687ab88a42372752afb3448eed6d4 sparse-2005.10.28.ebuild 638
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iQCVAwUBQ2Fgzp4WFLgrx1GWAQLKoAP9GmbRqNw/IyWrGiRlzDd90jdzVlrxSLhc
+GihEValbeUUxZkR9+9glnbhhXpns4YGrp3QiegXSzPx7vm2+iz3MyHjqgKz4K29b
+ApwSVr6Y0lfwgkskuyNMDsbMgimQUFh4CBysXPh4Rk8PCY3r1gv79gV20xafwkpB
+DoDY2eLJ6Qo=
+=5FDW
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/sparse/files/digest-sparse-2005.10.28 b/sys-devel/sparse/files/digest-sparse-2005.10.28
new file mode 100644
index 000000000000..a56baffe28e4
--- /dev/null
+++ b/sys-devel/sparse/files/digest-sparse-2005.10.28
@@ -0,0 +1 @@
+MD5 4aaa05cffd08021168a408cc98a9139e sparse-2005-10-28.tar.gz 160615
diff --git a/sys-devel/sparse/metadata.xml b/sys-devel/sparse/metadata.xml
new file mode 100644
index 000000000000..327d190e1578
--- /dev/null
+++ b/sys-devel/sparse/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kernel</herd>
+<maintainer>
+ <email>solar@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-devel/sparse/sparse-2005.10.28.ebuild b/sys-devel/sparse/sparse-2005.10.28.ebuild
new file mode 100644
index 000000000000..ae96435d422d
--- /dev/null
+++ b/sys-devel/sparse/sparse-2005.10.28.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2005-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-2005.10.28.ebuild,v 1.1 2005/10/27 23:20:33 solar Exp $
+
+MY_PV=${PV//./-}
+MY_PV2=${PV//./}
+
+DESCRIPTION="sparse - C semantic parser"
+HOMEPAGE="http://kernel.org/pub/scm/devel/sparse/"
+SRC_URI="http://www.codemonkey.org.uk/projects/git-snapshots/sparse/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/git-snapshot-${MY_PV2}
+
+src_install() {
+ newbin check sparse
+ dolib libsparse.so
+ dodoc FAQ LICENSE README
+}