summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-21 20:19:30 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-21 20:19:30 +0000
commit32f3cbfe7d321a0fb9f047bbbd536b0e987f312c (patch)
tree57c7ade93e5ae93597f5e05f51d093b279e55660 /sys-devel
parentmoved arch check into src_compile for testing (diff)
downloadhistorical-32f3cbfe7d321a0fb9f047bbbd536b0e987f312c.tar.gz
historical-32f3cbfe7d321a0fb9f047bbbd536b0e987f312c.tar.bz2
historical-32f3cbfe7d321a0fb9f047bbbd536b0e987f312c.zip
new package. Fixes #3542
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog19
-rw-r--r--sys-devel/distcc/distcc-0.3.ebuild25
-rw-r--r--sys-devel/distcc/distcc-0.4.ebuild25
-rw-r--r--sys-devel/distcc/files/digest-distcc-0.31
-rw-r--r--sys-devel/distcc/files/digest-distcc-0.41
5 files changed, 71 insertions, 0 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
new file mode 100644
index 000000000000..a7b30855060c
--- /dev/null
+++ b/sys-devel/distcc/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for sys-devel/distcc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.1 2002/06/21 20:19:30 rphillips Exp $
+
+*distcc-0.4 (21 Jun 2002)
+
+ 21 Jun 2002; Ryan Phillips <rphillips@gentoo.org> distcc-0.4.ebuild :
+
+ New release
+
+*distcc-0.3 (21 Jun 2002)
+
+ 21 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sys-devel/distcc/distcc-0.3.ebuild b/sys-devel/distcc/distcc-0.3.ebuild
new file mode 100644
index 000000000000..b912c2d98618
--- /dev/null
+++ b/sys-devel/distcc/distcc-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Marko Mikulicic <marko@seul.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-0.3.ebuild,v 1.1 2002/06/21 20:19:30 rphillips Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://ftp.samba.org/ftp/distcc/${P}.tar.gz"
+HOMEPAGE="http://ftp.samba.org/ftp/distcc/"
+DESCRIPTION="a program to distribute compilation of C code across several machines
+ over a network"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure || die "config"
+ emake || die
+}
+
+src_install () {
+ doins /usr
+ dobin ${S}/src/distcc
+ dobin ${S}/src/distccd
+}
+
+
+
diff --git a/sys-devel/distcc/distcc-0.4.ebuild b/sys-devel/distcc/distcc-0.4.ebuild
new file mode 100644
index 000000000000..02d7418e6d6d
--- /dev/null
+++ b/sys-devel/distcc/distcc-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Marko Mikulicic <marko@seul.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-0.4.ebuild,v 1.1 2002/06/21 20:19:30 rphillips Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://ftp.samba.org/ftp/distcc/${P}.tar.gz"
+HOMEPAGE="http://ftp.samba.org/ftp/distcc/"
+DESCRIPTION="a program to distribute compilation of C code across several machines
+ over a network"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure || die "config"
+ emake -C src || die
+}
+
+src_install () {
+ doins /usr
+ dobin ${S}/src/distcc
+ dobin ${S}/src/distccd
+}
+
+
+
diff --git a/sys-devel/distcc/files/digest-distcc-0.3 b/sys-devel/distcc/files/digest-distcc-0.3
new file mode 100644
index 000000000000..5dd6afad1213
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-0.3
@@ -0,0 +1 @@
+MD5 e232e16d3e3eeec0b1e9d4efcd8036ff distcc-0.3.tar.gz 105877
diff --git a/sys-devel/distcc/files/digest-distcc-0.4 b/sys-devel/distcc/files/digest-distcc-0.4
new file mode 100644
index 000000000000..1d20e8d1d22e
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-0.4
@@ -0,0 +1 @@
+MD5 3b21a4bde9810eb8040b05e6924430f8 distcc-0.4.tar.gz 121844