summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-09-22 18:00:12 +0000
committerRobert Coie <rac@gentoo.org>2004-09-22 18:00:12 +0000
commit86974497cc6ef2ab0f324761ea07cfc818bda525 (patch)
treec4b1c75689aeed5b633a5bdb5851cafb89b21494 /sys-devel/libperl/libperl-5.8.2.ebuild
parentStable amd64, sparc. (diff)
downloadhistorical-86974497cc6ef2ab0f324761ea07cfc818bda525.tar.gz
historical-86974497cc6ef2ab0f324761ea07cfc818bda525.tar.bz2
historical-86974497cc6ef2ab0f324761ea07cfc818bda525.zip
USE threads -> ithreads
Diffstat (limited to 'sys-devel/libperl/libperl-5.8.2.ebuild')
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index c3616ebed75e..6babf1e53a13 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.17 2004/09/06 20:45:30 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.18 2004/09/22 18:00:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm threads"
+IUSE="berkdb gdbm ithreads"
inherit eutils flag-o-matic
@@ -96,13 +96,13 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
- # I think this should rather be displayed if you *have* 'threads'
+ # I think this should rather be displayed if you *have* 'ithreads'
# in USE if it could break things ...
- if use threads
+ if use ithreads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
- ewarn "threading enabled."
+ ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -112,7 +112,7 @@ pkg_setup() {
ewarn ""
ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
ewarn "threading enabled , you must restart this emerge"
- ewarn "with USE=threads emerge...."
+ ewarn "with USE=ithreads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
@@ -142,9 +142,9 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if use threads
+ if use ithreads
then
- einfo "using threads"
+ einfo "using ithreads"
mythreading="-multi"
myconf="-Dusethreads ${myconf}"
myarch="${CHOST%%-*}-linux-thread"