summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-15 00:54:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-15 00:54:05 +0000
commit2d1b4d369651e1f4a93fa921b2031cba68f0453a (patch)
tree17a9aa4bef3a4430a95985abc60c78b6ffa80df7 /sys-devel/binutils-config
parentadd joystick into IUSE (diff)
downloadhistorical-2d1b4d369651e1f4a93fa921b2031cba68f0453a.tar.gz
historical-2d1b4d369651e1f4a93fa921b2031cba68f0453a.tar.bz2
historical-2d1b4d369651e1f4a93fa921b2031cba68f0453a.zip
remove bash3ism and delete env.d files when uninstalling
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/Manifest8
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-1.744
2 files changed, 26 insertions, 26 deletions
diff --git a/sys-devel/binutils-config/Manifest b/sys-devel/binutils-config/Manifest
index d8f13721bd03..4d69317cb73a 100644
--- a/sys-devel/binutils-config/Manifest
+++ b/sys-devel/binutils-config/Manifest
@@ -6,14 +6,14 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 f29faf5ea949b60f49db01fe57eb0db0 binutils-config-1.7.ebuild 581
MD5 4f942db37990035aa40c87e1d7408536 binutils-config-1.6.ebuild 599
MD5 35453667524ba4ee7ae09bee97e27317 files/binutils-config-1.6 7696
-MD5 ee85c5f5c882d34fd4bf9b1910453d40 files/binutils-config-1.7 8652
+MD5 e1ef6d1010faaefd5d581d094f1ebe01 files/binutils-config-1.7 8562
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-binutils-config-1.7 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-binutils-config-1.6 0
MD5 91f671b990b152b98e436bc29127c07b files/binutils-config.8 2335
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB5zybroRuSHgZdywRAmHFAJ9kq6gcCt9fXzb9bFzltzLJWxg9owCfS6ar
-jZudJstm534Ho0GjdlYYijc=
-=g4HJ
+iD8DBQFB6GnTroRuSHgZdywRAhOPAJ4sbhjgGbPaWFzb0vESUH8YxxAPXQCeJYtE
+oeIvrgLQT4eFPexj1g9ak/s=
+=pg4r
-----END PGP SIGNATURE-----
diff --git a/sys-devel/binutils-config/files/binutils-config-1.7 b/sys-devel/binutils-config/files/binutils-config-1.7
index 9f3ef2cdf340..d0e8d6c329f6 100755
--- a/sys-devel/binutils-config/files/binutils-config-1.7
+++ b/sys-devel/binutils-config/files/binutils-config-1.7
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.7,v 1.1 2005/01/14 03:28:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.7,v 1.2 2005/01/15 00:54:05 vapier Exp $
# Format of /etc/env.d/binutils/:
# config-TARGET: CURRENT=version for TARGET
@@ -16,26 +16,24 @@ source /etc/init.d/functions.sh || {
umask 022
usage() {
- cat <<-USAGE_END
- ${HILITE}binutils-config${NORMAL}:
- Change the current binutils profile or give info about profiles.
-
- Usage: ${HILITE}binutils-config${NORMAL} ${GOOD}[options]${NORMAL} ${BRACKET}[binutils profile]${NORMAL}
-
- ${HILITE}General Options:${NORMAL}
- ${GOOD}-c, --get-current-profile${NORMAL} Print current profile
- ${GOOD}-l, --list-profiles${NORMAL} Print a list of available profiles
- ${GOOD}-u, --uninstall${NORMAL} Remove all signs of specified target
-
- ${HILITE}Specific Cruft:${NORMAL}
- ${GOOD}--x86${NORMAL} Install extra x86 links (i[3-6]86)
- ${GOOD}--amd64${NORMAL} Install extra amd64 links (x86_64)
-
- Profile names are of the form: ${BRACKET}<CTARGET>-<binutils version>${NORMAL}
- For example: ${BRACKET}i686-pc-linux-gnu-2.15.92.0.2${NORMAL}
-
- For more info, please see ${HILITE}binutils-config${NORMAL}(8).
- USAGE_END
+cat << USAGE_END
+
+Usage: ${HILITE}binutils-config${NORMAL} ${GOOD}[options]${NORMAL} ${BRACKET}[binutils profile]${NORMAL}
+
+${HILITE}General Options:${NORMAL}
+ ${GOOD}-c, --get-current-profile${NORMAL} Print current profile
+ ${GOOD}-l, --list-profiles${NORMAL} Print a list of available profiles
+ ${GOOD}-u, --uninstall${NORMAL} Remove all signs of specified target
+
+${HILITE}Specific Cruft:${NORMAL}
+ ${GOOD}--x86${NORMAL} Install extra x86 links (i[3-6]86)
+ ${GOOD}--amd64${NORMAL} Install extra amd64 links (x86_64)
+
+Profile names are of the form: ${BRACKET}<CTARGET>-<binutils version>${NORMAL}
+For example: ${BRACKET}i686-pc-linux-gnu-2.15.92.0.2${NORMAL}
+
+For more info, please see ${HILITE}binutils-config${NORMAL}(8).
+USAGE_END
}
switch_profile() {
@@ -188,6 +186,8 @@ uninstall_target() {
rm -f "${ROOT}"/usr/${TARGET}/include/${x}
done
rm -f "${ROOT}"/usr/${TARGET}/lib/ldscripts
+
+ rm -f "${ENV_D}"/${TARGET}-*
}
get_current_profile() {
@@ -271,7 +271,7 @@ while [[ $# -gt 0 ]] ; do
exit 0
;;
-v|--version)
- cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.7,v 1.1 2005/01/14 03:28:15 vapier Exp $"
+ cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.7,v 1.2 2005/01/15 00:54:05 vapier Exp $"
cvsver=${cvsver##*binutils-config-}
echo "binutils-config-${cvsver%%,v *}"
exit 0