summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2007-10-05 14:02:52 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2007-10-05 14:02:52 +0000
commitaf6cd9f8045052b03cc3bdf40c7042550e961ec6 (patch)
tree380a3765d8efd6e2e5411dbba6ef2ad54e863602 /sys-cluster/drbd/drbd-8.0.6-r1.ebuild
parentNew revision with patch to fix fftw problem (see bug #194708). (diff)
downloadhistorical-af6cd9f8045052b03cc3bdf40c7042550e961ec6.tar.gz
historical-af6cd9f8045052b03cc3bdf40c7042550e961ec6.tar.bz2
historical-af6cd9f8045052b03cc3bdf40c7042550e961ec6.zip
DRDB package splitted in drbd + drbd-kernel, conversion to linux-mod, drbd-0.7.24 is scheduled to be removed.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'sys-cluster/drbd/drbd-8.0.6-r1.ebuild')
-rw-r--r--sys-cluster/drbd/drbd-8.0.6-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/drbd/drbd-8.0.6-r1.ebuild b/sys-cluster/drbd/drbd-8.0.6-r1.ebuild
new file mode 100644
index 000000000000..4fb21b2db099
--- /dev/null
+++ b/sys-cluster/drbd/drbd-8.0.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.0.6-r1.ebuild,v 1.1 2007/10/05 14:02:51 xmerlin Exp $
+
+inherit eutils versionator
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_MAJ_PV="$(get_version_component_range 1-2 ${PV})"
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+SRC_URI="http://oss.linbit.com/drbd/${MY_MAJ_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.drbd.org"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="~sys-cluster/drbd-kernel-${PV}"
+
+SLOT="0"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake -j1 tools || die "compile problem"
+}
+
+src_install() {
+ emake PREFIX=${D} install-tools || die "install problem"
+
+ # gentoo-ish init-script
+ newinitd ${FILESDIR}/${PN}-8.0.rc ${PN} || die
+
+ # docs
+ dodoc README ChangeLog COPYING ROADMAP INSTALL
+
+ # we put drbd.conf into docs
+ # it doesnt make sense to install a default conf in /etc
+ # put it to the docs
+ rm -f ${D}/etc/drbd.conf
+ dodoc scripts/drbd.conf || die
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Please copy and gunzip the configuration file"
+ einfo "from /usr/share/doc/${PF}/drbd.conf.gz to /etc"
+ einfo "and edit it to your needs. Helpful commands:"
+ einfo "man 5 drbd.conf"
+ einfo "man 8 drbdsetup"
+ einfo "man 8 drbdadm"
+ einfo "man 8 drbddisk"
+ einfo "man 8 drbdmeta"
+ einfo ""
+}