summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-10-08 14:40:12 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-10-08 14:40:12 +0000
commitf36cece663cec2a0fd375013f47e0f58cb1ea270 (patch)
treeec57eb0e97975ebe9f58e76805db9e4dcb0e6640 /sys-cluster/csync2/csync2-1.22.ebuild
parentcocoon only needs ant-core to build (diff)
downloadhistorical-f36cece663cec2a0fd375013f47e0f58cb1ea270.tar.gz
historical-f36cece663cec2a0fd375013f47e0f58cb1ea270.tar.bz2
historical-f36cece663cec2a0fd375013f47e0f58cb1ea270.zip
New version.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-cluster/csync2/csync2-1.22.ebuild')
-rw-r--r--sys-cluster/csync2/csync2-1.22.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/csync2/csync2-1.22.ebuild b/sys-cluster/csync2/csync2-1.22.ebuild
new file mode 100644
index 000000000000..da4c099f3f53
--- /dev/null
+++ b/sys-cluster/csync2/csync2-1.22.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.22.ebuild,v 1.1 2005/10/08 14:40:12 xmerlin Exp $
+
+DESCRIPTION="Cluster synchronization tool."
+SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz"
+HOMEPAGE="http://oss.linbit.com/csync2/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=net-libs/librsync-0.9.5
+ =dev-db/sqlite-2.8*
+ "
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+src_compile() {
+ econf --localstatedir=/var || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} localstatedir=${D}/var install || die "install problem"
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/${PN}.xinetd ${PN} || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "After you setup your conf file, edit the xinetd"
+ einfo "entry in /etc/xinetd.d/${PN} to enable, then"
+ einfo "start xinetd: /etc/init.d/xinetd start"
+ echo
+ einfo "To add ${PN} to your services file just run"
+ einfo "this command after you install:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+}
+
+pkg_config() {
+ einfo "Updating /etc/services"
+ { grep -v ^${PN} /etc/services;
+ echo "csync2 30865/tcp"
+ } > /etc/services.new
+ mv -f /etc/services.new /etc/services
+
+}