summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-05 13:50:36 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-05 13:50:36 +0000
commite14196ea294b6b4e2afda62a08246f4d9a1758e2 (patch)
treef0bb89ca124f695cf0ab476412b3441e5aa03054 /sys-auth
parentqt USE should be qt3. (diff)
downloadhistorical-e14196ea294b6b4e2afda62a08246f4d9a1758e2.tar.gz
historical-e14196ea294b6b4e2afda62a08246f4d9a1758e2.tar.bz2
historical-e14196ea294b6b4e2afda62a08246f4d9a1758e2.zip
Initial import. Ebuild by Jochen Maes <jochen.maes@sejo.be> who will be maintaining this package. I will be his proxy maintainer.
Package-Manager: portage-2.1.2_pre1-r4
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_bioapi/ChangeLog11
-rw-r--r--sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.13
-rw-r--r--sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch28
-rw-r--r--sys-auth/pam_bioapi/metadata.xml13
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.2.1.ebuild36
5 files changed, 91 insertions, 0 deletions
diff --git a/sys-auth/pam_bioapi/ChangeLog b/sys-auth/pam_bioapi/ChangeLog
new file mode 100644
index 000000000000..cba5d380d074
--- /dev/null
+++ b/sys-auth/pam_bioapi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/pam_bioapi
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.1 2006/10/05 13:50:35 wolf31o2 Exp $
+
+*pam_bioapi-0.2.1 (05 Oct 2006)
+
+ 05 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/pam_bioapi.c-0.2.1.patch, +metadata.xml, +pam_bioapi-0.2.1.ebuild:
+ Initial import. Ebuild by Jochen Maes <jochen.maes@sejo.be> who will be
+ maintaining this package. I will be his proxy maintainer.
+
diff --git a/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1 b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1
new file mode 100644
index 000000000000..f57f5622104d
--- /dev/null
+++ b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.2.1
@@ -0,0 +1,3 @@
+MD5 7101c49d5774e892f0eda401b4c1f634 pam_bioapi-0.2.1.tar.bz2 190025
+RMD160 8629841e99da13607c3e3f124bb2612af3b166b6 pam_bioapi-0.2.1.tar.bz2 190025
+SHA256 36b73c41fe455a5eb7c2b5f1de5d2fa147865c8b0e69e7c9cc8c164936ae72c6 pam_bioapi-0.2.1.tar.bz2 190025
diff --git a/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch b/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch
new file mode 100644
index 000000000000..3b778ce6ac99
--- /dev/null
+++ b/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch
@@ -0,0 +1,28 @@
+--- libpam_bioapi/pam_bioapi.c 2005-10-24 17:31:26.000000000 +0200
++++ libpam_bioapi/pam_bioapi.c.patched 2005-10-24 17:33:25.000000000 +0200
+@@ -54,6 +54,7 @@
+ BioAPI_HANDLE bspHandle;
+ BioAPI_INPUT_BIR BIR;
+ BioAPI_BOOL result = BioAPI_FALSE;
++ BioAPI_BOOL bPrecedence = BioAPI_TRUE;
+ BioAPI_FAR FARAchieved;
+ BioAPI_UUID tempUuid;
+ const BioAPI_UUID *uuid;
+@@ -143,7 +144,7 @@
+
+ tries = 3;
+ do {
+- bRet = BioAPI_Verify(bspHandle, &maxFAR, NULL, NULL, &BIR, NULL, &result, &FARAchieved, NULL, NULL, -1, NULL);
++ bRet = BioAPI_Verify(bspHandle, &maxFAR, NULL, &bPrecedence, &BIR, NULL, &result, &FARAchieved, NULL, NULL, -1, NULL);
+ switch(bRet) {
+ case BioAPI_OK:
+ if (result == BioAPI_TRUE) {
+@@ -370,7 +371,7 @@
+ }
+
+ bytesRead = fread(&(tempBir->Header), bytes, 1, inputFile);
+- bytes = (tempBir->Header.Length) - sizeof(BioAPI_DATA);
++ bytes = (tempBir->Header.Length) - sizeof(BioAPI_BIR_HEADER);
+ tempBir->BiometricData = (BioAPI_BIR_BIOMETRIC_DATA_PTR)malloc(bytes);
+ if (tempBir->BiometricData == 0) {
+ syslog(LOG_ALERT, "Unable to allocate memory.");
diff --git a/sys-auth/pam_bioapi/metadata.xml b/sys-auth/pam_bioapi/metadata.xml
new file mode 100644
index 000000000000..87871acf04f2
--- /dev/null
+++ b/sys-auth/pam_bioapi/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wolf31o2@gentoo.org</email>
+ <name>Chris Gianelloni</name>
+</maintainer>
+<maintainer>
+ <email>jochen.maes@sejo.be</email>
+ <name>Jochen Maes</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.2.1.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.2.1.ebuild
new file mode 100644
index 000000000000..62e198de4a18
--- /dev/null
+++ b/sys-auth/pam_bioapi/pam_bioapi-0.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.2.1.ebuild,v 1.1 2006/10/05 13:50:35 wolf31o2 Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="PAM interface for biometric auth"
+HOMEPAGE="http://www.qrivy.net/~michael/blua/"
+SRC_URI="http://www.qrivy.net/~michael/blua/pam_bioapi/pam_bioapi-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-auth/bioapi
+ sys-auth/tfm-fingerprint"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/pam_bioapi.c-${PV}.patch
+}
+
+src_compile() {
+ export CPPFLAGS="${CPPFLAGS} -I/opt/bioapi/include"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodir /lib/security
+ mv ${D}/usr/lib/security/* ${D}/lib/security
+ rmdir ${D}/usr/lib/security
+}