summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-03 22:12:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-03 22:12:08 +0000
commit98a87b8d78c4b24c16c695fdbda843c2ba232a6e (patch)
tree218c957221bdd78a7446bb2e76b44ae0b4514a90 /sys-apps
parentStable on alpha. (diff)
downloadhistorical-98a87b8d78c4b24c16c695fdbda843c2ba232a6e.tar.gz
historical-98a87b8d78c4b24c16c695fdbda843c2ba232a6e.tar.bz2
historical-98a87b8d78c4b24c16c695fdbda843c2ba232a6e.zip
stabilize
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86+/memtest86+-1.55.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sys-apps/memtest86+/memtest86+-1.55.ebuild b/sys-apps/memtest86+/memtest86+-1.55.ebuild
index 7bd5d17ac8b0..75847c5d63d8 100644
--- a/sys-apps/memtest86+/memtest86+-1.55.ebuild
+++ b/sys-apps/memtest86+/memtest86+-1.55.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.55.ebuild,v 1.5 2005/07/07 18:57:12 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86+/memtest86+-1.55.ebuild,v 1.6 2005/08/03 22:12:08 vapier Exp $
inherit mount-boot eutils
DESCRIPTION="Memory tester based on memtest86"
HOMEPAGE="http://www.memtest.org/"
SRC_URI="http://www.memtest.org/download/${PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 -ppc"
+KEYWORDS="-* amd64 x86"
IUSE="serial"
-DEPEND="virtual/libc"
RESTRICT="test"
+DEPEND=""
+
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# send the DOS newlines where they belong - /dev/null ;>
sed -e 's/\x0d//g' -i Makefile || die
@@ -31,8 +33,8 @@ src_compile() {
}
src_install() {
- dodir /boot/memtest86plus
- cp memtest.bin ${D}/boot/memtest86plus/memtest.bin || die
+ insinto /boot/memtest86plus
+ doins memtest.bin || die
dodoc README README.build-process
}
@@ -45,13 +47,14 @@ pkg_postinst() {
einfo " > title=Memtest86Plus"
# a little magic to make users' life as easy as possible ;)
+ local fstab=${ROOT}/etc/fstab
bootpart=0
root="(hd0,0)"
- res=`grep /boot /etc/fstab | grep -v "^#" | awk '{print $1}' | grep '/dev/hd[a-z0-9]\+'`
+ res=$(awk '$2 == "/boot" {print $1}' "${fstab}")
if [ -n "${res}" ] ; then
bootpart=1
else
- res=`grep -v '^#' /etc/fstab | grep -e '/dev/hd[a-z0-9]\+[[:space:]]\+\/[[:space:]]\+' | \
+ res=`grep -v '^#' "${fstab}" | grep -e '/dev/hd[a-z0-9]\+[[:space:]]\+\/[[:space:]]\+' | \
awk '{print $1}'`
fi