summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-17 17:22:07 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-17 17:22:07 +0000
commit6e3c27f74a6a06e83e2e4be227ae28d3648c9640 (patch)
tree51ea4a94101b590fcb8f9b49d70a5e51744dbc5c /sys-apps
parentInitial ebuild. (diff)
downloadhistorical-6e3c27f74a6a06e83e2e4be227ae28d3648c9640.tar.gz
historical-6e3c27f74a6a06e83e2e4be227ae28d3648c9640.tar.bz2
historical-6e3c27f74a6a06e83e2e4be227ae28d3648c9640.zip
Closes #8816.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openmosix-user/ChangeLog7
-rw-r--r--sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r41
-rw-r--r--sys-apps/openmosix-user/openmosix-user-0.2.4-r4.ebuild95
3 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/openmosix-user/ChangeLog b/sys-apps/openmosix-user/ChangeLog
index 1ed3f64f58d1..f78273be51cc 100644
--- a/sys-apps/openmosix-user/ChangeLog
+++ b/sys-apps/openmosix-user/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-apps/openmosix-user
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.7 2002/10/13 22:27:01 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.8 2002/10/17 17:22:07 tantive Exp $
+* openmosix-user-0.2.4-r4 (17 Oct 2002)
+
+ 17 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Sometimes the old method of creating the Makefile could result
+ in a Makefile of zero length. Fixed and closed #8816.
* openmosix-user-0.2.4-r3 (14 Oct 2002)
diff --git a/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r4 b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r4
new file mode 100644
index 000000000000..85f88e730ce3
--- /dev/null
+++ b/sys-apps/openmosix-user/files/digest-openmosix-user-0.2.4-r4
@@ -0,0 +1 @@
+MD5 2e4e630a391900b331323bffea5c5547 openMosixUserland-0.2.4.tgz 65494
diff --git a/sys-apps/openmosix-user/openmosix-user-0.2.4-r4.ebuild b/sys-apps/openmosix-user/openmosix-user-0.2.4-r4.ebuild
new file mode 100644
index 000000000000..ffc209e2adcc
--- /dev/null
+++ b/sys-apps/openmosix-user/openmosix-user-0.2.4-r4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/openmosix-user-0.2.4-r4.ebuild,v 1.1 2002/10/17 17:22:07 tantive Exp $
+
+S=${WORKDIR}/openMosixUserland-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openMosixUserland-${PV}.tgz"
+HOMEPAGE="http://www.openmosix.com"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ sys-devel/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+
+pkg_setup() {
+ if [ -z "`readlink /usr/src/linux|grep openmosix`" ]; then
+ eerror
+ eerror "Your linux kernel sources do not appear to be openmosix,"
+ eerror "please check your /usr/src/linux symlink."
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat Makefile | sed s/DIRS.*=/DIRS=autodiscovery/g > Makefile.tmp
+ mv Makefile.tmp Makefile
+ cat > configuration << EOF
+
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\$(OPENMOSIX)/include ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+
+#non-alpha-mode for autodiscovery (omdiscd)
+cd ${S}/autodiscovery
+cat openmosix.c | grep -v "define ALPHA" > openmosix.c.tmp
+mv openmosix.c.tmp openmosix.c
+cat showmap.c | grep -v "define ALPHA" > showmap.c.tmp
+mv showmap.c.tmp showmap.c
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install () {
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ dodir /usr/share/include
+ dodir /usr/bin
+ dodir /bin
+ ln -s /usr/bin/migrate ${D}/bin/migrate
+ ln -s /usr/bin/mmon ${D}/bin/mmon
+ ln -s /usr/bin/mosctl ${D}/bin/mosctl
+ ln -s /usr/bin/mosrun ${D}/bin/mosrun
+ dodir /usr/share/man/man1
+ make INSTALLBASEDIR=${D}usr \
+ INSTALLMANDIR=${D}usr/share/man \
+ INSTALLEXTRADIR=${D}usr/share \
+ DESTDIR=${D} \
+ INSTALLDIR=${D}usr \
+ install
+
+ dodoc COPYING README
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/mosix.map and then type:"
+ einfo " # rc-update add openmosix default"
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.18-openmosix-r1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.18)"
+ einfo
+}