summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-31 18:15:54 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-31 18:15:54 +0000
commitd8a3e3a5d4968685fe36e563c64a008f20ea91f9 (patch)
tree29e31ee1245a4e2e818ee606c13b65041a19059e /sys-apps/restartd/restartd-0.2.2.ebuild
parentRestrict Jython ABIs. (diff)
downloadhistorical-d8a3e3a5d4968685fe36e563c64a008f20ea91f9.tar.gz
historical-d8a3e3a5d4968685fe36e563c64a008f20ea91f9.tar.bz2
historical-d8a3e3a5d4968685fe36e563c64a008f20ea91f9.zip
Version bump. Respect LDFLAGS (bug #337606), CC. Remove old, failing ebuild.
Package-Manager: portage-2.2.0_alpha10/cvs/Linux i686
Diffstat (limited to 'sys-apps/restartd/restartd-0.2.2.ebuild')
-rw-r--r--sys-apps/restartd/restartd-0.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/restartd/restartd-0.2.2.ebuild b/sys-apps/restartd/restartd-0.2.2.ebuild
new file mode 100644
index 000000000000..98d19d5e0e01
--- /dev/null
+++ b/sys-apps/restartd/restartd-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/restartd/restartd-0.2.2.ebuild,v 1.1 2010/12/31 18:15:53 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/_alpha/.a-}
+DESCRIPTION="A daemon for checking your running and not running processes"
+HOMEPAGE="http://packages.debian.org/unstable/utils/restartd"
+SRC_URI="mirror://debian/pool/main/r/restartd/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile -e 's|-o restartd|$(LDFLAGS) &|g' || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) C_ARGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /etc /usr/sbin /usr/share/man/man8 /usr/share/man/fr/man8/
+ emake DESTDIR="${D}" install || die
+}