summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-01-08 02:34:26 +0000
committerAron Griffis <agriffis@gentoo.org>2002-01-08 02:34:26 +0000
commitee578de835a76c48f6756e9d976e7a1aa95e21cd (patch)
treeac5c43ce06f77431b25a2b1050bc3ec9b2eb1aae /sys-apps/quota
parentRemoved previous documentation location patches, they aren't needed (diff)
downloadhistorical-ee578de835a76c48f6756e9d976e7a1aa95e21cd.tar.gz
historical-ee578de835a76c48f6756e9d976e7a1aa95e21cd.tar.bz2
historical-ee578de835a76c48f6756e9d976e7a1aa95e21cd.zip
Added Linux quota tools (from sourceforge.net/projects/linuxquota).
Diffstat (limited to 'sys-apps/quota')
-rw-r--r--sys-apps/quota/files/digest-quota-3.031
-rw-r--r--sys-apps/quota/quota-3.03.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/quota/files/digest-quota-3.03 b/sys-apps/quota/files/digest-quota-3.03
new file mode 100644
index 000000000000..a65b60c25597
--- /dev/null
+++ b/sys-apps/quota/files/digest-quota-3.03
@@ -0,0 +1 @@
+MD5 799f6716346e239397d92680cead3f4d quota-3.03.tar.gz 184320
diff --git a/sys-apps/quota/quota-3.03.ebuild b/sys-apps/quota/quota-3.03.ebuild
new file mode 100644
index 000000000000..a03a881aa45b
--- /dev/null
+++ b/sys-apps/quota/quota-3.03.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.03.ebuild,v 1.1 2002/01/08 02:34:26 agriffis Exp $
+
+S=${WORKDIR}/quota-tools
+DESCRIPTION="Linux quota tools"
+SRC_URI="http://prdownloads.sourceforge.net/linuxquota/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ mkdir -p ${D}/{sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,2,3,8}}
+ make ROOTDIR=${D} install || die
+ install -m 644 warnquota.conf ${D}/etc
+}