summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-22 22:16:52 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-22 22:16:52 +0000
commit65174ba74336fd48422d020cac68bb4bc2483b98 (patch)
tree1b2f8b0d1e36065fc8dbdd40e2eab6c88e2c21f1 /sys-apps/netkit-base
parentbugfix (diff)
downloadhistorical-65174ba74336fd48422d020cac68bb4bc2483b98.tar.gz
historical-65174ba74336fd48422d020cac68bb4bc2483b98.tar.bz2
historical-65174ba74336fd48422d020cac68bb4bc2483b98.zip
Updated ebuild with a patch for ping posted by
ragnar@linalco.com (Ragnar Hojland Espinosa) on bug # 12023. Currently marked unstable.
Diffstat (limited to 'sys-apps/netkit-base')
-rw-r--r--sys-apps/netkit-base/ChangeLog12
-rw-r--r--sys-apps/netkit-base/files/digest-netkit-base-0.17-r71
-rw-r--r--sys-apps/netkit-base/files/netkit-base-0.17-wrong-byte-fix.patch20
-rw-r--r--sys-apps/netkit-base/netkit-base-0.17-r7.ebuild57
4 files changed, 89 insertions, 1 deletions
diff --git a/sys-apps/netkit-base/ChangeLog b/sys-apps/netkit-base/ChangeLog
index d4787494d4a3..8bbe41d2f43a 100644
--- a/sys-apps/netkit-base/ChangeLog
+++ b/sys-apps/netkit-base/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-apps/netkit-base
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/ChangeLog,v 1.6 2002/12/13 11:00:33 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/ChangeLog,v 1.7 2002/12/22 22:16:52 raker Exp $
+
+*netkit-base-0.17-r7 (22 Dec 2002)
+
+ 22 Dec 2002; Nick Hadaway <raker@gentoo.org>
+ netkit-base-0.17-r7.ebuild,
+ files/digest-netkit-base-0.17-r7,
+ files/netkit-base-0.17-wrong-byte-fix.patch :
+ Updated ebuild with a patch for ping posted by
+ ragnar@linalco.com (Ragnar Hojland Espinosa) on bug # 12023.
+ Currently marked unstable.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/sys-apps/netkit-base/files/digest-netkit-base-0.17-r7 b/sys-apps/netkit-base/files/digest-netkit-base-0.17-r7
new file mode 100644
index 000000000000..90e0df4a05c9
--- /dev/null
+++ b/sys-apps/netkit-base/files/digest-netkit-base-0.17-r7
@@ -0,0 +1 @@
+MD5 1f0193358e92559ec0f598b09ccbc0ec netkit-base-0.17.tar.gz 56473
diff --git a/sys-apps/netkit-base/files/netkit-base-0.17-wrong-byte-fix.patch b/sys-apps/netkit-base/files/netkit-base-0.17-wrong-byte-fix.patch
new file mode 100644
index 000000000000..2da89e57f3fc
--- /dev/null
+++ b/sys-apps/netkit-base/files/netkit-base-0.17-wrong-byte-fix.patch
@@ -0,0 +1,20 @@
+--- netkit-base-0.17/ping/ping.c.O 2002-12-12 16:11:40.000000000 +0100
++++ netkit-base-0.17/ping/ping.c 2002-12-12 16:14:26.000000000 +0100
+@@ -639,7 +639,7 @@ check_packet_data(void)
+ cp = INPACK_PAYLOAD;
+ dp = OUTPACK_PAYLOAD;
+
+- for (i=0; i<datalen-ICMP_MINLEN; i++) {
++ for (i=sizeof(struct timeval); i<datalen-ICMP_MINLEN; i++) {
+ if (cp[i] != dp[i]) {
+ printf("\n");
+ printf("wrong data byte #%d should be 0x%x "
+@@ -648,7 +648,7 @@ check_packet_data(void)
+ for (i=0; i<datalen-ICMP_MINLEN; i++) {
+ if ((i % 32) == 8)
+ printf("\n\t");
+- printf("%x ", cp[i]);
++ printf(" %x", cp[i]);
+ }
+ return;
+ }
diff --git a/sys-apps/netkit-base/netkit-base-0.17-r7.ebuild b/sys-apps/netkit-base/netkit-base-0.17-r7.ebuild
new file mode 100644
index 000000000000..abebed246549
--- /dev/null
+++ b/sys-apps/netkit-base/netkit-base-0.17-r7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/netkit-base-0.17-r7.ebuild,v 1.1 2002/12/22 22:16:52 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard linux net thingees -- inetd, ping"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+LICENSE="BSD"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ ${ARCH} == "alpha" ]; then
+ patch -p1 < ${FILESDIR}/netkit-base-0.17-alpha-ping-fix.patch || die
+ fi
+ patch -p1 < ${FILESDIR}/netkit-base-0.17-wrong-byte-fix.patch || die
+}
+
+src_compile() {
+ ./configure || die
+
+ cp MCONFIG MCONFIG.orig
+ #sed -e "s/-O2/${CFLAGS} -Wstrict-prototypes -fomit-frame-pointer/"
+ sed -e "s:^CFLAGS=.*:CFLAGS=${CFLAGS} -Wall -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline:" \
+ MCONFIG.orig > MCONFIG
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ exeopts -m 4755
+ exeinto /bin
+ doexe ping/ping
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}/etc.sample
+ sed -e 's:in\.telnetd$:in.telnetd -L /usr/sbin/telnetlogin:' \
+ < inetd.conf > inetd.conf.new
+ mv inetd.conf.new inetd.conf
+ cd ${S}
+
+ exeopts -m 755
+ exeinto /usr/bin
+ dosbin inetd/inetd
+ doman inetd/inetd.8 inetd/daemon.3 ping/ping.8
+
+ dodoc BUGS ChangeLog README
+ docinto samples ; dodoc etc.sample/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/inetd.rc6 inetd
+ fi
+}