summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-11 01:50:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-11 01:50:32 +0000
commit8a78d668ae86540eb4177b3f56eabb65016726e1 (patch)
tree9797a1439cf92fced8367124cd7d8291047162da /sys-apps/memtest86
parentstabilize (diff)
downloadhistorical-8a78d668ae86540eb4177b3f56eabb65016726e1.tar.gz
historical-8a78d668ae86540eb4177b3f56eabb65016726e1.tar.bz2
historical-8a78d668ae86540eb4177b3f56eabb65016726e1.zip
Disable src_test (since one doesnt exist) #77368 and only add PIC patch if toolchain supports stack-protector #76515.
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog6
-rw-r--r--sys-apps/memtest86/Manifest10
-rw-r--r--sys-apps/memtest86/memtest86-3.2.ebuild21
3 files changed, 20 insertions, 17 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index ca71f07efd2b..acfd077859fb 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/memtest86
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.23 2005/01/02 19:15:26 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.24 2005/01/11 01:50:32 vapier Exp $
+
+ 10 Jan 2005; Mike Frysinger <vapier@gentoo.org> memtest86-3.2.ebuild:
+ Disable src_test (since one doesnt exist) #77368 and only add PIC patch if
+ toolchain supports stack-protector #76515.
*memtest86-3.2 (02 Jan 2005)
diff --git a/sys-apps/memtest86/Manifest b/sys-apps/memtest86/Manifest
index ac75ab635592..a070add5b6dd 100644
--- a/sys-apps/memtest86/Manifest
+++ b/sys-apps/memtest86/Manifest
@@ -1,15 +1,15 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 e0d4b12d48ff97d1278fd932f114dffe ChangeLog 3636
+MD5 0076775a66ee96e6304169122b9f8f1d ChangeLog 3829
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 257bd95abb74ad08d91cc86bc48996d6 memtest86-3.2.ebuild 1932
+MD5 e2581cba8e65a0a7ff450d36acfb6e02 memtest86-3.2.ebuild 1947
MD5 64a30db4579e12539572f71ca895e1ed files/digest-memtest86-3.2 65
MD5 9b8f71a15e2d7236b658f1f9e0fb79df files/memtest86-3.2-test-pic.patch 641
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB4y0uroRuSHgZdywRAly+AJ9YEXlEtd7/MBWeXE/R8VmERULoFQCfUewI
-aFxp97l2Tj2oEF8ZXlKG7nI=
-=bQOz
+iD8DBQFB4zEBroRuSHgZdywRAhA5AJ90kQFOf9EqLcZJEyE6q3IZ444dnQCeIzY0
+75D6YLGCJfl++u6kpY4+V5I=
+=EtUi
-----END PGP SIGNATURE-----
diff --git a/sys-apps/memtest86/memtest86-3.2.ebuild b/sys-apps/memtest86/memtest86-3.2.ebuild
index 15d3c2fa897a..3a384b0fb78b 100644
--- a/sys-apps/memtest86/memtest86-3.2.ebuild
+++ b/sys-apps/memtest86/memtest86-3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.2 2005/01/11 01:34:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.3 2005/01/11 01:50:32 vapier Exp $
-inherit mount-boot eutils
+inherit mount-boot eutils flag-o-matic
DESCRIPTION="A stand alone memory test for x86 computers"
HOMEPAGE="http://www.memtest86.com/"
@@ -12,24 +12,23 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* x86"
IUSE="serial"
+RESTRICT="maketest"
DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- # bug 66630
- epatch ${FILESDIR}/${P}-test-pic.patch
+ test_flag -fno-stack-protector && \
+ epatch "${FILESDIR}"/${P}-test-pic.patch #66630
sed -i -e '/DISCARD/d' memtest_shared.lds
- if use serial ; then
- sed -i \
- -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' \
- config.h \
- || die
- fi
+ use serial && \
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h
}
src_compile() {