summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 01:42:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 01:42:49 +0000
commitba16c97e6f08171baa6f0ae53280c3e10ea62267 (patch)
tree3b820b057ceb344ddc0f99479a138f6708f1c573 /sys-apps/logwatch
parentCleaning (diff)
downloadhistorical-ba16c97e6f08171baa6f0ae53280c3e10ea62267.tar.gz
historical-ba16c97e6f08171baa6f0ae53280c3e10ea62267.tar.bz2
historical-ba16c97e6f08171baa6f0ae53280c3e10ea62267.zip
Version bump and add a cron script #83641 by Meder Bakirov.
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/ChangeLog10
-rw-r--r--sys-apps/logwatch/Manifest5
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-6.0.21
-rwxr-xr-xsys-apps/logwatch/files/logwatch5
-rw-r--r--sys-apps/logwatch/logwatch-6.0.2.ebuild59
5 files changed, 77 insertions, 3 deletions
diff --git a/sys-apps/logwatch/ChangeLog b/sys-apps/logwatch/ChangeLog
index 0a2dbd98b720..5abe912f1f1f 100644
--- a/sys-apps/logwatch/ChangeLog
+++ b/sys-apps/logwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/logwatch
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.21 2005/04/07 01:45:31 weeve Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.22 2005/04/29 01:42:48 vapier Exp $
+
+*logwatch-6.0.2 (29 Apr 2005)
+
+ 29 Apr 2005; Mike Frysinger <vapier@gentoo.org> +files/logwatch,
+ +logwatch-6.0.2.ebuild:
+ Version bump and add a cron script #83641 by Meder Bakirov.
07 Apr 2005; Jason Wever <weeve@gentoo.org> logwatch-5.2.2.ebuild:
Stable on SPARC.
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 47813adf6b3d..1c209c0dfe4e 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,8 +1,11 @@
-MD5 2d727b51e02400dee93a92472524ad88 ChangeLog 3603
+MD5 22ab79a27006d42716485e42219db8e3 ChangeLog 3791
MD5 4e550750cdcb0a6432c46d259d38e4db logwatch-4.3.2.ebuild 1345
MD5 70cb3442dbd2bafb307ea09f5eea8d03 logwatch-5.0.ebuild 1398
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 8eb1d712eab6b882df0d6d9e490d73db logwatch-5.2.2.ebuild 1404
+MD5 257be866b10f505f557e95605ea8d126 logwatch-6.0.2.ebuild 1348
MD5 cf548a7143dce1aba3792d0647ae4f90 files/digest-logwatch-4.3.2 65
MD5 4a5e8c25106385b7e823785f6c61855d files/digest-logwatch-5.0 63
MD5 e8d38d01460c2fcf26e92e8853bf6c84 files/digest-logwatch-5.2.2 66
+MD5 bdcfb03932e5e0dd4ea2b3eebc6d714e files/digest-logwatch-6.0.2 66
+MD5 edb003cbc0686ed4cf37db16025635f3 files/logwatch 98
diff --git a/sys-apps/logwatch/files/digest-logwatch-6.0.2 b/sys-apps/logwatch/files/digest-logwatch-6.0.2
new file mode 100644
index 000000000000..affe48dfab4c
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-6.0.2
@@ -0,0 +1 @@
+MD5 a3048abed19fedfa2d954de7ff6b40cb logwatch-6.0.2.tar.gz 153382
diff --git a/sys-apps/logwatch/files/logwatch b/sys-apps/logwatch/files/logwatch
new file mode 100755
index 000000000000..3640fcfe1c22
--- /dev/null
+++ b/sys-apps/logwatch/files/logwatch
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ -x /usr/sbin/logwatch.pl ] ; then
+ exec /usr/sbin/logwatch.pl 2>&1 > /dev/null
+fi
diff --git a/sys-apps/logwatch/logwatch-6.0.2.ebuild b/sys-apps/logwatch/logwatch-6.0.2.ebuild
new file mode 100644
index 000000000000..8bd957aa7e0e
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-6.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-6.0.2.ebuild,v 1.1 2005/04/29 01:42:48 vapier Exp $
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron
+ virtual/mta
+ dev-lang/perl
+ dev-perl/Tie-IxHash
+ dev-perl/Date-Calc
+ virtual/mailx"
+DEPEND=""
+
+src_install() {
+ dodir /etc/log.d/lib
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/scripts/shared
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ for i in scripts/logfiles/* ; do
+ exeinto /etc/log.d/$i
+ doexe $i/* || die "doexe $i failed"
+ done
+
+ exeinto /etc/log.d/lib
+ doexe lib/*.pm
+
+ exeinto /etc/log.d/scripts/services
+ doexe scripts/services/*
+
+ exeinto /etc/log.d/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /etc/log.d/conf
+ doins conf/logwatch.conf
+
+ insinto /etc/log.d/conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /etc/log.d/conf/services
+ doins conf/services/*
+
+ exeinto /etc/cron.daily
+ newexe ${FILESDIR}/logwatch.cron logwatch
+
+ doman logwatch.8
+ dodoc License project/CHANGES README HOWTO-Make-Filter
+}