summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-29 17:14:29 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-29 17:14:29 +0000
commit5cd1a16a5bd2c0a10fe2b4757b15d5cb84927e86 (patch)
treecb4b676e1a1787b129b174b80e725f4ef32b4781 /sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-5cd1a16a5bd2c0a10fe2b4757b15d5cb84927e86.tar.gz
historical-5cd1a16a5bd2c0a10fe2b4757b15d5cb84927e86.tar.bz2
historical-5cd1a16a5bd2c0a10fe2b4757b15d5cb84927e86.zip
Version bump (bug #343209 by jlec). Update SRC_URI, add lzma USE flag and dependency, and add a couple die statements to helper functions.
Package-Manager: portage-2.2.0_alpha2/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild
new file mode 100644
index 000000000000..c29e7a38186e
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-2.0.2.ebuild,v 1.1 2010/10/29 17:14:29 radhermit Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="http://kernel.org/pub/linux/utils/kernel/kexec/"
+SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lzma xen zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ lzma? ( app-arch/xz-utils )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.0-respect-LDFLAGS.patch"
+
+ # to disable the -fPIE -pie in the hardened compiler
+ if gcc-specs-pie ; then
+ filter-flags -fPIE
+ append-ldflags -nopie
+ fi
+}
+
+src_configure() {
+ econf $(use_with lzma) $(use_with xen) $(use_with zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doman kexec/kexec.8 || die "doman failed"
+ dodoc News AUTHORS TODO || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/kexec.init kexec || die
+ newconfd "${FILESDIR}"/kexec.conf kexec || die
+}