summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-31 10:40:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-31 10:40:07 +0000
commit1b0c94f8445baf89081c147a699e8e829cbc4ca2 (patch)
treedfe1fc9df5242e6ddf339f677c53031ce15725e2 /sys-apps/dmapi/dmapi-2.2.0.ebuild
parentfix the locale fix so that it works for apps other than adobe acrobat (diff)
downloadhistorical-1b0c94f8445baf89081c147a699e8e829cbc4ca2.tar.gz
historical-1b0c94f8445baf89081c147a699e8e829cbc4ca2.tar.bz2
historical-1b0c94f8445baf89081c147a699e8e829cbc4ca2.zip
Cleanup of XFS-related apps: dmapi, acl, xfsdump, attr.
Diffstat (limited to 'sys-apps/dmapi/dmapi-2.2.0.ebuild')
-rw-r--r--sys-apps/dmapi/dmapi-2.2.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.0.ebuild b/sys-apps/dmapi/dmapi-2.2.0.ebuild
new file mode 100644
index 000000000000..754a2228378c
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.0.ebuild,v 1.1 2004/08/31 10:40:07 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~ia64 ~amd64 ~alpha"
+IUSE="debug static"
+
+DEPEND="sys-fs/xfsprogs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.in || die
+}
+
+src_compile() {
+ if use debug; then
+ DEBUG=-DDEBUG
+ OPTIMIZER="-g"
+ CFLAGS=
+ CXXFLAGS=
+ export CFLAGS CXXFLAGS
+ else
+ DEBUG=-DNDEBUG
+ OPTIMIZER="${CFLAGS}"
+ fi
+ export DEBUG OPTIMIZER
+
+ # Some archs need the PLATFORM var unset
+ if hasq ${ARCH} mips ppc sparc ppc64 s390; then
+ unset PLATFORM
+ fi
+
+ autoconf || die
+
+ local myconf
+ LIBDIR="`get_libdir`"
+ myconf="${myconf} --libdir=/${LIBDIR} --libexecdir=/usr/${LIBDIR}"
+ myconf="${myconf} `use_enable !static shared`"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}