summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-02-05 02:11:33 +0000
committerJon Nall <nall@gentoo.org>2003-02-05 02:11:33 +0000
commit70bf20cebb6aecfc6af55bb3ca9b9d55ee987ca4 (patch)
treee557e49e391c07b26078969e307ee512ad05bbee /sys-apps/diffutils
parentinitial commit (diff)
downloadhistorical-70bf20cebb6aecfc6af55bb3ca9b9d55ee987ca4.tar.gz
historical-70bf20cebb6aecfc6af55bb3ca9b9d55ee987ca4.tar.bz2
historical-70bf20cebb6aecfc6af55bb3ca9b9d55ee987ca4.zip
fix for bug #13502; added help2man dep to fix man pages
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/ChangeLog9
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r3.ebuild78
-rw-r--r--sys-apps/diffutils/files/digest-diffutils-2.8.4-r31
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index 7547f99302b8..0f4e046e43b9 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/diffutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.12 2003/01/20 00:47:29 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.13 2003/02/05 02:11:33 nall Exp $
+
+*diffutils-2.8.4-r3 (04 Feb 2003)
+
+ 04 Feb 2003; Jon Nall <nall@gentoo.org> diffutils-2.8.4-r3.ebuild,
+ files/digest-diffutils-2.8.4-r3 :
+ filter -mpowerpc-gfxopt out of CFLAGS to fix #13502;
+ add deps on help2man to fix broken man pages
*diffutils-2.8.4-r2 (20 Jan 2003)
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
new file mode 100644
index 000000000000..7bb5197fca86
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild,v 1.1 2003/02/05 02:11:33 nall Exp $
+
+IUSE="nls build"
+
+inherit eutils || die "I lost my inheritence"
+inherit flag-o-matic || die "I lost my inheritence"
+
+# sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
+# this fixes bug #13502
+filter-flags "-mpowerpc-gfxopt"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools to make diffs and compare files"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !build? ( sys-apps/texinfo sys-apps/help2man )"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if [ -n "`use build`" ]
+ then
+ #disable texinfo building so we can remove the dep
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:SUBDIRS = doc:SUBDIRS =:' \
+ Makefile.in.orig > Makefile.in
+ fi
+
+ # Build fails with make -j5 or greater on pentium4. This is because
+ # the jobs creating the opjects, which depend on paths.h is sheduled
+ # at the same time paths.h is generated. This patch just fix a small
+ # typeo that caused this. This closes bug #8934.
+ # <azarah@gentoo.org> (14 Oct 2002)
+ cd ${S}; epatch ${FILESDIR}/${P}-Makefile-fix-typeo.patch
+
+ # Removes waitpid() call after pclose() on piped diff stream, closing
+ # bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
+ cd ${S}; epatch ${FILESDIR}/${P}-sdiff-no-waitpid.patch
+}
+
+src_compile() {
+ local myconf=""
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+
+ econf --build=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-apps/diffutils/files/digest-diffutils-2.8.4-r3 b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r3
new file mode 100644
index 000000000000..ab1523b47820
--- /dev/null
+++ b/sys-apps/diffutils/files/digest-diffutils-2.8.4-r3
@@ -0,0 +1 @@
+MD5 a9c028579abc79ecd6842d60a13abf1d diffutils-2.8.4.tar.gz 828766