summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-24 05:26:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-24 05:26:29 +0000
commit071ac1f80c2abf181eb70a176fd65bc2c46ffad0 (patch)
tree86c957279312623c277e2745722f5dd521cb6e72 /sys-apps/dcron
parentconversion from /etc/svc.d to /etc/supervise and /var/supervise (diff)
downloadhistorical-071ac1f80c2abf181eb70a176fd65bc2c46ffad0.tar.gz
historical-071ac1f80c2abf181eb70a176fd65bc2c46ffad0.tar.bz2
historical-071ac1f80c2abf181eb70a176fd65bc2c46ffad0.zip
conversion from /etc/svc.d to /etc/supervise and /var/supervise
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/dcron-2.7.ebuild13
-rwxr-xr-xsys-apps/dcron/files/dcron2
2 files changed, 7 insertions, 8 deletions
diff --git a/sys-apps/dcron/dcron-2.7.ebuild b/sys-apps/dcron/dcron-2.7.ebuild
index cf4c03ee30fd..7edf4591325d 100644
--- a/sys-apps/dcron/dcron-2.7.ebuild
+++ b/sys-apps/dcron/dcron-2.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7.ebuild,v 1.3 2000/12/23 00:29:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7.ebuild,v 1.4 2000/12/24 05:26:17 drobbins Exp $
A=dcron27.tgz
S=${WORKDIR}/dcron
@@ -30,15 +30,14 @@ src_install() {
dodoc CHANGELOG README
#set up supervise support
- dodir /etc/svc.d/services/dcron
- exeinto /etc/svc.d/services/dcron
+ dodir /var/supervise/dcron /etc/supervise
+ exeinto /var/supervise/dcron
newexe ${FILESDIR}/dcron-run run
#this next line tells svcan to start the log process too (and set up a pipe)
- chmod +t ${D}/etc/svc.d/services/dcron
- exeinto /etc/svc.d/services/log
+ chmod +t ${D}/var/supervise/dcron
+ exeinto /var/supervise/dcron/log
newexe ${FILESDIR}/log-run run
- dodir /etc/svc.d/control
- dosym ../services/dcron /etc/svc.d/control/dcron
+ dosym /var/supervise/cron /etc/supervise/cron
#install rc script
exeinto /etc/rc.d/init.d
diff --git a/sys-apps/dcron/files/dcron b/sys-apps/dcron/files/dcron
index 81103a91d9a2..c4d1efd59dba 100755
--- a/sys-apps/dcron/files/dcron
+++ b/sys-apps/dcron/files/dcron
@@ -6,7 +6,7 @@
SERVICE=dcron
EXE="/usr/sbin/crond"
-SVCDIR=/etc/svc.d/control/dcron
+SVCDIR=/etc/supervise/dcron
opts="start stop"
start() {