summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-05-28 19:31:54 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-05-28 19:31:54 +0000
commit09c8ea3f446e7633ccd2be1a1292e450eef0e701 (patch)
treeaa4480b37ae7e87e04fc899dc73f496997527159 /sys-apps/coreutils-darwin
parentFixed su issue. (diff)
downloadhistorical-09c8ea3f446e7633ccd2be1a1292e450eef0e701.tar.gz
historical-09c8ea3f446e7633ccd2be1a1292e450eef0e701.tar.bz2
historical-09c8ea3f446e7633ccd2be1a1292e450eef0e701.zip
Fixed more collisions.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/coreutils-darwin')
-rw-r--r--sys-apps/coreutils-darwin/ChangeLog6
-rw-r--r--sys-apps/coreutils-darwin/Manifest6
-rw-r--r--sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild4
-rw-r--r--sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild12
4 files changed, 17 insertions, 11 deletions
diff --git a/sys-apps/coreutils-darwin/ChangeLog b/sys-apps/coreutils-darwin/ChangeLog
index 9f79758a012d..c0a023d1b1b4 100644
--- a/sys-apps/coreutils-darwin/ChangeLog
+++ b/sys-apps/coreutils-darwin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils-darwin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.5 2005/05/28 19:16:23 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.6 2005/05/28 19:31:54 josejx Exp $
+
+ 28 May 2005; Joseph Jezak <josejx@gentoo.org> coreutils-darwin-5.0.ebuild,
+ coreutils-darwin-5.3.0.ebuild:
+ Fixed more collisions.
28 May 2005; Joseph Jezak <josejx@gentoo.org>
coreutils-darwin-5.3.0.ebuild:
diff --git a/sys-apps/coreutils-darwin/Manifest b/sys-apps/coreutils-darwin/Manifest
index 76826e6ae273..ebd46c3cda54 100644
--- a/sys-apps/coreutils-darwin/Manifest
+++ b/sys-apps/coreutils-darwin/Manifest
@@ -1,6 +1,6 @@
-MD5 995d481b3a3ddbea1180e053d00e7924 ChangeLog 827
+MD5 89bcf969526d0a94b130390dd3fdc34d ChangeLog 963
MD5 fc76b60032187aa3e2029ee04b00e773 metadata.xml 156
-MD5 ff4274c8a1c213bd12bab3dbf7a337ba coreutils-darwin-5.0.ebuild 5065
-MD5 368ed60b50fc2aa9568123a5303e60ab coreutils-darwin-5.3.0.ebuild 3326
+MD5 b21b93690310d127794b90cd99fc9e44 coreutils-darwin-5.0.ebuild 5072
+MD5 dbf287abeb1fd9b92f1d73cc68aa69f4 coreutils-darwin-5.3.0.ebuild 3403
MD5 e80d3d87cfbe40bc56636167ae5b4768 files/digest-coreutils-darwin-5.0 141
MD5 fadcaa23c9484df6bd9dd2eefce42003 files/digest-coreutils-darwin-5.3.0 69
diff --git a/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild b/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild
index 8f53eabfa907..7f35963a8963 100644
--- a/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild
+++ b/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild,v 1.2 2005/05/12 06:22:58 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.0.ebuild,v 1.3 2005/05/28 19:31:54 josejx Exp $
inherit eutils
@@ -36,7 +36,7 @@ EXISTINGUSR="basename chgrp cksum comm cut dirname \
printf sort split stat sum tail tee touch tr true \
tsort tty uname unexpand uniq users wc who whoami yes"
EXISTINGBIN="cat chmod cp date dd df echo expr ln ls mkdir mv pwd rm rmdir sleep stty sync test"
-EXISTINGUSBIN="chown chroot"
+EXISTINGUSBIN="chown chroot uptime"
EXISTINGSBIN="mknod"
src_unpack() {
diff --git a/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
index 883819a550fe..f96d80c47909 100644
--- a/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
+++ b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild,v 1.4 2005/05/28 19:16:23 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild,v 1.5 2005/05/28 19:31:54 josejx Exp $
inherit eutils
@@ -32,10 +32,11 @@ EXISTINGUSR="basename chgrp cksum comm cut dirname \
tsort tty uname unexpand uniq users wc who whoami yes"
EXISTINGBIN="cat chmod cp date dd df echo expr ln ls mkdir \
mv pwd rm rmdir sleep stty sync test"
-EXISTINGUSBIN="chown chroot"
+EXISTINGUSBIN="chown chroot groups uptime"
EXISTINGSBIN="mknod"
DONTLINK="[ kill hostname"
-TENFOUR="link unlink csplit nl pathchk"
+TENFOURBIN="link unlink csplit nl"
+TENFOURUSBIN="pathchk readlink"
src_compile() {
cd ${S}
@@ -60,11 +61,12 @@ src_install() {
dodir /usr/bin
rm -rf usr/lib
- cd bin
if [ "$MACOSX_DEPLOYMENT_TARGET" == "10.4" ]; then
- rm ${TENFOUR}
+ rm bin/${TENFOURBIN}
+ rm usr/bin/${TENFOURUSBIN}
fi
+ cd bin
rm ${EXISTINGBIN} ${EXISTINGUSR} ${EXISTINGUSBIN} ${EXISTINGSBIN} ${DONTLINK}
# Move the non-critical pacakges to /usr/bin