summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-10-05 19:25:49 +0000
committerNed Ludd <solar@gentoo.org>2003-10-05 19:25:49 +0000
commit468f7dc05494d05453b9f2db27d49f428736c626 (patch)
treea4a6ec655e2e5f3b253936ccc67e9363c0d82049 /sys-apps/chpax
parentAdded metadata.xml (diff)
downloadhistorical-468f7dc05494d05453b9f2db27d49f428736c626.tar.gz
historical-468f7dc05494d05453b9f2db27d49f428736c626.tar.bz2
historical-468f7dc05494d05453b9f2db27d49f428736c626.zip
version bump of chpax, adds manpage, little more verbose when -v is used in combo with other flags. this should go stable pretty quickly
Diffstat (limited to 'sys-apps/chpax')
-rw-r--r--sys-apps/chpax/ChangeLog9
-rw-r--r--sys-apps/chpax/Manifest4
-rw-r--r--sys-apps/chpax/chpax-0.5.ebuild41
3 files changed, 53 insertions, 1 deletions
diff --git a/sys-apps/chpax/ChangeLog b/sys-apps/chpax/ChangeLog
index 12a5305033a9..d625659b5c13 100644
--- a/sys-apps/chpax/ChangeLog
+++ b/sys-apps/chpax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/chpax
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/ChangeLog,v 1.7 2003/09/26 09:06:26 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/ChangeLog,v 1.8 2003/10/05 19:25:48 solar Exp $
+
+*chpax-0.5 (05 Oct 2003)
+
+ 05 Oct 2003; <solar@gentoo.org> chpax-0.5.ebuild, files/pax-conf.d,
+ files/pax-init.d:
+ version bump of chpax, adds manpage, little more verbose when -v is used in
+ combo with other flags. this should go stable pretty quickly
26 Sep 2003; <solar@gentoo.org> chpax-0.4.ebuild:
marking stable for sparc
diff --git a/sys-apps/chpax/Manifest b/sys-apps/chpax/Manifest
index c9c4b814dec2..bacae5d56ec3 100644
--- a/sys-apps/chpax/Manifest
+++ b/sys-apps/chpax/Manifest
@@ -1,4 +1,8 @@
MD5 04c07649c132de56243ab26d21cfcbfb ChangeLog 883
MD5 49f11ae4512178f15981e4105f3219bd chpax-0.4.ebuild 772
MD5 e3de83396baf3f43d8213367ba434daf metadata.xml 339
+MD5 289a7fc6764b0f5b695dcbc01ee1b844 chpax-0.5.ebuild 953
+MD5 10c35ed1761b215e4602ba951a94ab3e files/pax-init.d 962
MD5 e0bef5df8955711a482c1d29f060b6ac files/digest-chpax-0.4 59
+MD5 d95ac8cbc92ddd4a9e401455d79571f7 files/digest-chpax-0.5 59
+MD5 42cfb4d3b4160fc595b8ad9d3b97d28e files/pax-conf.d 698
diff --git a/sys-apps/chpax/chpax-0.5.ebuild b/sys-apps/chpax/chpax-0.5.ebuild
new file mode 100644
index 000000000000..eeea9e0ce98c
--- /dev/null
+++ b/sys-apps/chpax/chpax-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.5.ebuild,v 1.1 2003/10/05 19:25:49 solar Exp $
+
+# S=${WORKDIR}/chpax
+
+DESCRIPTION="Manages various PaX related flags for ELF32, ELF64, and a.out binaries."
+SRC_URI="http://pageexec.virtualave.net/chpax-${PV}.tar.gz"
+HOMEPAGE="http://pageexec.virtualave.net"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa"
+LICENSE="public-domain"
+SLOT="0"
+
+IUSE=""
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile{,.orig}
+ sed -e "s|-Wall|${CFLAGS} -Wall|" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake CC="${CC}" || die "Parallel Make Failed"
+}
+
+src_install() {
+ into /
+ dosbin chpax
+ fperms 700 /sbin/chpax
+
+ dodoc Changelog README
+ doman chpax.1
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pax-conf.d chpax
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pax-init.d chpax
+
+}