summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-21 01:35:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-21 01:35:50 +0000
commit81eddfbb8e987ab804c831c6b63d7cbc80bf8945 (patch)
treecfbd7df402630791cf48f47047c2cfbd2aaa055a /sys-apps/attr
parentget rid of flaky libc DEPEND (diff)
downloadhistorical-81eddfbb8e987ab804c831c6b63d7cbc80bf8945.tar.gz
historical-81eddfbb8e987ab804c831c6b63d7cbc80bf8945.tar.bz2
historical-81eddfbb8e987ab804c831c6b63d7cbc80bf8945.zip
Tweak the warning message #93348 by Doug Goldstein.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/ChangeLog11
-rw-r--r--sys-apps/attr/Manifest5
-rw-r--r--sys-apps/attr/attr-2.4.19-r1.ebuild57
-rw-r--r--sys-apps/attr/files/attr-2.4.19-attr_copy_file-suppress-warning.patch20
-rw-r--r--sys-apps/attr/files/digest-attr-2.4.19-r11
5 files changed, 91 insertions, 3 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index c4576a608a94..e260148c3b31 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/attr
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.48 2005/02/07 04:02:10 kumba Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.49 2005/05/21 01:35:50 vapier Exp $
+
+*attr-2.4.19-r1 (21 May 2005)
+
+ 21 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/attr-2.4.19-attr_copy_file-suppress-warning.patch,
+ +attr-2.4.19-r1.ebuild:
+ Tweak the warning message #93348 by Doug Goldstein.
06 Feb 2005; Joshua Kinard <kumba@gentoo.org> attr-2.4.19.ebuild:
Marked stable on mips.
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index 2d59c8d80df2..46febd7e435f 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1,5 +1,8 @@
-MD5 5275f7da90fea35f132c6e9c6497d8cc ChangeLog 6896
+MD5 853c62ae3d9243d77d45964479627c33 ChangeLog 7119
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 eeb475e34fe68073b231bb538260e24e attr-2.4.19-r1.ebuild 1425
MD5 6aacfb1280c73cfbe4ea404779c23fa7 attr-2.4.19.ebuild 1459
+MD5 9884f12ef497050faff6f6418acae8e2 files/digest-attr-2.4.19-r1 67
MD5 8c0ffc8078bf36ce6eb5c698e9df7e0f files/attr-no-man2pages.patch 398
MD5 9884f12ef497050faff6f6418acae8e2 files/digest-attr-2.4.19 67
+MD5 c09974172d4e6f9fd20a4c4b53c0a8d4 files/attr-2.4.19-attr_copy_file-suppress-warning.patch 715
diff --git a/sys-apps/attr/attr-2.4.19-r1.ebuild b/sys-apps/attr/attr-2.4.19-r1.ebuild
new file mode 100644
index 000000000000..d9457d8dfc7e
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.19-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.19-r1.ebuild,v 1.1 2005/05/21 01:35:50 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls debug"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ nls? ( sys-devel/gettext )
+ sys-devel/libtool"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+
+ epatch "${FILESDIR}"/${P}-attr_copy_file-suppress-warning.patch #93348
+ # More extensive man 2 documentation is found in the man-pages package,
+ # so disable the installation of them
+ epatch "${FILESDIR}"/${PN}-no-man2pages.patch
+}
+
+src_compile() {
+ if use debug ; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ econf \
+ $(use_enable nls gettext) \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-lib install-dev || die
+ prepalldocs
+}
diff --git a/sys-apps/attr/files/attr-2.4.19-attr_copy_file-suppress-warning.patch b/sys-apps/attr/files/attr-2.4.19-attr_copy_file-suppress-warning.patch
new file mode 100644
index 000000000000..1fb43b976560
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.19-attr_copy_file-suppress-warning.patch
@@ -0,0 +1,20 @@
+http://bugs.gentoo.org/93348
+
+ libattr/attr_copy_file.c | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+--- attr-2.4.22/libattr/attr_copy_file.c 2004-11-30 08:34:47.000000000 -0500
++++ attr/libattr/attr_copy_file.c 2005-05-20 11:49:25.000000000 -0400
+@@ -138,9 +138,9 @@
+ if (lsetxattr (dst_path, name, value, size, 0) != 0)
+ {
+ const char *qpath = quote (ctx, dst_path);
+- if (errno == ENOSYS) {
+- error (ctx, _("setting attributes for %s"),
+- qpath);
++ if (errno == ENOSYS || errno == EOPNOTSUPP) {
++ error (ctx, _("Metadata will be lost, "
++ "setting attributes for %s"), qpath);
+ ret = -1;
+ break; /* no hope of getting any further */
+ } else {
diff --git a/sys-apps/attr/files/digest-attr-2.4.19-r1 b/sys-apps/attr/files/digest-attr-2.4.19-r1
new file mode 100644
index 000000000000..603a636034af
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-2.4.19-r1
@@ -0,0 +1 @@
+MD5 0ea0d3bea5a58727eafd46fa1c0f09cc attr-2.4.19.src.tar.gz 103599