summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-17 17:55:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-17 17:55:16 +0000
commit510e9c4ee34ef7def3723f1d4e53d430675d0f86 (patch)
treed63c71813c8a9efe4089502ca514eae2ce5146a5 /sci-physics
parentModernize to make it consistent with other cernlib ebuilds (diff)
downloadhistorical-510e9c4ee34ef7def3723f1d4e53d430675d0f86.tar.gz
historical-510e9c4ee34ef7def3723f1d4e53d430675d0f86.tar.bz2
historical-510e9c4ee34ef7def3723f1d4e53d430675d0f86.zip
Initial import to the main tree from the science overlay
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/herwig/ChangeLog14
-rw-r--r--sci-physics/herwig/herwig-6.5.10.ebuild58
-rw-r--r--sci-physics/herwig/metadata.xml9
3 files changed, 81 insertions, 0 deletions
diff --git a/sci-physics/herwig/ChangeLog b/sci-physics/herwig/ChangeLog
new file mode 100644
index 000000000000..4d932a27b714
--- /dev/null
+++ b/sci-physics/herwig/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-physics/herwig
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/herwig/ChangeLog,v 1.1 2009/04/17 17:55:16 bicatali Exp $
+
+*herwig-6.5.10 (17 Apr 2009)
+
+ 17 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +herwig-6.5.10.ebuild:
+ Initial import to the main tree from the science overlay
+
+ 18 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +sci-physics/herwig/metadata.xml:
+ Initial import, ebuild from Ben Bannier, bug #257734
+
diff --git a/sci-physics/herwig/herwig-6.5.10.ebuild b/sci-physics/herwig/herwig-6.5.10.ebuild
new file mode 100644
index 000000000000..59a63dd9001c
--- /dev/null
+++ b/sci-physics/herwig/herwig-6.5.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/herwig/herwig-6.5.10.ebuild,v 1.1 2009/04/17 17:55:16 bicatali Exp $
+
+EAPI=2
+inherit versionator
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+MY_P=${PN}${PV1}${PV2}${PV3}
+MY_PINC="$(echo ${PN}|tr '[:lower:]' '[:upper:]')${PV1}${PV2}.INC"
+
+DESCRIPTION="High Energy Physics Event Generator"
+HOMEPAGE="http://hepwww.rl.ac.uk/theory/seymour/herwig/"
+
+COM_URI="http://hepwww.rl.ac.uk/theory/seymour/${PN}"
+SRC_URI="${COM_URI}/${MY_P}.f
+ ${COM_URI}/${MY_P}.inc
+ ${COM_URI}/${MY_PINC}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!sci-physics/cernlib-montecarlo[herwig]"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/* "${S}"
+}
+
+src_prepare() {
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ AC_PROG_LIBTOOL
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ cat > Makefile.am <<-EOF
+ lib_LTLIBRARIES = lib${PN}.la
+ lib${PN}_la_SOURCES = ${MY_P}.f
+ pkginclude_HEADERS = \
+ ${MY_PINC} \
+ ${MY_P}.inc
+
+ EOF
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/sci-physics/herwig/metadata.xml b/sci-physics/herwig/metadata.xml
new file mode 100644
index 000000000000..5141b913339a
--- /dev/null
+++ b/sci-physics/herwig/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ HERWIG is a Monte Carlo package for simulating Hadron Emission
+ Reactions With Interfering Gluons.
+</longdescription>
+</pkgmetadata>