summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-27 21:40:39 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-27 21:40:39 +0000
commit4a299fe4fdfae2b02560c67ec68cba7e79ff5b0c (patch)
treebaf02a0811933340de2109c96368783725d4b48f /sci-misc/comedi
parentStable on x86. (diff)
downloadhistorical-4a299fe4fdfae2b02560c67ec68cba7e79ff5b0c.tar.gz
historical-4a299fe4fdfae2b02560c67ec68cba7e79ff5b0c.tar.bz2
historical-4a299fe4fdfae2b02560c67ec68cba7e79ff5b0c.zip
Moved from app-sci/comedi to sci-misc/comedi.
Diffstat (limited to 'sci-misc/comedi')
-rw-r--r--sci-misc/comedi/ChangeLog23
-rw-r--r--sci-misc/comedi/Manifest16
-rw-r--r--sci-misc/comedi/comedi-0.7.67.ebuild25
-rw-r--r--sci-misc/comedi/comedi-0.7.68.ebuild30
-rw-r--r--sci-misc/comedi/files/digest-comedi-0.7.671
-rw-r--r--sci-misc/comedi/files/digest-comedi-0.7.681
-rw-r--r--sci-misc/comedi/metadata.xml9
7 files changed, 105 insertions, 0 deletions
diff --git a/sci-misc/comedi/ChangeLog b/sci-misc/comedi/ChangeLog
new file mode 100644
index 000000000000..bb8070207f1a
--- /dev/null
+++ b/sci-misc/comedi/ChangeLog
@@ -0,0 +1,23 @@
+# ChangeLog for app-sci/comedi
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/comedi/ChangeLog,v 1.1 2004/12/27 21:40:39 ribosome Exp $
+
+*comedi-0.7.68 (27 Dec 2004)
+
+ 27 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +comedi-0.7.67.ebuild, +comedi-0.7.68.ebuild:
+ Moved from app-sci/comedi to sci-misc/comedi.
+
+ 03 Oct 2004; <iggy@gentoo.org> comedi-0.7.68.ebuild:
+ switched custom ARCH setting code to use set_arch_to_* from eutils
+
+*comedi-0.7.68 (01 Mar 2004)
+
+ 01 Mar 2004; Caleb Tennis <caleb@gentoo.org> comedi-0.7.68.ebuild:
+ New version, cleanups to make it compile properly.
+
+*comedi-0.7.67 (20 Nov 2003)
+
+ 20 Nov 2003; Caleb Tennis <caleb@gentoo.org> comedi-0.7.67.ebuild, metadata.xml:
+ Initial import - lots of changes yet to come.
+
diff --git a/sci-misc/comedi/Manifest b/sci-misc/comedi/Manifest
new file mode 100644
index 000000000000..fcfff94f35cb
--- /dev/null
+++ b/sci-misc/comedi/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 06aa37b9cb896b83a0ceb5a7a6b2ada7 comedi-0.7.68.ebuild 682
+MD5 50a807df2d3d0a79d4fb9b3ad4c29c4b comedi-0.7.67.ebuild 592
+MD5 207560e5ad2a77c5c3f83433acf9002a ChangeLog 639
+MD5 2134be6a8452efc15d542b70b134dcc7 metadata.xml 249
+MD5 804f8a7a298030bd85bd7f91df6388ac files/digest-comedi-0.7.67 65
+MD5 6c65ff5c4dd2926c5e7773cf22b307c4 files/digest-comedi-0.7.68 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBYMIcMSkoRwEucGERApBbAKCpWaEdvdMS6h6hUNfx/AAmR634OQCg7fIw
+9mcbAzyU1rMMZtmZV8c7dOw=
+=ulGq
+-----END PGP SIGNATURE-----
diff --git a/sci-misc/comedi/comedi-0.7.67.ebuild b/sci-misc/comedi/comedi-0.7.67.ebuild
new file mode 100644
index 000000000000..515f5fbedad0
--- /dev/null
+++ b/sci-misc/comedi/comedi-0.7.67.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/comedi/comedi-0.7.67.ebuild,v 1.1 2004/12/27 21:40:39 ribosome Exp $
+
+inherit kernel-mod
+
+DESCRIPTION="Comedi - COntrol and MEasurement Device Interface for Linux"
+SRC_URI="ftp://ftp.comedi.org/pub/comedi/${P}.tar.gz"
+HOMEPAGE="http://www.comedi.org"
+KEYWORDS="x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile()
+{
+ kernel-mod_getversion
+ ./configure --prefix=${D}/usr --with-linuxdir=${KERNEL_DIR}
+ emake
+}
+
+src_install()
+{
+ make install
+}
diff --git a/sci-misc/comedi/comedi-0.7.68.ebuild b/sci-misc/comedi/comedi-0.7.68.ebuild
new file mode 100644
index 000000000000..1b1c5cc07519
--- /dev/null
+++ b/sci-misc/comedi/comedi-0.7.68.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/comedi/comedi-0.7.68.ebuild,v 1.1 2004/12/27 21:40:39 ribosome Exp $
+
+inherit kernel-mod eutils
+
+DESCRIPTION="Comedi - COntrol and MEasurement Device Interface for Linux"
+SRC_URI="ftp://ftp.comedi.org/pub/comedi/${P}.tar.gz"
+HOMEPAGE="http://www.comedi.org"
+KEYWORDS="x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile()
+{
+ kernel-mod_getversion
+
+ addpredict ${KERNEL_DIR}
+
+ set_arch_to_kernel
+ ./configure --prefix=${D}/usr --libdir=${D}/lib --with-linuxdir=${KERNEL_DIR}
+ emake
+}
+
+src_install()
+{
+ make install
+ set_arch_to_portage
+}
diff --git a/sci-misc/comedi/files/digest-comedi-0.7.67 b/sci-misc/comedi/files/digest-comedi-0.7.67
new file mode 100644
index 000000000000..47af9eacbe9e
--- /dev/null
+++ b/sci-misc/comedi/files/digest-comedi-0.7.67
@@ -0,0 +1 @@
+MD5 bbea2609fdcb53a9989fb361150fb839 comedi-0.7.67.tar.gz 703539
diff --git a/sci-misc/comedi/files/digest-comedi-0.7.68 b/sci-misc/comedi/files/digest-comedi-0.7.68
new file mode 100644
index 000000000000..4a908855bdbb
--- /dev/null
+++ b/sci-misc/comedi/files/digest-comedi-0.7.68
@@ -0,0 +1 @@
+MD5 0cd3506b5c555ca09d597f7b8a85c785 comedi-0.7.68.tar.gz 862403
diff --git a/sci-misc/comedi/metadata.xml b/sci-misc/comedi/metadata.xml
new file mode 100644
index 000000000000..44a4ca1eb246
--- /dev/null
+++ b/sci-misc/comedi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>caleb@gentoo.org</email>
+ <name>Caleb Tennis</name>
+</maintainer>
+</pkgmetadata>