summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-11 09:14:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-11 09:14:54 +0000
commit35f1fa15d4b941f625a8ed90a0b01d06619805ae (patch)
tree21e2765a3b05ab538251019cae4d4c3c733e2f14 /sci-mathematics/octave/octave-2.1.72.ebuild
parentStable on hppa (bug #132931). (diff)
downloadhistorical-35f1fa15d4b941f625a8ed90a0b01d06619805ae.tar.gz
historical-35f1fa15d4b941f625a8ed90a0b01d06619805ae.tar.bz2
historical-35f1fa15d4b941f625a8ed90a0b01d06619805ae.zip
Clean up ebuild a bit more for CC/CXX/LDFLAGS definitions.
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'sci-mathematics/octave/octave-2.1.72.ebuild')
-rw-r--r--sci-mathematics/octave/octave-2.1.72.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-mathematics/octave/octave-2.1.72.ebuild b/sci-mathematics/octave/octave-2.1.72.ebuild
index f4301c410922..f83147b3f337 100644
--- a/sci-mathematics/octave/octave-2.1.72.ebuild
+++ b/sci-mathematics/octave/octave-2.1.72.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.5 2006/05/11 08:04:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.72.ebuild,v 1.6 2006/05/11 09:14:54 robbat2 Exp $
inherit flag-o-matic fortran
@@ -62,11 +62,11 @@ src_compile() {
myconf="${myconf} --with-mpi=mpi"
fi
else
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
myconf="${myconf} --without-mpi"
fi
-
- LDFLAGS="${LDFLAGS}" \
CC="${CC}" CXX="${CXX}" \
econf \
$(use_with hdf5) \