summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 19:32:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 19:32:30 +0000
commit04ffe3804109d6c745a48b4678f67499fdc32ba1 (patch)
tree1d4b8e6e44d67ba4802215ee88304fdfb269e2e1 /sci-libs
parentamd64 stable, bug #307045 (diff)
downloadhistorical-04ffe3804109d6c745a48b4678f67499fdc32ba1.tar.gz
historical-04ffe3804109d6c745a48b4678f67499fdc32ba1.tar.bz2
historical-04ffe3804109d6c745a48b4678f67499fdc32ba1.zip
Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay, keyworded as in overlay
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog8
-rw-r--r--sci-libs/gdal/gdal-1.6.3-r1.ebuild220
-rw-r--r--sci-libs/gsl/ChangeLog8
-rw-r--r--sci-libs/gsl/gsl-1.13-r2.ebuild88
-rw-r--r--sci-libs/lapack-reference/ChangeLog11
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild98
6 files changed, 429 insertions, 4 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 5c31775db40d..9d8e097c4b66 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.73 2010/02/23 05:29:53 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.74 2010/03/07 19:32:30 jlec Exp $
+
+*gdal-1.6.3-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +gdal-1.6.3-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
23 Feb 2010; Steve Arnold <nerdboy@gentoo.org> gdal-1.6.1.ebuild,
gdal-1.6.2.ebuild, gdal-1.6.3.ebuild:
diff --git a/sci-libs/gdal/gdal-1.6.3-r1.ebuild b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..8efe7bfb834f
--- /dev/null
+++ b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
@@ -0,0 +1,220 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.1 2010/03/07 19:32:30 jlec Exp $
+
+EAPI="3"
+WANT_AUTOCONF="2.5"
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby18"
+
+inherit autotools distutils eutils perl-module ruby toolchain-funcs
+
+DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+# need to get these arches updated on several libs first
+#KEYWORDS="~alpha ~hppa"
+
+IUSE="curl debug doc ecwj2k fits geos gif gml hdf hdf5 jpeg jpeg2k mysql \
+netcdf odbc png ogdi perl postgres python ruby sqlite threads"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=media-libs/tiff-3.9.1
+ sci-libs/libgeotiff
+ dev-libs/expat
+ curl? ( net-misc/curl )
+ jpeg? ( media-libs/jpeg )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ perl? ( dev-lang/perl )
+ python? ( virtual/python
+ dev-python/numpy )
+ ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
+ fits? ( sci-libs/cfitsio )
+ ogdi? ( sci-libs/ogdi )
+ gml? ( >=dev-libs/xerces-c-3 )
+ hdf5? ( >=sci-libs/hdf5-1.6.4 )
+ postgres? ( virtual/postgresql-base )
+ || (
+ netcdf? ( sci-libs/netcdf )
+ hdf? ( sci-libs/hdf )
+ )
+ || (
+ jpeg2k? ( media-libs/jasper )
+ ecwj2k? ( sci-libs/libecwj2 )
+ )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ geos? ( >=sci-libs/geos-2.2.1 )
+ sqlite? ( >=dev-db/sqlite-3 )"
+
+DEPEND="${RDEPEND}
+ perl? ( >=dev-lang/swig-1.3.32 )
+ python? ( >=dev-lang/swig-1.3.32 )
+ ruby? ( >=dev-lang/swig-1.3.32 )
+ doc? ( app-doc/doxygen )"
+
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
+ elog "User-specified configure options are ${GDAL_CONFIGURE_OPTS}."
+ else
+ elog "User-specified configure options are not set."
+ elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
+ fi
+}
+
+src_prepare() {
+ eaclocal
+ eautoconf
+
+ epatch "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
+ "${FILESDIR}"/${PN}-1.5.0-soname.patch \
+ "${FILESDIR}"/${PN}-1.5.1-python-install.patch \
+ "${FILESDIR}"/${PN}-1.6.0-swig-fix.patch \
+ "${FILESDIR}"/${PN}-1.6.1-ruby-make.patch
+
+ if useq hdf && useq netcdf; then
+ ewarn "Netcdf and HDF4 are incompatible due to certain tools in"
+ ewarn "common; HDF5 is now the preferred choice for HDF data."
+ die "Please disable either the hdf or netcdf use flag."
+ fi
+}
+
+src_configure() {
+
+ distutils_python_version
+
+ local pkg_conf="${GDAL_CONFIGURE_OPTS}"
+ local use_conf=""
+
+ pkg_conf="${pkg_conf} --enable-shared=yes --with-pic \
+ --with-libgrass=no --without-libtool --with-expat=${EPREFIX}/usr"
+
+ use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
+ $(use_with postgres pg) $(use_with python) $(use_with ruby) \
+ $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
+ $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
+ $(use_with sqlite sqlite3 ="${EPREFIX}"/usr) $(use_with jpeg2k jasper) $(use_with odbc) \
+ $(use_with gml xerces) $(use_with hdf5) $(use_with curl) \
+ $(use_enable debug)"
+
+ # It can't find this
+ if useq ogdi ; then
+ use_conf="--with-ogdi=${EPREFIX}/usr/$(get_libdir) ${use_conf}"
+ fi
+
+ if useq mysql ; then
+ use_conf="--with-mysql=${EPREFIX}/usr/bin/mysql_config ${use_conf}"
+ fi
+
+ if useq gif ; then
+ use_conf="--with-gif=internal ${use_conf}"
+ else
+ use_conf="--with-gif=no ${use_conf}"
+ fi
+
+ if useq python ; then
+ use_conf="--with-pymoddir=${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages \
+ ${use_conf}"
+ fi
+
+ # Fix doc path just in case
+ sed -i -e "s:@exec_prefix@/doc:@exec_prefix@/share/doc/${PF}/html:g" \
+ GDALmake.opt.in || die "sed gdalmake.opt failed"
+
+ econf ${pkg_conf} ${use_conf} || die "econf failed"
+}
+
+src_compile() {
+ local i
+ for i in perl ruby python; do
+ if useq $i; then
+ rm "${S}"/swig/$i/*_wrap.cpp
+ emake -C "${S}"/swig/$i generate || \
+ die "make generate failed for swig/$i"
+ fi
+ done
+
+ # parallel makes fail on the ogr stuff (C++, what can I say?)
+ # also failing with gcc4 in libcsf
+ emake -j1 || die "emake failed"
+
+ if useq python; then
+ sed -i -e "s#library_dirs = #library_dirs = ${EPREFIX}/usr/$(get_libdir):#g" \
+ swig/python/setup.cfg || die "sed python setup.cfg failed"
+ sed -i -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
+ swig/python/GNUmakefile || die "sed python makefile failed"
+ fi
+
+ if useq perl ; then
+ cd "${S}"/swig/perl
+ perl-module_src_prep
+ perl-module_src_compile
+ cd "${S}"
+ fi
+
+ if useq doc ; then
+ make docs || die "make docs failed"
+ fi
+}
+
+src_install() {
+
+ if useq perl ; then
+ cd "${S}"/swig/perl
+ perl-module_src_install
+ sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
+ GDALmake.opt
+ cd "${S}"
+ fi
+
+ # einstall causes sandbox violations on /usr/lib/libgdal.so
+ emake DESTDIR="${D}" install \
+ || die "make install failed"
+
+ dodoc Doxyfile HOWTO-RELEASE NEWS
+
+ if useq doc ; then
+ dohtml html/* || die "install html failed"
+ docinto ogr
+ dohtml ogr/html/* || die "install ogr html failed"
+ fi
+
+ if useq python; then
+ newdoc swig/python/README.txt README-python.txt
+ dodir /usr/share/${PN}/samples
+ insinto /usr/share/${PN}/samples
+ doins swig/python/samples/*
+ fi
+
+ use perl && fixlocalpod
+}
+
+pkg_postinst() {
+ elog
+ elog "If you need libgrass support, then you must rebuild gdal, after"
+ elog "installing the latest Grass, and set the following option:"
+ elog
+ elog "GDAL_CONFIGURE_OPTS=--with-grass=\$GRASS_HOME emerge gdal"
+ elog
+ elog "GDAL is most useful with full graphics support enabled via various"
+ elog "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
+ elog "geos, and support for either netcdf or HDF4 is available, as well as"
+ elog "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
+ elog "and rebuilding gdal). HDF5 support is now included."
+ elog
+ elog "Note: tiff and geotiff are now hard depends, so no USE flags."
+ elog "Also, this package will check for netcdf before hdf, so if you"
+ elog "prefer hdf, please emerge hdf with USE=szip prior to emerging"
+ elog "gdal. Detailed API docs require doxygen (man pages are free)."
+ elog
+ elog "Check available image and data formats after building with"
+ elog "gdalinfo and ogrinfo (using the --formats switch)."
+ elog
+}
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index ceea6dc9525f..845c129f2f13 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gsl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.65 2010/01/30 19:07:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.66 2010/03/07 19:26:09 jlec Exp $
+
+*gsl-1.13-r2 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +gsl-1.13-r2.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
30 Jan 2010; Raúl Porcel <armin76@gentoo.org> gsl-1.13-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #299826
diff --git a/sci-libs/gsl/gsl-1.13-r2.ebuild b/sci-libs/gsl/gsl-1.13-r2.ebuild
new file mode 100644
index 000000000000..a679d0007a6f
--- /dev/null
+++ b/sci-libs/gsl/gsl-1.13-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.13-r2.ebuild,v 1.1 2010/03/07 19:26:09 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="The GNU Scientific Library"
+HOMEPAGE="http://www.gnu.org/software/gsl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cblas"
+
+RDEPEND="cblas? ( virtual/cblas )"
+DEPEND="${RDEPEND}
+ app-admin/eselect-cblas
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ ESELECT_PROF="gsl"
+ # prevent to use external cblas from a previously installed gsl
+ local current_lib=$(eselect cblas show | cut -d' ' -f2)
+ if use cblas && [[ ${current_lib} == gsl ]]; then
+ ewarn "USE flag cblas is set: linking gsl with an external cblas."
+ ewarn "However the current selected external cblas is gsl."
+ ewarn "Please install and/or eselect another cblas"
+ die "Circular gsl dependency"
+ fi
+}
+
+src_prepare() {
+ filter-flags -ffast-math
+ epatch "${FILESDIR}"/${P}-cblas.patch
+ epatch "${FILESDIR}"/${P}-cblas-vars.patch
+ eautoreconf
+
+ cp "${FILESDIR}"/eselect.cblas.gsl "${T}"/
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.cblas.gsl || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.cblas.gsl || die
+ fi
+}
+
+src_configure() {
+ if use cblas; then
+ export CBLAS_LIBS="$(pkg-config --libs cblas)"
+ export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
+ fi
+ econf $(use_with cblas)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+
+ # take care of pkgconfig file for cblas implementation.
+ sed -e "s/@LIBDIR@/$(get_libdir)/" \
+ -e "s/@PV@/${PV}/" \
+ -e "/^prefix=/s:=:=${EPREFIX}:" \
+ -e "/^libdir=/s:=:=${EPREFIX}:" \
+ "${FILESDIR}"/cblas.pc.in > cblas.pc \
+ || die "sed cblas.pc failed"
+ insinto /usr/$(get_libdir)/blas/gsl
+ doins cblas.pc || die "installing cblas.pc failed"
+ eselect cblas add $(get_libdir) "${T}"/eselect.cblas.gsl \
+ ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}
diff --git a/sci-libs/lapack-reference/ChangeLog b/sci-libs/lapack-reference/ChangeLog
index bc1c68072414..37c7f61cd1b8 100644
--- a/sci-libs/lapack-reference/ChangeLog
+++ b/sci-libs/lapack-reference/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/lapack-reference
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.49 2009/12/12 17:43:05 markusle Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.50 2010/03/07 19:31:08 jlec Exp $
+
+*lapack-reference-3.2.1-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +lapack-reference-3.2.1-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
12 Dec 2009; Markus Dittrich <markusle@gentoo.org>
lapack-reference-3.2.1.ebuild,
diff --git a/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..3bb1ac8cae26
--- /dev/null
+++ b/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild,v 1.1 2010/03/07 19:31:08 jlec Exp $
+
+EAPI="3"
+
+inherit eutils autotools flag-o-matic fortran multilib
+
+MyPN="${PN/-reference/}"
+PATCH_V="3.2.1"
+
+DESCRIPTION="FORTRAN reference implementation of LAPACK Linear Algebra PACKage"
+HOMEPAGE="http://www.netlib.org/lapack/index.html"
+SRC_URI="mirror://gentoo/${MyPN}-${PV}.tgz
+ mirror://gentoo/${PN}-${PATCH_V}-autotools.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+DEPEND="virtual/blas
+ dev-util/pkgconfig
+ app-admin/eselect-lapack"
+RDEPEND="virtual/blas
+ app-admin/eselect-lapack
+ doc? ( app-doc/lapack-docs )"
+
+S="${WORKDIR}/${MyPN}-${PV}"
+
+pkg_setup() {
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ if [[ ${FORTRANC} == if* ]]; then
+ ewarn "Using Intel Fortran at your own risk"
+ export LDFLAGS="$(raw-ldflags)"
+ export NOOPT_FFLAGS=-O
+ fi
+ ESELECT_PROF=reference
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}-${PATCH_V}-autotools.patch
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+ eautoreconf
+
+ # set up the testing routines
+ sed -e "s:g77:${FORTRANC}:" \
+ -e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
+ -e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
+ -e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \
+ -e "s:lapack\$(PLAT).a:SRC/.libs/liblapack.a:" \
+ make.inc.example > make.inc \
+ || die "Failed to set up make.inc"
+
+ cp "${FILESDIR}"/eselect.lapack.reference "${T}"/
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.lapack.reference || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.lapack.reference || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)/lapack/reference" \
+ --with-blas="$(pkg-config --libs blas)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die "dodoc failed"
+ eselect lapack add $(get_libdir) "${T}"/eselect.lapack.reference ${ESELECT_PROF}
+}
+
+src_test() {
+ cd "${S}"/TESTING/MATGEN
+ emake || die "Failed to create tmglib.a"
+ cd "${S}"/TESTING
+ emake || die "lapack-reference tests failed."
+}
+
+pkg_postinst() {
+ local p=lapack
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}