summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 20:22:26 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 20:22:26 +0000
commitbfa4be2f617a429f2ae532f304af5b45ed6a8553 (patch)
tree55d21ab4d936299d7f2ae97adc7e1e555e68ff7d /sci-libs/galib
parentFixed ChangeLog header. (diff)
downloadhistorical-bfa4be2f617a429f2ae532f304af5b45ed6a8553.tar.gz
historical-bfa4be2f617a429f2ae532f304af5b45ed6a8553.tar.bz2
historical-bfa4be2f617a429f2ae532f304af5b45ed6a8553.zip
Moved from dev-libs/galib to sci-libs/galib.
Diffstat (limited to 'sci-libs/galib')
-rw-r--r--sci-libs/galib/ChangeLog20
-rw-r--r--sci-libs/galib/Manifest5
-rw-r--r--sci-libs/galib/files/digest-galib-2.4.51
-rw-r--r--sci-libs/galib/files/galib-2.4.5-gcc3.3.patch12
-rw-r--r--sci-libs/galib/galib-2.4.5.ebuild40
-rw-r--r--sci-libs/galib/metadata.xml5
6 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/galib/ChangeLog b/sci-libs/galib/ChangeLog
new file mode 100644
index 000000000000..87111b8b082a
--- /dev/null
+++ b/sci-libs/galib/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for dev-libs/galib
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/ChangeLog,v 1.1 2004/12/28 20:22:26 ribosome Exp $
+
+*galib-2.4.5 (28 Dec 2004)
+
+ 28 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +files/galib-2.4.5-gcc3.3.patch, +galib-2.4.5.ebuild:
+ Moved from dev-libs/galib to sci-libs/galib.
+
+ 27 May 2004; Patrick Kursawe <phosphan@gentoo.org> galib-2.4.5.ebuild,
+ files/galib-2.4.5-gcc3.3.patch:
+ Fixing bug #51821 (gcc 3.3 compilation problems)
+
+*galib-2.4.5 (16 Oct 2003)
+
+ 16 Oct 2003; Patrick Kursawe <phosphan@gentoo.org> galib-2.4.5.ebuild,
+ metadata.xml:
+ Initial import, suggested in bug 26493
+
diff --git a/sci-libs/galib/Manifest b/sci-libs/galib/Manifest
new file mode 100644
index 000000000000..642736b6fb39
--- /dev/null
+++ b/sci-libs/galib/Manifest
@@ -0,0 +1,5 @@
+MD5 c4809d1cd6f013f1c07b47649e3a838a galib-2.4.5.ebuild 991
+MD5 a4636d00171db797ba7122847b29069e ChangeLog 521
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 e5d3346954cd2e5477fda23e6bc3c916 files/galib-2.4.5-gcc3.3.patch 438
+MD5 d2d902e9c308e59752fcd77e290a5b9d files/digest-galib-2.4.5 60
diff --git a/sci-libs/galib/files/digest-galib-2.4.5 b/sci-libs/galib/files/digest-galib-2.4.5
new file mode 100644
index 000000000000..8d869281d50a
--- /dev/null
+++ b/sci-libs/galib/files/digest-galib-2.4.5
@@ -0,0 +1 @@
+MD5 5a19b7692c3c18741cc0a120d36de165 galib245.tar.gz 385224
diff --git a/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch b/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch
new file mode 100644
index 000000000000..bba1dc122c90
--- /dev/null
+++ b/sci-libs/galib/files/galib-2.4.5-gcc3.3.patch
@@ -0,0 +1,12 @@
+--- ga/GARealGenome.h 2004-05-27 14:51:05.239072957 +0200
++++ ga/GARealGenome.h 2004-05-27 15:02:21.824011198 +0200
+@@ -18,6 +18,9 @@
+ typedef GAAlleleSet<float> GARealAlleleSet;
+ typedef GAAlleleSetArray<float> GARealAlleleSetArray;
+
++float GAAlleleSet<float>::allele() const;
++float GAAlleleSet<float>::allele(unsigned) const;
++
+ typedef GA1DArrayAlleleGenome<float> GARealGenome;
+
+ inline void GARealUniformInitializer(GAGenome& g){
diff --git a/sci-libs/galib/galib-2.4.5.ebuild b/sci-libs/galib/galib-2.4.5.ebuild
new file mode 100644
index 000000000000..d1a74d3b70ef
--- /dev/null
+++ b/sci-libs/galib/galib-2.4.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.5.ebuild,v 1.1 2004/12/28 20:22:26 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="library for using genetic algorithms in C++ programs"
+
+HOMEPAGE="http://lancet.mit.edu/ga/"
+SRC_URI="ftp://lancet.mit.edu/pub/ga/galib245.tar.gz"
+LICENSE="GAlib"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND=">=sys-apps/sed-4"
+
+S=${WORKDIR}/galib245
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
+ for file in examples/*.C ga/gaconfig.h; do
+ for thing in iostream fstream; do
+ sed -e "s:${thing}.h:${thing}:" -i ${file};
+ done
+ done
+}
+
+src_compile() {
+ make CXXFLAGS="${CXXFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dodir /usr/lib /usr/include
+ make LIB_DEST_DIR=${D}/usr/lib/ HDR_DEST_DIR=${D}/usr/include/ install || die
+ dohtml -r doc/*
+ dodoc RELEASE-NOTES README
+ cp -r examples ${D}/usr/share/doc/${PF}/
+}
diff --git a/sci-libs/galib/metadata.xml b/sci-libs/galib/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-libs/galib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>