summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-07-09 14:33:31 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-07-09 14:33:31 +0000
commit7050e1cf1c8cbc8778f71c185bd8b26b58bcdd53 (patch)
tree1402a0939407fe1fc3e4a519bceabc7ea69a7f52 /sci-biology/infernal/infernal-1.0.ebuild
parentstable x86, bug 277187 (diff)
downloadhistorical-7050e1cf1c8cbc8778f71c185bd8b26b58bcdd53.tar.gz
historical-7050e1cf1c8cbc8778f71c185bd8b26b58bcdd53.tar.bz2
historical-7050e1cf1c8cbc8778f71c185bd8b26b58bcdd53.zip
Import from Science overlay
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/infernal/infernal-1.0.ebuild')
-rw-r--r--sci-biology/infernal/infernal-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/infernal/infernal-1.0.ebuild b/sci-biology/infernal/infernal-1.0.ebuild
new file mode 100644
index 000000000000..9e1ea171a272
--- /dev/null
+++ b/sci-biology/infernal/infernal-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/infernal/infernal-1.0.ebuild,v 1.1 2009/07/09 14:33:31 weaver Exp $
+
+EAPI="2"
+
+DESCRIPTION="Inference of RNA alignments"
+HOMEPAGE="http://infernal.janelia.org/"
+SRC_URI="ftp://selab.janelia.org/pub/software/infernal/infernal.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="mpi"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --prefix="${D}/usr" \
+ $(use_enable mpi) || die
+}
+
+src_install() {
+ emake install || die
+ (cd documentation/manpages; for i in *; do newman ${i} ${i/.man/.1}; done)
+ insinto /usr/share/${PN}
+ doins -r benchmarks tutorial intro matrices
+ dodoc 00README* Userguide.pdf documentation/release-notes/*
+}