summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-21 20:00:40 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-21 20:00:40 +0000
commit90f72a9cf3b4098a3a387966e843eac42849d223 (patch)
treeeec61b1c63579ee90daab2bc2ea11778686cb771 /perl-core
parentsparc stable wrt #289342 (diff)
downloadhistorical-90f72a9cf3b4098a3a387966e843eac42849d223.tar.gz
historical-90f72a9cf3b4098a3a387966e843eac42849d223.tar.bz2
historical-90f72a9cf3b4098a3a387966e843eac42849d223.zip
Version bump
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Module-Build/ChangeLog8
-rw-r--r--perl-core/Module-Build/Module-Build-0.36.03.ebuild26
-rw-r--r--perl-core/Module-CoreList/ChangeLog8
-rw-r--r--perl-core/Module-CoreList/Module-CoreList-2.25.ebuild19
4 files changed, 59 insertions, 2 deletions
diff --git a/perl-core/Module-Build/ChangeLog b/perl-core/Module-Build/ChangeLog
index 92773af6c14a..196ea5535e08 100644
--- a/perl-core/Module-Build/ChangeLog
+++ b/perl-core/Module-Build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Module-Build
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.29 2010/01/17 19:03:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/ChangeLog,v 1.30 2010/01/21 19:57:56 tove Exp $
+
+*Module-Build-0.36.03 (21 Jan 2010)
+
+ 21 Jan 2010; Torsten Veller <tove@gentoo.org>
+ +Module-Build-0.36.03.ebuild:
+ Version bump
17 Jan 2010; Raúl Porcel <armin76@gentoo.org>
Module-Build-0.36.01.ebuild:
diff --git a/perl-core/Module-Build/Module-Build-0.36.03.ebuild b/perl-core/Module-Build/Module-Build-0.36.03.ebuild
new file mode 100644
index 000000000000..6d699b7cfefc
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.36.03.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.36.03.ebuild,v 1.1 2010/01/21 19:57:56 tove Exp $
+
+EAPI=2
+
+inherit versionator
+MODULE_AUTHOR=DAGOLDEN
+MY_P=${PN}-$(delete_version_separator 2)
+S=${WORKDIR}/${MY_P}
+inherit perl-module
+
+DESCRIPTION="Build and install Perl modules"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-perl/YAML-Tiny
+ >=virtual/perl-ExtUtils-CBuilder-0.27
+ >=virtual/perl-Archive-Tar-1.09
+ >=virtual/perl-Test-Harness-3.16"
+RDEPEND="${DEPEND}"
+PDEPEND=">=virtual/perl-ExtUtils-ParseXS-2.21"
+
+SRC_TEST="do"
diff --git a/perl-core/Module-CoreList/ChangeLog b/perl-core/Module-CoreList/ChangeLog
index 41d8ea07a850..05486162ef8c 100644
--- a/perl-core/Module-CoreList/ChangeLog
+++ b/perl-core/Module-CoreList/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Module-CoreList
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-CoreList/ChangeLog,v 1.8 2010/01/17 14:10:29 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-CoreList/ChangeLog,v 1.9 2010/01/21 20:00:40 tove Exp $
+
+*Module-CoreList-2.25 (21 Jan 2010)
+
+ 21 Jan 2010; Torsten Veller <tove@gentoo.org>
+ +Module-CoreList-2.25.ebuild:
+ Version bump
17 Jan 2010; Torsten Veller <tove@gentoo.org>
-Module-CoreList-2.17.ebuild, -Module-CoreList-2.20.ebuild,
diff --git a/perl-core/Module-CoreList/Module-CoreList-2.25.ebuild b/perl-core/Module-CoreList/Module-CoreList-2.25.ebuild
new file mode 100644
index 000000000000..005492b569b0
--- /dev/null
+++ b/perl-core/Module-CoreList/Module-CoreList-2.25.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-CoreList/Module-CoreList-2.25.ebuild,v 1.1 2010/01/21 20:00:40 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=RGARCIA
+inherit perl-module
+
+DESCRIPTION="what modules shipped with versions of perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=do