summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-06-09 07:34:26 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-06-09 07:34:26 +0000
commitfb7bb903550c5ef1848bab1d41a5fffb3f96e389 (patch)
treebde6698781cfc22e5a73194a42967c35237ecc87 /net-www
parentxfree r12 is much better for gcc 3.1 support.. so i'm making that the (diff)
downloadhistorical-fb7bb903550c5ef1848bab1d41a5fffb3f96e389.tar.gz
historical-fb7bb903550c5ef1848bab1d41a5fffb3f96e389.tar.bz2
historical-fb7bb903550c5ef1848bab1d41a5fffb3f96e389.zip
Updated w3m so a it would honor gpm use variable
Diffstat (limited to 'net-www')
-rw-r--r--net-www/w3m/ChangeLog11
-rw-r--r--net-www/w3m/files/digest-w3m-0.3-r21
-rw-r--r--net-www/w3m/w3m-0.3-r2.ebuild111
3 files changed, 122 insertions, 1 deletions
diff --git a/net-www/w3m/ChangeLog b/net-www/w3m/ChangeLog
index 698954bd67a0..10b5cdbc00bf 100644
--- a/net-www/w3m/ChangeLog
+++ b/net-www/w3m/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/w3m
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.3 2002/05/03 13:08:17 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.4 2002/06/09 07:34:26 naz Exp $
+
+
+*w3m-0.3-r2 (07 Jun 2002)
+
+ 07 Jun 2002; Michael Nazaroff <naz@gentoo.org> w3m-0.3-r2.ebuild:
+
+ Updated the ebuild and changed to the Customize configure option so I
+ could add a gpm use variable to the ebuild. This takes care of bug 3264.
+
*w3m-0.3-r1, w3m-0.2.2-r1 (03 May 2002)
diff --git a/net-www/w3m/files/digest-w3m-0.3-r2 b/net-www/w3m/files/digest-w3m-0.3-r2
new file mode 100644
index 000000000000..9f6e24c4479d
--- /dev/null
+++ b/net-www/w3m/files/digest-w3m-0.3-r2
@@ -0,0 +1 @@
+MD5 d1dab828926801901276fbe1bbfedd5a w3m-0.3.tar.gz 1061297
diff --git a/net-www/w3m/w3m-0.3-r2.ebuild b/net-www/w3m/w3m-0.3-r2.ebuild
new file mode 100644
index 000000000000..fc4d7ef04f12
--- /dev/null
+++ b/net-www/w3m/w3m-0.3-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.3-r2.ebuild,v 1.1 2002/06/09 07:34:26 naz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+SRC_URI="mirror://sourceforge/w3m/${P}.tar.gz"
+HOMEPAGE="http://w3m.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ imlib? ( media-libs/imlib )"
+
+src_compile() {
+ # It seems to be hard to configure this program in any reasonable
+ # way.
+ (
+ # Which directory do you want to put the binary?
+ echo /usr/bin
+ # Which directory do you want to put the support binary files?
+ echo /usr/lib/w3m
+ # Which directory do you want to put the helpfile?
+ echo /usr/share/w3m
+ # Which directory do you want to put the system wide w3m
+ # configuration file?
+ echo /etc/w3m
+ # Which language do you prefer?
+ # 1 - Japanese (charset ISO-2022-JP, EUC-JP, Shift_JIS)
+ # 2 - English (charset US_ASCII, ISO-8859-1, etc.)
+ echo 2
+ # Do you want to use Lynx-like key binding?
+ echo n
+ # Let's do some configurations. Choose config option among the list.
+ #
+ # 1 - Baby model (no color, no menu, no mouse, no cookie, no SSL)
+ # 2 - Little model (color, menu, no mouse, no cookie, no SSL)
+ # 3 - Mouse model (color, menu, mouse, no cookie, no SSL)
+ # 4 - Cookie model (color, menu, mouse, cookie, no SSL)
+ # 5 - Monster model (with everything; you need openSSL library)
+ # 6 - Customize
+ # Ok this was 5 but there is no option to disable gpm which not all
+ # people want, so I'm switching this to 6 instead.
+ # Which?
+ echo 6
+ # Do you want color ESC sequence for kterm/pxvt?
+ echo n
+ # Use mouse (requires xterm/kterm/gpm/sysmouse)?
+ use gpm &>/dev/null && echo y || echo n
+ # Use popup menu?
+ echo y
+ # Use cookie?
+ echo y
+ # Do you want SSL verification support?
+ # (Your SSL library must be version 0.8 or later)
+ use ssl &>/dev/null && echo y || echo n
+ # Digest Auth support [y]?
+ echo y
+ # Inline image support (you need Imlib library) [n]?
+ use imlib &>/dev/null && echo y || echo n
+ # ANSI color escape sequences support [n]?
+ echo y
+ # Use Migemo (Roma-ji search; Please see
+ # http://migemo.namazu.org/) [n]?
+ echo n
+ # External URI loader support [y]?
+ echo y
+ # Use w3mmail.cgi [y]?
+ echo y
+ # NNTP support [y]?
+ echo n
+ # Gopher support [y]?
+ echo n
+ # Use alarm support code [y]?
+ echo y
+ # Use mark operation [y]?
+ echo y
+ # Input your favorite editor program.
+ echo /usr/bin/vi
+ # Input your favorite external browser program.
+ echo /usr/bin/mozilla
+ # Input your favorite C-compiler.
+ echo gcc
+ # Input your favorite C flags.
+ printf "%s\n" "$CFLAGS"
+ # Which terminal library do you want to use? (type "none" if you
+ # do not need one)
+ printf "%s\n" "-lncurses"
+ # Input additional LD flags other than listed above, if any:
+ # (default: -lncurses) :
+ echo
+ ) | ./configure || die "configure failed"
+
+ # binary executables come prebuilt for 80386!
+ # clean it up and be sure to remake for ANY arch
+
+ cd ${S}/gc
+ make clean
+ cd -
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc doc/* README*
+ doman doc/w3m.1
+}