summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-24 15:24:43 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-24 15:24:43 +0000
commit72476c86cb4675213420b6cf33c04d42f745ea6a (patch)
tree9a35c72c1b9b6111833da43aeee16b0f4c077b8f /net-www
parentupdated to use the MOZILLA_FIVE_HOME variable instead of hardcoded paths to M... (diff)
downloadhistorical-72476c86cb4675213420b6cf33c04d42f745ea6a.tar.gz
historical-72476c86cb4675213420b6cf33c04d42f745ea6a.tar.bz2
historical-72476c86cb4675213420b6cf33c04d42f745ea6a.zip
updated to 0.12.2, also use MOZILLA_FIVE_HOME instead of hardcoded paths to Mozilla
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/files/digest-galeon-0.12.21
-rw-r--r--net-www/galeon/galeon-0.12.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-www/galeon/files/digest-galeon-0.12.2 b/net-www/galeon/files/digest-galeon-0.12.2
new file mode 100644
index 000000000000..6271b16b6557
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-0.12.2
@@ -0,0 +1 @@
+MD5 ea36ed41d1d6a9e9d98ed61fcaef2c53 galeon-0.12.2.tar.gz
diff --git a/net-www/galeon/galeon-0.12.2.ebuild b/net-www/galeon/galeon-0.12.2.ebuild
new file mode 100644
index 000000000000..1130becc7362
--- /dev/null
+++ b/net-www/galeon/galeon-0.12.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-0.12.2.ebuild,v 1.1 2001/09/24 15:24:43 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A small webbrowser for gnome that uses mozillas render engine"
+SRC_URI="http://prdownloads.sourceforge.net/galeon/${A}"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+DEPEND=">=net-www/mozilla-0.9.4
+ >=gnome-base/libglade-0.13
+ >=gnome-base/gnome-core-1.4.0
+ >=gnome-base/libxml-1.8.13
+ >=gnome-base/gnome-vfs-0.6.0
+ >=gnome-base/gconf-1.0.4
+ >=dev-util/xml-i18n-tools-0.8.4
+ >=gnome-base/oaf-0.6.2
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome \
+ --host=${CHOST} \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ $myconf
+
+ assert "Configuration failed."
+
+ emake || die
+}
+
+src_install () {
+ gconftool --shutdown
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}