summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tindal <urilith@gentoo.org>2005-06-01 21:21:47 +0000
committerMichael Tindal <urilith@gentoo.org>2005-06-01 21:21:47 +0000
commit3ddfae8b7fe484cb2fbb9f9536da859ea69ad618 (patch)
tree364dddfd698179139a6b1ab41b77281526549fc1 /net-www
parentFix to detect safe MPMs in light of the new one-mpm structure in 2.0.54-r6. (diff)
downloadhistorical-3ddfae8b7fe484cb2fbb9f9536da859ea69ad618.tar.gz
historical-3ddfae8b7fe484cb2fbb9f9536da859ea69ad618.tar.bz2
historical-3ddfae8b7fe484cb2fbb9f9536da859ea69ad618.zip
Bail if more than one MPM is specified.
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog5
-rw-r--r--net-www/apache/Manifest10
-rw-r--r--net-www/apache/apache-2.0.54-r6.ebuild21
3 files changed, 17 insertions, 19 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 0a6f204e9c95..1c949f73847c 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/apache
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.373 2005/06/01 19:17:58 urilith Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.374 2005/06/01 21:21:47 urilith Exp $
+
+ 01 Jun 2005; Michael Tindal <urilith@gentoo.org> apache-2.0.54-r6.ebuild:
+ Bail if more than one MPM is specified.
01 Jun 2005; Michael Tindal <urilith@gentoo.org> apache-2.0.54-r6.ebuild:
Fix the ebuild not selecting a default MPM if no MPM use flags are present.
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index 8566b3d9c0c3..f4f4798c6cdf 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,7 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 2c67ac4be3c66327e8b84ce9f3c125dc ChangeLog 62827
+MD5 033638517f9dd2021b710ebdc09c3a7e ChangeLog 62946
MD5 36b862baf4b3928e4da389714afb1155 apache-1.3.29-r2.ebuild 7227
MD5 d2794a4d623366ae015307911b5f5a1f apache-1.3.31-r1.ebuild 6806
MD5 26aeecc4289a4d8982052af3d229704a apache-1.3.31-r2.ebuild 6931
@@ -29,7 +29,7 @@ MD5 76fcf04846de38c8e17e4eb91a3564f8 apache-2.0.54-r2.ebuild 12281
MD5 5a8c76df38a1569a641933ce49383e6f apache-2.0.54-r3.ebuild 12377
MD5 fa6fc4e42369397f5f4d210d6fc2ee47 apache-2.0.54-r4.ebuild 12385
MD5 327548e6f3ae9f9edceec26421703db6 apache-2.0.54-r5.ebuild 12485
-MD5 086cbc26a156f7850b302847ea7e7161 apache-2.0.54-r6.ebuild 12700
+MD5 3b91b23a8bd18e7d0d2f853a07f9715b apache-2.0.54-r6.ebuild 12800
MD5 b34b4d92bab51e4eab58fd5021beb7c2 apache-2.0.54.ebuild 12084
MD5 37f5ed6f2423381241b029e6685bcdd2 metadata.xml 493
MD5 8b12871dd74fcd3f4fdf451c9d8c259e files/00_apache_manual.conf 781
@@ -124,7 +124,7 @@ MD5 5d45e2b46965e7c6866b259df4efe4b2 files/patches/2.0.50-r1/Readme.PATCHES 357
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCngoxQcyUawK/P5kRAjznAJ4z/VfnydUD+AR+LcbomkIU1BSKnwCfcDpX
-7hO9ad7UXfD9ItVh+dIv5KA=
-=5Q5D
+iD8DBQFCnib0QcyUawK/P5kRAlObAJ9/ymPy00os/9lUGGvkOkwXhixJEACdFmKw
+3KxfngCw3+gnXTbq8xteIP8=
+=Y13r
-----END PGP SIGNATURE-----
diff --git a/net-www/apache/apache-2.0.54-r6.ebuild b/net-www/apache/apache-2.0.54-r6.ebuild
index f4166f7d0a42..7402917b3005 100644
--- a/net-www/apache/apache-2.0.54-r6.ebuild
+++ b/net-www/apache/apache-2.0.54-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r6.ebuild,v 1.3 2005/06/01 19:17:58 urilith Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r6.ebuild,v 1.4 2005/06/01 21:21:47 urilith Exp $
inherit eutils gnuconfig
@@ -61,6 +61,7 @@ big_fat_warnings() {
pkg_setup() {
big_fat_warnings
+ select_mpms
}
src_unpack() {
@@ -143,12 +144,6 @@ src_compile() {
myconf="${myconf} --enable-maintainer-mode"
fi
- select_mpms
-
- # now we build each mpm
- # clean up
- cd server; make clean; cd ..
-
./configure --with-mpm=${mpm} ${myconf} || die "bad ./configure please submit bug report to bugs.gentoo.org. Include your config.layout and config.log"
# we don't want to try and recompile the ssl_expr_parse.c file, because
@@ -363,10 +358,11 @@ setup_apache_vars() {
einfo "USERDIR is set to: ${USERDIR}"
}
-mpm_warn() {
- echo
- ewarn "More than one MPM was specified. Defaulting to ${mpm}."
- echo
+mpm_die() {
+ eerror "You attempted to specify the MPM $1, but MPM $2 was already specified."
+ eerror "The apache ebuilds no longer support multiple MPM installations. Please choose"
+ eerror "one MPM and reinstall."
+ die "More than one MPM was specified."
}
try_mpm() {
@@ -377,8 +373,7 @@ try_mpm() {
fi
if [ -n "${mpm}" ]; then
- mpm_warn
- return 0
+ mpm_die ${nmpm} ${mpm}
fi
mpm="${nmpm}"