summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 03:17:15 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 03:17:15 +0000
commitf9be5b48c09aeddb17ddae148fcb72e54bf0dda0 (patch)
tree2b14e1f9ea1fb44f85c5049013b5f3f8cdb9b16e /net-wireless/linux-wlan-ng
parentDeedra Waters != to Seemant. Sorry Seemant, Deedra is the maintainer :P (diff)
downloadhistorical-f9be5b48c09aeddb17ddae148fcb72e54bf0dda0.tar.gz
historical-f9be5b48c09aeddb17ddae148fcb72e54bf0dda0.tar.bz2
historical-f9be5b48c09aeddb17ddae148fcb72e54bf0dda0.zip
Fix use invocation
Diffstat (limited to 'net-wireless/linux-wlan-ng')
-rw-r--r--net-wireless/linux-wlan-ng/ChangeLog10
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild20
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild20
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild8
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild20
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild20
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild8
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild12
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild8
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild8
-rw-r--r--net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild20
11 files changed, 81 insertions, 73 deletions
diff --git a/net-wireless/linux-wlan-ng/ChangeLog b/net-wireless/linux-wlan-ng/ChangeLog
index ac2e70b884ea..7d445b6093bf 100644
--- a/net-wireless/linux-wlan-ng/ChangeLog
+++ b/net-wireless/linux-wlan-ng/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-wireless/linux-wlan-ng
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.38 2004/04/27 22:12:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/ChangeLog,v 1.39 2004/06/15 03:16:17 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ linux-wlan-ng-0.2.0-r1.ebuild, linux-wlan-ng-0.2.0-r2.ebuild,
+ linux-wlan-ng-0.2.0-r3.ebuild, linux-wlan-ng-0.2.1_pre11.ebuild,
+ linux-wlan-ng-0.2.1_pre16.ebuild, linux-wlan-ng-0.2.1_pre17-r1.ebuild,
+ linux-wlan-ng-0.2.1_pre17.ebuild, linux-wlan-ng-0.2.1_pre19.ebuild,
+ linux-wlan-ng-0.2.1_pre20.ebuild, linux-wlan-ng-0.2.1_pre8.ebuild:
+ Fix use invocation
27 Apr 2004; Aron Griffis <agriffis@gentoo.org>
linux-wlan-ng-0.2.1_pre19.ebuild:
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild
index a35a4109c96d..e59f132569ea 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild,v 1.6 2004/02/01 23:33:51 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r1.ebuild,v 1.7 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -45,7 +45,7 @@ fi
src_unpack() {
unpack ${P}.tar.gz
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
check_KV
unpack ${PCMCIA_CS}.tar.gz
cd ${PCMCIA_DIR}
@@ -94,28 +94,28 @@ src_compile() {
# the kernel tree.
#
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
cd ${WORKDIR}/${PCMCIA_CS}
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -140,7 +140,7 @@ src_compile() {
config.in > default.config
mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
export PCMCIA_CS=${PCMCIA_CS}
sed -e 's:PCMCIA_SRC=:PCMCIA_SRC=${WORKDIR}/${PCMCIA_CS}:' \
-e 's:PRISM2_PLX=n:PRISM2_PLX=y:' \
@@ -151,7 +151,7 @@ src_compile() {
fi
mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in > default.config
mv default.config config.in
@@ -176,7 +176,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild
index 30b3b795b2a0..86f7c459ca9b 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild,v 1.5 2004/02/01 23:33:51 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r2.ebuild,v 1.6 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -52,7 +52,7 @@ src_unpack() {
cp ${PN}-gentoo-init ${S}/etc/rc.wlan
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
check_KV
unpack ${PCMCIA_CS}.tar.gz
cd ${PCMCIA_DIR}
@@ -101,28 +101,28 @@ src_compile() {
# the kernel tree.
#
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
cd ${WORKDIR}/${PCMCIA_CS}
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -147,7 +147,7 @@ src_compile() {
config.in > default.config
mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
export PCMCIA_CS=${PCMCIA_CS}
sed -e 's:PCMCIA_SRC=:PCMCIA_SRC=${WORKDIR}/${PCMCIA_CS}:' \
-e 's:PRISM2_PLX=n:PRISM2_PLX=y:' \
@@ -158,7 +158,7 @@ src_compile() {
fi
mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in > default.config
mv default.config config.in
@@ -183,7 +183,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild
index 17aa6bfc41e6..51952f2e6d7b 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild,v 1.3 2004/02/08 19:32:16 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.0-r3.ebuild,v 1.4 2004/06/15 03:16:17 agriffis Exp $
inherit pcmcia
@@ -87,7 +87,7 @@ src_compile() {
config.in
#mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ -n "${PCMCIA_SOURCE_DIR}" ]
then
export PCMCIA_SOURCE_DIR=${PCMCIA_SOURCE_DIR}
@@ -102,7 +102,7 @@ src_compile() {
fi
#mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -i -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in
#mv default.config config.in
@@ -127,7 +127,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild
index e4d1a0637a44..a05a2f255e82 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild,v 1.4 2004/02/01 23:33:51 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre11.ebuild,v 1.5 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -51,7 +51,7 @@ src_unpack() {
unpack ${PN}-gentoo-init.gz
cp ${WORKDIR}/${PN}-gentoo-init ${S}/etc/rc.wlan
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
unpack ${PCMCIA_CS}.tar.gz
cd ${PCMCIA_DIR}
if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
@@ -99,28 +99,28 @@ src_compile() {
# the kernel tree.
#
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
cd ${WORKDIR}/${PCMCIA_CS}
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -145,7 +145,7 @@ src_compile() {
config.in > default.config
mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
export PCMCIA_CS=${PCMCIA_CS}
sed -e 's:PCMCIA_SRC=:PCMCIA_SRC=${WORKDIR}/${PCMCIA_CS}:' \
-e 's:PRISM2_PLX=n:PRISM2_PLX=y:' \
@@ -156,7 +156,7 @@ src_compile() {
fi
mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in > default.config
mv default.config config.in
@@ -182,7 +182,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild
index 4d861a90e8df..f4591e8128fe 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild,v 1.1 2004/01/24 22:59:20 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre16.ebuild,v 1.2 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -50,7 +50,7 @@ src_unpack() {
unpack ${PN}-gentoo-init.gz
cp ${WORKDIR}/${PN}-gentoo-init ${S}/etc/rc.wlan
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
unpack ${PCMCIA_CS}.tar.gz
cd ${PCMCIA_DIR}
if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
@@ -98,28 +98,28 @@ src_compile() {
# the kernel tree.
#
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
cd ${WORKDIR}/${PCMCIA_CS}
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -144,7 +144,7 @@ src_compile() {
config.in > default.config
mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
export PCMCIA_CS=${PCMCIA_CS}
sed -e 's:PCMCIA_SRC=:PCMCIA_SRC=${WORKDIR}/${PCMCIA_CS}:' \
-e 's:PRISM2_PLX=n:PRISM2_PLX=y:' \
@@ -155,7 +155,7 @@ src_compile() {
fi
mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in > default.config
mv default.config config.in
@@ -181,7 +181,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild
index d78747e3bdde..39333ac057df 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild,v 1.3 2004/02/29 22:47:54 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17-r1.ebuild,v 1.4 2004/06/15 03:16:17 agriffis Exp $
inherit pcmcia kernel-mod
@@ -66,7 +66,7 @@ src_compile() {
-e 's:PRISM2_PCI=n:PRISM2_PCI=y:' \
config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ -n "${PCMCIA_SOURCE_DIR}" ];
then
export PCMCIA_SOURCE_DIR=${PCMCIA_SOURCE_DIR}
@@ -80,7 +80,7 @@ src_compile() {
config.in
fi
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -i -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in
fi
@@ -111,7 +111,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild
index 279b20d2a969..ee4aebf6fe9a 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild,v 1.1 2004/02/04 00:14:28 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre17.ebuild,v 1.2 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -40,7 +40,7 @@ src_unpack() {
cd ${S}
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if egrep '^CONFIG_PCMCIA=[ym]' /usr/src/linux/.config >&/dev/null
then
# Sadly, we still need to download these sources in SRC_URI
@@ -108,7 +108,7 @@ src_compile() {
kernelpcmcia="no"
fi
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ "${kernelpcmcia}" = "no" ]; then
local myarch myconf
@@ -140,7 +140,7 @@ src_compile() {
-e 's:PRISM2_PCI=n:PRISM2_PCI=y:' \
config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ "${kernelpcmcia}" = "no" ];
then
export PCMCIA_CS=${PCMCIA_CS}
@@ -154,7 +154,7 @@ src_compile() {
config.in
fi
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -i -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in
fi
@@ -180,7 +180,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild
index 2a88db7ebef5..9017b38f20dd 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild,v 1.2 2004/04/27 22:12:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre19.ebuild,v 1.3 2004/06/15 03:16:17 agriffis Exp $
inherit pcmcia eutils
@@ -73,7 +73,7 @@ src_compile() {
-e 's:PRISM2_PCI=n:PRISM2_PCI=y:' \
config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ -n "${PCMCIA_SOURCE_DIR}" ];
then
export PCMCIA_SOURCE_DIR=${PCMCIA_SOURCE_DIR}
@@ -87,7 +87,7 @@ src_compile() {
config.in
fi
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -i -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in
fi
@@ -113,7 +113,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild
index 22bdbdeff3bb..57e799f6a88d 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild,v 1.1 2004/03/01 05:42:22 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre20.ebuild,v 1.2 2004/06/15 03:16:17 agriffis Exp $
inherit pcmcia
@@ -65,7 +65,7 @@ src_compile() {
-e 's:PRISM2_PCI=n:PRISM2_PCI=y:' \
config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
if [ -n "${PCMCIA_SOURCE_DIR}" ];
then
export PCMCIA_SOURCE_DIR=${PCMCIA_SOURCE_DIR}
@@ -79,7 +79,7 @@ src_compile() {
config.in
fi
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -i -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in
fi
@@ -105,7 +105,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1
diff --git a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild
index ebc9993180fb..99ec425ba090 100644
--- a/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild
+++ b/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild,v 1.4 2004/02/01 23:33:51 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/linux-wlan-ng/linux-wlan-ng-0.2.1_pre8.ebuild,v 1.5 2004/06/15 03:16:17 agriffis Exp $
inherit eutils
@@ -51,7 +51,7 @@ src_unpack() {
unpack ${PN}-gentoo-init.gz
cp ${WORKDIR}/${PN}-gentoo-init ${S}/etc/rc.wlan
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
unpack ${PCMCIA_CS}.tar.gz
cd ${PCMCIA_DIR}
if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
@@ -99,28 +99,28 @@ src_compile() {
# the kernel tree.
#
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
cd ${WORKDIR}/${PCMCIA_CS}
local myconf
- if [ -n "`use trusted`" ] ; then
+ if use trusted ; then
myconf="--trust"
else
myconf="--notrust"
fi
- if [ -n "`use apm`" ] ; then
+ if use apm ; then
myconf="$myconf --apm"
else
myconf="$myconf --noapm"
fi
- if [ -n "`use pnp`" ] ; then
+ if use pnp ; then
myconf="$myconf --pnp"
else
myconf="$myconf --nopnp"
fi
- if [ -n "`use nocardbus`" ] ; then
+ if use nocardbus ; then
myconf="$myconf --nocardbus"
else
myconf="$myconf --cardbus"
@@ -145,7 +145,7 @@ src_compile() {
config.in > default.config
mv default.config config.in
- if [ -n "`use pcmcia`" ]; then
+ if use pcmcia; then
export PCMCIA_CS=${PCMCIA_CS}
sed -e 's:PCMCIA_SRC=:PCMCIA_SRC=${WORKDIR}/${PCMCIA_CS}:' \
-e 's:PRISM2_PLX=n:PRISM2_PLX=y:' \
@@ -156,7 +156,7 @@ src_compile() {
fi
mv default.config config.in
- if [ -n "`use usb`" ]; then
+ if use usb; then
sed -e 's:PRISM2_USB=n:PRISM2_USB=y:' \
config.in > default.config
mv default.config config.in
@@ -182,7 +182,7 @@ src_install () {
dodir etc/wlan
mv ${D}/etc/conf.d/shared ${D}/etc/wlan/
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodir /usr/share/man/man1
newman ${S}/man/nwepgen.man nwepgen.1