summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:11:00 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:11:00 +0000
commit81ede9d32f8f6afeef88c18e3e1441606e6ce74e (patch)
tree621a419f5b9dad283ddd0ad2eae3cefdcbcc3033 /net-p2p
parentChanged econf||die to econf (diff)
downloadhistorical-81ede9d32f8f6afeef88c18e3e1441606e6ce74e.tar.gz
historical-81ede9d32f8f6afeef88c18e3e1441606e6ce74e.tar.bz2
historical-81ede9d32f8f6afeef88c18e3e1441606e6ce74e.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gnunet/gnunet-0.4.2.ebuild14
-rw-r--r--net-p2p/gnunet/gnunet-0.4.4.ebuild13
2 files changed, 12 insertions, 15 deletions
diff --git a/net-p2p/gnunet/gnunet-0.4.2.ebuild b/net-p2p/gnunet/gnunet-0.4.2.ebuild
index 0abe11ad47cf..2e1dc771a4ba 100644
--- a/net-p2p/gnunet/gnunet-0.4.2.ebuild
+++ b/net-p2p/gnunet/gnunet-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.4.2.ebuild,v 1.3 2002/10/20 18:52:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.4.2.ebuild,v 1.4 2002/11/30 21:09:54 vapier Exp $
S=${WORKDIR}/GNUnet-${PV}
DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
@@ -17,22 +17,20 @@ DEPEND=">=dev-libs/openssl-0.9.6d
=x11-libs/gtk+-1.2*
>=dev-libs/libextractor-0.1.0"
-
-src_compile () {
- econf || die "./configure failed"
+src_compile() {
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING INSTALL NEWS README
- mkdir ${D}/usr/share/gnunet
+ dodir /usr/share/gnunet
cp ${S}/contrib/gnunet.conf* ${D}/usr/share/gnunet
cp ${FILESDIR}/gnunet ${D}/usr/share/gnunet
-
}
-pkg_postinstall () {
+pkg_postinstall() {
einfo "Default configuration files are provided in /usr/share/gnunet"
einfo "An example rc script for gentoo is also available and "
einfo "should be run by permanent nodes."
diff --git a/net-p2p/gnunet/gnunet-0.4.4.ebuild b/net-p2p/gnunet/gnunet-0.4.4.ebuild
index f5ea83d57f3b..f6636264fdd5 100644
--- a/net-p2p/gnunet/gnunet-0.4.4.ebuild
+++ b/net-p2p/gnunet/gnunet-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.4.4.ebuild,v 1.2 2002/10/20 18:52:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.4.4.ebuild,v 1.3 2002/11/30 21:11:00 vapier Exp $
S=${WORKDIR}/GNUnet-${PV}
DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
@@ -17,22 +17,21 @@ DEPEND=">=dev-libs/openssl-0.9.6d
=x11-libs/gtk+-1.2*
>=dev-libs/libextractor-0.1.0"
-
-src_compile () {
- econf || die "./configure failed"
+src_compile() {
+ econf
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING INSTALL NEWS README
- mkdir ${D}/usr/share/gnunet
+ dodir /usr/share/gnunet
cp ${S}/contrib/gnunet.conf* ${D}/usr/share/gnunet
cp ${FILESDIR}/gnunet ${D}/usr/share/gnunet
}
-pkg_postinstall () {
+pkg_postinst() {
einfo "Default configuration files are provided in /usr/share/gnunet"
einfo "An example rc script for gentoo is also available and "
einfo "should be run by permanent nodes."