summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Destuynder <kang@gentoo.org>2004-07-28 12:26:05 +0000
committerGuillaume Destuynder <kang@gentoo.org>2004-07-28 12:26:05 +0000
commited4502ed8204c99cc46f4157ec258ec8c2aaf6d8 (patch)
treefd309b2a7106afb778cf3d36eb3893413ab1c3d2 /net-p2p/mhxd
parentinitial import (diff)
downloadhistorical-ed4502ed8204c99cc46f4157ec258ec8c2aaf6d8.tar.gz
historical-ed4502ed8204c99cc46f4157ec258ec8c2aaf6d8.tar.bz2
historical-ed4502ed8204c99cc46f4157ec258ec8c2aaf6d8.zip
version bump
Diffstat (limited to 'net-p2p/mhxd')
-rw-r--r--net-p2p/mhxd/ChangeLog7
-rw-r--r--net-p2p/mhxd/files/digest-mhxd-0.4.101
-rw-r--r--net-p2p/mhxd/mhxd-0.4.10.ebuild76
-rw-r--r--net-p2p/mhxd/mhxd-0.4.9.ebuild3
4 files changed, 85 insertions, 2 deletions
diff --git a/net-p2p/mhxd/ChangeLog b/net-p2p/mhxd/ChangeLog
index f7867765c53b..b66cb6ad5fda 100644
--- a/net-p2p/mhxd/ChangeLog
+++ b/net-p2p/mhxd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/mhxd
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mhxd/ChangeLog,v 1.5 2004/07/17 10:42:14 kang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mhxd/ChangeLog,v 1.6 2004/07/28 12:26:05 kang Exp $
+
+*mhxd-0.4.10 (28 Jul 2004)
+
+ 28 Jul 2004; Guillaume Destuynder <kang@gentoo.org> +mhxd-0.4.9.ebuild:
+ Version bump. Now also uses enewgroup/enewuser in the ebuild.
17 Jul 2004; Guillaume Destuynder <kang@gentoo.org> mhxd-0.4.9.ebuild:
Added ~sparc keyword (ebuild was tested and verified working for this arch)
diff --git a/net-p2p/mhxd/files/digest-mhxd-0.4.10 b/net-p2p/mhxd/files/digest-mhxd-0.4.10
new file mode 100644
index 000000000000..33e14ac3b4b5
--- /dev/null
+++ b/net-p2p/mhxd/files/digest-mhxd-0.4.10
@@ -0,0 +1 @@
+MD5 6b664c5f798746c5c0617c72d1c95967 mhxd-0.4.10.tar.bz2 768353
diff --git a/net-p2p/mhxd/mhxd-0.4.10.ebuild b/net-p2p/mhxd/mhxd-0.4.10.ebuild
new file mode 100644
index 000000000000..3c7ba1b42de1
--- /dev/null
+++ b/net-p2p/mhxd/mhxd-0.4.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mhxd/mhxd-0.4.10.ebuild,v 1.1 2004/07/28 12:26:05 kang Exp $
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DESCRIPTION="This is a Hotline 1.5+ compatible *nix Hotline Server. It supports IRC compatibility. See http://www.hotspringsinc.com/"
+SRC_URI="http://projects.acidbeats.de/${P}.tar.bz2"
+HOMEPAGE="http://hotlinex.sf.net/"
+
+IUSE="ipv6 ssl mysql"
+
+DEPEND="virtual/libc
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ mysql? ( >=dev-db/mysql-3.23.52 )
+ >=sys-libs/zlib-1.1.4"
+
+SLOT="0"
+
+src_compile() {
+ econf \
+ `use_enable ssl idea` \
+ `use_enable ssl cipher` \
+ `use_enable ssl hope` \
+ `use_enable ssl compress` \
+ `use_enable ipv6` \
+ `use_enable mysql sql` \
+ --enable-acctedit || die "bad configure"
+ emake || die "compile problem"
+ make install || die "compile problem"
+}
+
+src_install() {
+ cd ${S}
+ dodoc hxd.sql AUTHORS INSTALL PROBLEMS README* ChangeLog TODO NEWS run/hxd/hxd.conf
+
+ cpdirs="accounts files newsdir etc exec lib"
+ dodir /etc/mhxd
+ insinto /etc/mhxd; doins run/hxd/hxd.conf
+ dosbin run/hxd/bin/hxd
+ dobin run/hxd/bin/acctedit
+
+ dodir /var/mhxd
+ for d in ${cpdirs} ; do
+ insinto /var/mhxd
+ cp -R run/hxd/${d} ${D}/var/mhxd/${d}
+ done
+ insinto /var/mhxd ; doins run/hxd/news
+ insinto /var/mhxd; doins run/hxd/agreement
+ insinto /var/mhxd; doins run/hxd/.common
+
+ keepdir /var/mhxd/files
+ keepdir /var/mhxd/lib
+ exeinto /etc/init.d ; newexe ${FILESDIR}/hxd.rc mhxd
+}
+
+pkg_preinst() {
+ if ! groupmod hxd; then
+ enewgroup hxd -1 || die "Failed to create hxd group"
+ fi
+
+ if ! id hxd; then
+ enewuser hxd -1 /bin/bash /var/hxd hxd || "Failed to create hxd user"
+ fi
+}
+
+pkg_postinst() {
+ #fowners don't do directories :(
+ chown -R hxd:hxd /var/mhxd || "Failed to set owner on /var/mhxd"
+ einfo
+ einfo "Welcome to Horline!"
+ einfo "Do '/etc/init.d/mhxd start' to start the server, then"
+ einfo "Login as admin and no password to your hotline server, and change the password"
+ einfo
+}
diff --git a/net-p2p/mhxd/mhxd-0.4.9.ebuild b/net-p2p/mhxd/mhxd-0.4.9.ebuild
index 50a60a6d1bf7..0d0cf52123f4 100644
--- a/net-p2p/mhxd/mhxd-0.4.9.ebuild
+++ b/net-p2p/mhxd/mhxd-0.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mhxd/mhxd-0.4.9.ebuild,v 1.5 2004/07/17 10:42:14 kang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mhxd/mhxd-0.4.9.ebuild,v 1.6 2004/07/28 12:26:05 kang Exp $
LICENSE="GPL-2"
KEYWORDS="x86 ppc ~sparc"
@@ -49,6 +49,7 @@ src_install() {
insinto /var/mhxd ; doins run/hxd/news
insinto /var/mhxd; doins run/hxd/agreement
insinto /var/mhxd; doins run/hxd/.common
+ insinto /var/mhxd; doins run/hxd/hxd.sql
keepdir /var/mhxd/files
keepdir /var/mhxd/lib