summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-08 05:05:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-08 05:05:13 +0000
commit4426cdc9b233dbac829e7a2d3836e84285f45b12 (patch)
treec1bfa10633b2eff7c2ef5dd5bc75f5a995d97e8d /net-news
parentupdate digest with ppc file digest (diff)
downloadhistorical-4426cdc9b233dbac829e7a2d3836e84285f45b12.tar.gz
historical-4426cdc9b233dbac829e7a2d3836e84285f45b12.tar.bz2
historical-4426cdc9b233dbac829e7a2d3836e84285f45b12.zip
version bump
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/ChangeLog9
-rw-r--r--net-news/pan/files/digest-pan-0.11.941
-rw-r--r--net-news/pan/pan-0.11.94.ebuild60
3 files changed, 69 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index 3072723bacbf..4bee40c14e9d 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.7 2002/05/23 19:15:18 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.8 2002/06/08 05:05:13 seemant Exp $
+
+*pan-0.11.94 (7 Jun 2002)
+
+ 7 Jun 2002; Seemant Kulleen <seemant@gentoo.org> pan-0.11.94.ebuild
+ files/digest-pan-0.11.94 :
+
+ Version bump.
*pan-0.11.93 (23 May 2002)
23 May 2002; Spider <spider@gentoo.org> pan-0.11.93.ebuild:
diff --git a/net-news/pan/files/digest-pan-0.11.94 b/net-news/pan/files/digest-pan-0.11.94
new file mode 100644
index 000000000000..bdb115bf1eb8
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.11.94
@@ -0,0 +1 @@
+MD5 b1553fa8cd83348b0b8110ec4c745b82 pan-0.11.94.tar.bz2 1604716
diff --git a/net-news/pan/pan-0.11.94.ebuild b/net-news/pan/pan-0.11.94.ebuild
new file mode 100644
index 000000000000..d41b62726edc
--- /dev/null
+++ b/net-news/pan/pan-0.11.94.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.11.94.ebuild,v 1.1 2002/06/08 05:05:13 seemant Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/0.11.94/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+LICENSE="GPL-2"
+SLOT="0"
+
+#libglade
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-1.114.0
+ dev-libs/libxml2"
+
+DEPEND="$RDEPEND"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ libtoolize --copy --force
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}
+
+