summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-27 21:26:09 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-27 21:26:09 +0000
commit05251f20bec7cf53af71e36cf7d0d86ceb7a6cd8 (patch)
treeb9bcddbf593ddbc0441af7500a4ad65ba567ad94 /net-news/tin
parentadd dev-lang/python dep. only build against current version of python. (#39347) (diff)
downloadhistorical-05251f20bec7cf53af71e36cf7d0d86ceb7a6cd8.tar.gz
historical-05251f20bec7cf53af71e36cf7d0d86ceb7a6cd8.tar.bz2
historical-05251f20bec7cf53af71e36cf7d0d86ceb7a6cd8.zip
Version bumped.
Diffstat (limited to 'net-news/tin')
-rw-r--r--net-news/tin/Manifest4
-rw-r--r--net-news/tin/files/digest-tin-1.6.21
-rw-r--r--net-news/tin/tin-1.6.2.ebuild45
3 files changed, 48 insertions, 2 deletions
diff --git a/net-news/tin/Manifest b/net-news/tin/Manifest
index a8407d33d2a3..d5b40b092bdd 100644
--- a/net-news/tin/Manifest
+++ b/net-news/tin/Manifest
@@ -1,7 +1,7 @@
-MD5 143fe18916fba83ef535430fb67a8200 ChangeLog 779
+MD5 c41b2ee92c22e138c26137ab151fc43c ChangeLog 890
MD5 34534e9cd0b43175726e7d868842c2de tin-1.4.5.ebuild 1105
MD5 4159045ee638df50c64a4d8c3d239817 tin-1.6.0.ebuild 1109
-MD5 392124d61963390173458320c5ed6a54 tin-1.6.2.ebuild 1110
+MD5 cfdd28dc2c738030a705fdf45949e1b5 tin-1.6.2.ebuild 1112
MD5 d7152552e399cbeb77e775886d1c6506 files/digest-tin-1.6.2 62
MD5 cba3ba7f3d628ed33c94f3ff4f1375e3 files/digest-tin-1.4.5 61
MD5 2475288cb79f81762730eb56c53ba235 files/digest-tin-1.6.0 62
diff --git a/net-news/tin/files/digest-tin-1.6.2 b/net-news/tin/files/digest-tin-1.6.2
new file mode 100644
index 000000000000..8948f7e9f515
--- /dev/null
+++ b/net-news/tin/files/digest-tin-1.6.2
@@ -0,0 +1 @@
+MD5 8f34747809b6fe5c135694fcbe2c8f46 tin-1.6.2.tar.gz 1548753
diff --git a/net-news/tin/tin-1.6.2.ebuild b/net-news/tin/tin-1.6.2.ebuild
new file mode 100644
index 000000000000..772befbfd4a3
--- /dev/null
+++ b/net-news/tin/tin-1.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/tin/tin-1.6.2.ebuild,v 1.1 2004/01/27 21:25:57 mholzer Exp $
+
+IUSE="ncurses"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v1.6/${P}.tar.gz"
+HOMEPAGE="http://www.tin.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ia64"
+
+DEPEND="ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ local myconf
+
+ use ncurses && myconf="--enable-curses --with-ncurses"
+ [ -f /etc/NNTP_INEWS_DOMAIN ] \
+ && myconf="${myconf} --with-domain-name=/etc/NNTP_INEWS_DOMAIN"
+
+ ./configure \
+ --verbose \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --disable-echo \
+ --disable-mime-strict-charset \
+ --with-coffee \
+ --enable-fascist-newsadmin \
+ ${myconf} || die
+ make build || die
+}
+
+src_install() {
+ dobin src/tin
+ ln -s tin ${D}/usr/bin/rtin
+ doman doc/tin.1
+ dodoc doc/*
+ insinto /etc/tin
+ doins doc/tin.defaults
+}