summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
commit087ed89c6892c663cb31ab5d5e826869f0aef98a (patch)
tree673daf16e9ee0adf5a0c74ece2e31b3e6be8163c /net-nds
parentClosing bug25551 (diff)
downloadhistorical-087ed89c6892c663cb31ab5d5e826869f0aef98a.tar.gz
historical-087ed89c6892c663cb31ab5d5e826869f0aef98a.tar.bz2
historical-087ed89c6892c663cb31ab5d5e826869f0aef98a.zip
ia64 stable for #66786
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ypbind/ypbind-1.17.2-r1.ebuild26
-rw-r--r--net-nds/ypserv/ypserv-2.13-r1.ebuild30
2 files changed, 27 insertions, 29 deletions
diff --git a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
index c81eb255d932..e6f7a8a90921 100644
--- a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
+++ b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.6 2004/10/08 18:01:16 hansmi Exp $
-
-IUSE="nls slp"
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.7 2004/10/31 05:38:08 vapier Exp $
MY_P=${PN}-mt-${PV}
S="${WORKDIR}/${MY_P}"
@@ -13,19 +11,21 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc alpha ppc amd64 ~ia64 ~ppc64"
-
-DEPEND="slp? ( net-libs/openslp )"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE="nls slp"
-RDEPEND="${DEPEND}
+RDEPEND="slp? ( net-libs/openslp )
net-nds/yp-tools
net-nds/portmap"
-
-DEPEND="${DEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-apps/portage-2.0.51"
src_compile() {
- econf `use_enable nls` `use_enable slp` || die
+ econf \
+ $(use_enable nls) \
+ $(use_enable slp) \
+ || die
emake || die "emake failed"
}
@@ -33,8 +33,8 @@ src_install() {
einstall || die
dodoc AUTHORS ChangeLog README THANKS TODO
insinto /etc ; doins etc/yp.conf
- insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd-r1 ypbind
- exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.initd ypbind
+ newconfd ${FILESDIR}/ypbind.confd-r1 ypbind
+ newinitd ${FILESDIR}/ypbind.initd ypbind
}
pkg_postinst() {
diff --git a/net-nds/ypserv/ypserv-2.13-r1.ebuild b/net-nds/ypserv/ypserv-2.13-r1.ebuild
index dbf66c4bea95..691c6d1e94e8 100644
--- a/net-nds/ypserv/ypserv-2.13-r1.ebuild
+++ b/net-nds/ypserv/ypserv-2.13-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.13-r1.ebuild,v 1.8 2004/10/08 18:02:53 hansmi Exp $
-
-IUSE="slp"
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.13-r1.ebuild,v 1.9 2004/10/31 05:40:05 vapier Exp $
DESCRIPTION="Network Information Service server"
HOMEPAGE="http://www.linux-nis.org/nis/"
@@ -10,35 +8,35 @@ SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc ~ppc64 amd64"
+KEYWORDS="amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE="slp"
-DEPEND=">=sys-libs/gdbm-1.8.0
+RDEPEND=">=sys-libs/gdbm-1.8.0
slp? ( net-libs/openslp )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
src_compile() {
- econf `use_enable slp` || die
+ econf $(use_enable slp) || die
emake || die
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
insinto /etc
doins etc/ypserv.conf etc/netgroup etc/netmasks
-
insinto /var/yp
newins etc/securenets securenets.default
- insinto /etc/conf.d
- newins ${FILESDIR}/ypserv.confd ypserv
- newins ${FILESDIR}/rpc.yppasswdd.confd rpc.yppasswdd
- newins ${FILESDIR}/rpc.ypxfrd.confd rpc.ypxfrd
+ newconfd ${FILESDIR}/ypserv.confd ypserv
+ newconfd ${FILESDIR}/rpc.yppasswdd.confd rpc.yppasswdd
+ newconfd ${FILESDIR}/rpc.ypxfrd.confd rpc.ypxfrd
- exeinto /etc/init.d
- newexe ${FILESDIR}/ypserv ypserv
- newexe ${FILESDIR}/rpc.yppasswdd-r1 rpc.yppasswdd
- newexe ${FILESDIR}/rpc.ypxfrd rpc.ypxfrd
+ newinitd ${FILESDIR}/ypserv ypserv
+ newinitd ${FILESDIR}/rpc.yppasswdd-r1 rpc.yppasswdd
+ newinitd ${FILESDIR}/rpc.ypxfrd rpc.ypxfrd
# Save the old config into the new package as CONFIG_PROTECT
# doesn't work for this package.