summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-09-12 21:32:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-09-12 21:32:01 +0000
commit9f644dcdbd1196bb2448ae4dc997ec4e6e1764aa (patch)
tree3508b46a734c6088fda93786444bd527fad09411 /net-misc/wget
parentVersion bump. (diff)
downloadhistorical-9f644dcdbd1196bb2448ae4dc997ec4e6e1764aa.tar.gz
historical-9f644dcdbd1196bb2448ae4dc997ec4e6e1764aa.tar.bz2
historical-9f644dcdbd1196bb2448ae4dc997ec4e6e1764aa.zip
add a note about preferring ipv6 in the wgetrc file, closing bug #102209
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/files/digest-wget-1.9.1-r32
-rw-r--r--net-misc/wget/files/wgetrc-ipv63
-rw-r--r--net-misc/wget/wget-1.10.ebuild11
-rw-r--r--net-misc/wget/wget-1.9.1-r3.ebuild62
5 files changed, 17 insertions, 67 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 2f46de400066..64ecbaa7a2f3 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.72 2005/07/28 14:44:01 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.73 2005/09/12 21:32:01 seemant Exp $
+
+ 12 Sep 2005; Seemant Kulleen <seemant@gentoo.org> +files/wgetrc-ipv6,
+ -wget-1.9.1-r3.ebuild, wget-1.10.ebuild:
+ add a note about preferring ipv6 in the wgetrc file, closing bug #102209
28 Jul 2005; Kito <kito@gentoo.org> wget-1.9.1-r5.ebuild:
stable on ppc-macos.
diff --git a/net-misc/wget/files/digest-wget-1.9.1-r3 b/net-misc/wget/files/digest-wget-1.9.1-r3
deleted file mode 100644
index 05e9ec0b2be6..000000000000
--- a/net-misc/wget/files/digest-wget-1.9.1-r3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 e6051f1e1487ec0ebfdbda72bedc70ad wget-1.9.1.tar.gz 1322378
-MD5 941758fd70ed3d70c34aa439d6dd585c wget-1.9.1-gentoo-0.1.tar.bz2 9019
diff --git a/net-misc/wget/files/wgetrc-ipv6 b/net-misc/wget/files/wgetrc-ipv6
new file mode 100644
index 000000000000..d87995fc4f31
--- /dev/null
+++ b/net-misc/wget/files/wgetrc-ipv6
@@ -0,0 +1,3 @@
+
+# To try ipv6 addresses first:
+#prefer-family = IPv6
diff --git a/net-misc/wget/wget-1.10.ebuild b/net-misc/wget/wget-1.10.ebuild
index aada1fd9737f..c3cb2c803984 100644
--- a/net-misc/wget/wget-1.10.ebuild
+++ b/net-misc/wget/wget-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.10.ebuild,v 1.4 2005/07/28 14:21:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.10.ebuild,v 1.5 2005/09/12 21:32:01 seemant Exp $
inherit eutils flag-o-matic
@@ -51,6 +51,13 @@ src_install() {
fi
make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc AUTHORS ChangeLog MAILING-LIST NEWS README TODO
dodoc doc/sample.wgetrc
+
+ if use ipv6 ; then
+ ebegin "Adding a note about ipv6 in the config file"
+ cat ${FILESDIR}/wgetrc-ipv6 >> ${D}/etc/wget/wgetrc
+ eend $?
+ fi
+
}
diff --git a/net-misc/wget/wget-1.9.1-r3.ebuild b/net-misc/wget/wget-1.9.1-r3.ebuild
deleted file mode 100644
index 62adb846fcfe..000000000000
--- a/net-misc/wget/wget-1.9.1-r3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r3.ebuild,v 1.15 2005/07/28 14:21:54 seemant Exp $
-
-inherit gnuconfig eutils flag-o-matic
-
-IUSE="build debug ipv6 nls socks5 ssl static"
-
-PATCHVER=0.1
-DESCRIPTION="Network utility to retrieve files from the WWW"
-HOMEPAGE="http://wget.sunsite.dk/"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz
- mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos s390 sh sparc x86"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
- socks5? ( net-proxy/dante )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-
-src_unpack() {
- unpack ${A} ; cd ${S}
- EPATCH_SUFFIX="patch" epatch ${WORKDIR}/gentoo
-}
-
-src_compile() {
- # Make wget use up-to-date configure scripts
- gnuconfig_update
-
- use ssl && append-flags -I/usr/include/openssl
-
- econf \
- --sysconfdir=/etc/wget \
- $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable debug) \
- $(use_with socks5 socks) \
- || die
-
- if use static; then
- emake LDFLAGS="--static" || die
- else
- emake || die
- fi
-}
-
-src_install() {
- if use build; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}