summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2006-06-13 12:52:18 +0000
committerStefan Knoblich <stkn@gentoo.org>2006-06-13 12:52:18 +0000
commiteb9e9194268ef1e50125bc146571d1f8c2ffd0a1 (patch)
tree5aae35ff1932959ea40484f3980ab2358b67772a /net-misc/kiax/kiax-0.8.5_p1.ebuild
parentremove a couple of headers that weren't allowing it to build against qt 4.1.3 (diff)
downloadhistorical-eb9e9194268ef1e50125bc146571d1f8c2ffd0a1.tar.gz
historical-eb9e9194268ef1e50125bc146571d1f8c2ffd0a1.tar.bz2
historical-eb9e9194268ef1e50125bc146571d1f8c2ffd0a1.zip
Version bump, wrt bug #136099.
Package-Manager: portage-2.1
Diffstat (limited to 'net-misc/kiax/kiax-0.8.5_p1.ebuild')
-rw-r--r--net-misc/kiax/kiax-0.8.5_p1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/kiax/kiax-0.8.5_p1.ebuild b/net-misc/kiax/kiax-0.8.5_p1.ebuild
new file mode 100644
index 000000000000..e9b58726e3b0
--- /dev/null
+++ b/net-misc/kiax/kiax-0.8.5_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/kiax-0.8.5_p1.ebuild,v 1.1 2006/06/13 12:52:17 stkn Exp $
+
+inherit eutils kde-functions
+
+IUSE=""
+
+MY_P="${P/_p/}"
+
+DESCRIPTION="QT based IAX (Inter Asterisk eXchange) client"
+HOMEPAGE="http://kiax.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kiax/${MY_P}-src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="$(qt_min_version 3.2)"
+
+S="${WORKDIR}/${MY_P}-src"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/configure.patch
+
+ # add prefix for make install
+ sed -i -e "s:\(\$(DEST_PATH)\):\${INSTALL_ROOT}\1:" \
+ bin/Makefile
+
+ # fix icon/i18n prefix (bug #123839)
+ sed -i -e "s:/usr/local:/usr:g" \
+ src/src.pro.or
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ domenu kiax.desktop
+ dodoc README README.* CHANGELOG COPYING INSTALL INSTALL.*
+}