summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-09 21:45:42 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-09 21:45:42 +0000
commitedcbb43d75b6884788d5b80d3f9730eb86a4dd4b (patch)
treec4278fa95be9dd3efbd2342e2bbbfe76affcf33e /net-misc/jwhois/jwhois-4.0.ebuild
parentincrease boost dep to avoid missing boost_thread library (bug #209357) (diff)
downloadhistorical-edcbb43d75b6884788d5b80d3f9730eb86a4dd4b.tar.gz
historical-edcbb43d75b6884788d5b80d3f9730eb86a4dd4b.tar.bz2
historical-edcbb43d75b6884788d5b80d3f9730eb86a4dd4b.zip
Make sure we control optional libidn depend via USE=idn.
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'net-misc/jwhois/jwhois-4.0.ebuild')
-rw-r--r--net-misc/jwhois/jwhois-4.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-misc/jwhois/jwhois-4.0.ebuild b/net-misc/jwhois/jwhois-4.0.ebuild
index e13b77919b9e..5aef840b090e 100644
--- a/net-misc/jwhois/jwhois-4.0.ebuild
+++ b/net-misc/jwhois/jwhois-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jwhois/jwhois-4.0.ebuild,v 1.3 2008/02/05 11:09:39 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jwhois/jwhois-4.0.ebuild,v 1.4 2008/02/09 21:45:42 vapier Exp $
DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
HOMEPAGE="http://www.gnu.org/software/jwhois/"
@@ -9,15 +9,16 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="nls"
+IUSE="idn nls"
-DEPEND=""
+DEPEND="idn? ( net-dns/libidn )"
src_compile() {
econf \
--localstatedir=/var/cache \
--without-cache \
$(use_enable nls) \
+ $(use_with idn libidn) \
|| die "econf failed"
emake || die
}