summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-30 13:32:20 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-30 13:32:20 +0000
commitd37939635a358cac0ec6e3a93331a066a68cdd59 (patch)
tree60bc96817065345f960bf9002b23fbeb400d02de /net-mail
parentmask kxine for testing (diff)
downloadhistorical-d37939635a358cac0ec6e3a93331a066a68cdd59.tar.gz
historical-d37939635a358cac0ec6e3a93331a066a68cdd59.tar.bz2
historical-d37939635a358cac0ec6e3a93331a066a68cdd59.zip
Added a patch submitted by Vadim Berezniker backported from the devel
branch of vpopmail. Fixes some login issues. Closes bug #5746.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vpopmail/ChangeLog8
-rw-r--r--net-mail/vpopmail/files/vpopmail.diff88
-rw-r--r--net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild7
3 files changed, 101 insertions, 2 deletions
diff --git a/net-mail/vpopmail/ChangeLog b/net-mail/vpopmail/ChangeLog
index 51a11709423d..f3b87a9760f1 100644
--- a/net-mail/vpopmail/ChangeLog
+++ b/net-mail/vpopmail/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for net-mail/vpopmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.3 2002/07/26 11:09:41 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.4 2002/07/30 13:32:20 raker Exp $
*vpopmail-5.2.1 (24 Jul 2002)
+ 30 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ files/vpopmail.diff, vpopmail-5.2.1-r2.ebuild :
+
+ Added a patch submitted by Vadim Berezniker backported from the devel
+ branch of vpopmail. Fixes some login issues. Closes bug #5746.
+
26 Feb 2002; Nicholas Jones <carpaski@gentoo.org> vpopmail-5.2.1-r2 :
Revised -r1 submitted via consortium of Patrick Naubert and Maurizio
diff --git a/net-mail/vpopmail/files/vpopmail.diff b/net-mail/vpopmail/files/vpopmail.diff
new file mode 100644
index 000000000000..afa08c4b6354
--- /dev/null
+++ b/net-mail/vpopmail/files/vpopmail.diff
@@ -0,0 +1,88 @@
+--- vpopmail.c Sat May 18 02:25:49 2002
++++ vb/vpopmail.c Mon Jul 29 15:06:47 2002
+@@ -1012,51 +1012,45 @@
+ int buff_size;
+ {
+ int i;
+- int j;
+- int k;
+- int found;
+-
+- for( i=0,j=0,found=0; found==0 && j<buff_size && email[i]!=0; ++i,++j) {
+- for(k=0;ATCHARS[k]!=0;++k){
+- if ( email[i] == ATCHARS[k] ) {
+- found = 1;
+- continue;
+- }
+- }
+- if ( found == 0 ) {
+- user[j] = email[i];
+- }
+- }
+- user[j] = 0;
+- lowerit(user);
+-
++ int n;
++ int len;
++ char *at = NULL;
++
++ lowerit(email);
++
++ len = strlen(ATCHARS);
++ for(i=0;i<len; ++i ) if ((at=strchr(email,ATCHARS[i]))) break;
++
++ if ( at!=NULL ) {
++ n = at - email + 1;
++ if ( n > buff_size ) n = buff_size;
++ strncpy(user, email, n);
++ user[n-1] = 0;
++ strncpy(domain, ++at, buff_size);
++ domain[buff_size-1] = 0;
++ } else {
++ strncpy(user, email, buff_size);
++ user[buff_size-1] = 0;
+ domain[0] = 0;
+- if (email[i]!=0) {
+- for(j=0;j<buff_size&&email[i]!=0&&email[i]!='@';++i,++j) {
+- domain[j] = email[i];
+- }
+- domain[j] = 0;
+- lowerit(domain);
+- }
+-
+- if ( is_username_valid( user ) != 0 ) {
+- printf("user invalid %s\n", user);
+- return(-1);
+- }
++ }
+
+- if ( is_domain_valid( domain ) != 0 ) {
+- printf("domain invalid %s\n", domain);
+- return(-1);
+- }
++ if ( is_username_valid( user ) != 0 ) {
++ printf("user invalid %s\n", user);
++ return(-1);
++ }
+
+- /* if the domain is blank put in the default domain
+- * if it was configured with --enable-default-domain=something
+- */
+- vset_default_domain(domain);
++ if ( is_domain_valid( domain ) != 0 ) {
++ printf("domain invalid %s\n", domain);
++ return(-1);
++ }
+
+- vget_real_domain(domain, buff_size);
++ /* if the domain is blank put in the default domain
++ * if it was configured with --enable-default-domain=something
++ */
++ vset_default_domain(domain);
++ vget_real_domain(domain, buff_size);
+
+- return(0);
++ return(0);
+ }
+
+ /*
diff --git a/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild b/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild
index e3e0d8605a0c..f1632fb1a4c8 100644
--- a/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild
+++ b/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild,v 1.4 2002/07/26 13:31:34 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.2.1-r2.ebuild,v 1.5 2002/07/30 13:32:20 raker Exp $
# TODO: all ldap, sybase support
S=${WORKDIR}/${P}
@@ -63,6 +63,11 @@ src_unpack() {
# Thanks to Nicholas Jones (carpaski@gentoo.org)
patch < ${DISTDIR}/vpopmail-5.2.1-mysql.diff
fi
+
+ # Thanks to Vadim Berezniker (vadim@berezniker.com)
+ # This patch backports a bug fix from the devel version re: logons
+ patch -p1 < ${FILESDIR}/vpopmail.diff
+
}
src_compile() {